• 0

    posted a message on DrDamage - Official Thread
    German Client: DrDamage didn't work with my lvl 70 rogue.

    1. I've got 40 hit but the tooltip shows "Hit 98,14%" on lvl 73 mobs. That should be too much...

    2. When I select a PLAYER (not npc) DrDamage changes the Hit in the tooltip. But I didn't check "Hit calculation by current target". This doesn't happen with my priest.

    3. When I select a low level player DrDamage shows "Hit: 100%"... I thought 99% is max?^^

    With my priest it works fine... =/
    Posted in: General AddOns
  • 0

    posted a message on Recount
    Quote from Elsia »

    Does the problem persist if you hide the recount window during combat?


    I have the same problem with stuttering and low fps. When I close the window it disappears. When I open it again it reappears. =/
    Posted in: General AddOns
  • 0

    posted a message on Recount
    Quote from Elsia »

    What you request is essentially not checking Keep Boss Fights Only. Then you will see trash segments.


    Yes but I can't merge these trash segements... I can only see each trash group separately. And this is not always useful =/
    Posted in: General AddOns
  • 0

    posted a message on Recount
    German Client:

    If I turn on "Nur Bosssegmente behalten" (Only boss segments retain) the whole trash (tested in hyjal) is added to the damagemeter of the boss. =/
    And there is another thing... With this option I can't see the Damage/Heal of the trashmobs. And without this option I had to reset Recount to see a sumary of the whole trashmobs.
    Could you merge the whole Heal/Damage of all trashmobs to a category named "trash" and put it between the data of the bosses?

    Example:
    trashmobs
    boss1
    trashmobs
    boss2
    trashmobs
    ...

    And another thing: At Archimonde I had once a low frame rating till I closed the Recount window. The next fights it worked fine.

    Here is also a bug:
    "Recount-70066\\Recount_Modes.lua:298: attempt to index field '?' (a nil value)\nRecount-70066\\GUI_Main.lua:572: in function `UpdateDetailData'\nRecount-70066\\GUI_Main.lua:890: in function <Interface\\AddOns\\Recount\\GUI_Main.lua:697>\n(tail call): ?:\n<in C code>: ?\n<string>:\"safecall Dispatcher[2]\":9: in function <[string \"safecall Dispatcher[2]\"]:5>\n(tail call): ?:\nAceTimer-3.0\\AceTimer-3.0.lua:140: in function <...ddOns\\BetterInbox\\libs\\AceTimer-3.0\\AceTimer-3.0.lua:114>\n\n ---"
    Posted in: General AddOns
  • 0

    posted a message on Recount
    "Recount-69336\\healbuffs.lua:170: table index is nil\nRecount-69336\\Tracker.lua:420: in function `parsefunc'\nRecount-69336\\Tracker.lua:556: in function `?'\nCallbackHandler-1.0\\CallbackHandler-1.0.lua:146: in function <...ibs\\Ace3\\CallbackHandler-1.0\\CallbackHandler-1.0.lua:146>\n<string>:\"safecall Dispatcher[13]\":4: in function <[string \"safecall Dispatcher[13]\"]:4>\n<in C code>: ?\n<string>:\"safecall Dispatcher[13]\":13: in function `?'\nCallbackHandler-1.0\\CallbackHandler-1.0.lua:91: in function `Fire'\nAceEvent-3.0\\AceEvent-3.0.lua:70: in function <...ddOns\\BetterInbox\\libs\\AceEvent-3.0\\AceEvent-3.0.lua:69>\n\n ---",
    Posted in: General AddOns
  • 0

    posted a message on Recount
    German Client:

    POM ("Prayer of Mending" in German "Gebet der Besserung")is not assigned to me or other players. It is assigned to a "Player" named "NoOne". But other "problematic" spells seems to work. =/

    Here are also some Error-Messages:
    "Recount-68880\\Recount_Modes.lua:300: attempt to index local 'data' (a nil value)\nRecount-68880\\GUI_Main.lua:606: in function `DetailWindowPrevMode'\nRecount-68880\\GUI_Detail.lua:1424: in function <Interface\\AddOns\\Recount\\GUI_Detail.lua:1424>\n\n ---",
    
    "Recount-68880\\Recount_Modes.lua:300: attempt to index local 'data' (a nil value)\nRecount-68880\\GUI_Main.lua:593: in function `DetailWindowNextMode'\nRecount-68880\\GUI_Detail.lua:1432: in function <Interface\\AddOns\\Recount\\GUI_Detail.lua:1432>\n\n ---",
    
    "FuBar_RecountFu-3.4\\RecountFu_Options.lua:358: bad argument #1 to 'pairs' (table expected, got nil)\nFuBar_RecountFu-3.4\\RecountFu_Options.lua:358: in function `func'\nDewdrop-2.0-56529 (BugSack):721: in function <...face\\AddOns\\BugSack\\Libs\\Dewdrop-2.0\\Dewdrop-2.0.lua:660>\n\n ---",
    
    "AceConfigCmd-3.0\\AceConfigCmd-3.0.lua:660: AceConfigCmd-3.0: /recount syncdesc: unknown options table item type 'description'\nAceConfigCmd-3.0\\AceConfigCmd-3.0.lua:55: in function <...\\AceConfig-3.0\\AceConfigCmd-3.0\\AceConfigCmd-3.0.lua:53>\nAceConfigCmd-3.0\\AceConfigCmd-3.0.lua:660: in function <...\\AceConfig-3.0\\AceConfigCmd-3.0\\AceConfigCmd-3.0.lua:299>\n(tail call): ?:\nAceConfigCmd-3.0\\AceConfigCmd-3.0.lua:693: in function `HandleCommand'\nAceConfigCmd-3.0\\AceConfigCmd-3.0.lua:712: in function `?'\nInterface\\FrameXML\\ChatFrame.lua:2995: in function <Interface\\FrameXML\\ChatFrame.lua:2957>:\n<in C code>: ?\n<in C code>: in function `ChatEdit_ParseText'\nInterface\\FrameXML\\ChatFrame.lua:2724: in function `ChatEdit_SendText':\nInterface\\FrameXML\\ChatFrame.lua:2745: in function `ChatEdit_OnEnterPressed':\n<string>:\"*:OnEnterPressed\":1: in function <[string \"*:OnEnterPressed\"]:1>\n\n ---",
    
    "AceConfigCmd-3.0\\AceConfigCmd-3.0.lua:660: AceConfigCmd-3.0: /recount datadesc: unknown options table item type 'description'\nAceConfigCmd-3.0\\AceConfigCmd-3.0.lua:55: in function <...\\AceConfig-3.0\\AceConfigCmd-3.0\\AceConfigCmd-3.0.lua:53>\nAceConfigCmd-3.0\\AceConfigCmd-3.0.lua:660: in function <...\\AceConfig-3.0\\AceConfigCmd-3.0\\AceConfigCmd-3.0.lua:299>\n(tail call): ?:\nAceConfigCmd-3.0\\AceConfigCmd-3.0.lua:693: in function `HandleCommand'\nAceConfigCmd-3.0\\AceConfigCmd-3.0.lua:712: in function `?'\nInterface\\FrameXML\\ChatFrame.lua:2995: in function <Interface\\FrameXML\\ChatFrame.lua:2957>:\n<in C code>: ?\n<in C code>: in function `ChatEdit_ParseText'\nInterface\\FrameXML\\ChatFrame.lua:2724: in function `ChatEdit_SendText':\nInterface\\FrameXML\\ChatFrame.lua:2745: in function `ChatEdit_OnEnterPressed':\n<string>:\"*:OnEnterPressed\":1: in function <[string \"*:OnEnterPressed\"]:1>\n\n ---",
    
    "AceConfigCmd-3.0\\AceConfigCmd-3.0.lua:660: AceConfigCmd-3.0: /recount windesc: unknown options table item type 'description'\nAceConfigCmd-3.0\\AceConfigCmd-3.0.lua:55: in function <...\\AceConfig-3.0\\AceConfigCmd-3.0\\AceConfigCmd-3.0.lua:53>\nAceConfigCmd-3.0\\AceConfigCmd-3.0.lua:660: in function <...\\AceConfig-3.0\\AceConfigCmd-3.0\\AceConfigCmd-3.0.lua:299>\n(tail call): ?:\nAceConfigCmd-3.0\\AceConfigCmd-3.0.lua:693: in function `HandleCommand'\nAceConfigCmd-3.0\\AceConfigCmd-3.0.lua:712: in function `?'\nInterface\\FrameXML\\ChatFrame.lua:2995: in function <Interface\\FrameXML\\ChatFrame.lua:2957>:\n<in C code>: ?\n<in C code>: in function `ChatEdit_ParseText'\nInterface\\FrameXML\\ChatFrame.lua:2724: in function `ChatEdit_SendText':\nInterface\\FrameXML\\ChatFrame.lua:2745: in function `ChatEdit_OnEnterPressed':\n<string>:\"*:OnEnterPressed\":1: in function <[string \"*:OnEnterPressed\"]:1>\n\n ---",
    Posted in: General AddOns
  • 0

    posted a message on Cartographer_QuestObjectives - Official Thread
    German Client: The "notes" are saved with the english zone name and the "objectives" are saved with the german zone name. When I share my database with someone he only gets the "objectives" when the english zone name is different to the german zone name. Does anyone exist who can fix this? =)
    Posted in: Map/Minimap AddOns
  • 0

    posted a message on Cartographer: Quest Objectives -- share your database here!
    Ok I was wrong. The "notes" are saved with the english zone name and the "objectives" are saved with the german zone name. When I share my database with someone he only gets the "objectives" when the english zone name is different to the german zone name. Does anyone exist who can fix this? =)

    Edit: I try posting this in the official thread
    Posted in: Map/Minimap AddOns
  • 0

    posted a message on Cartographer: Quest Objectives -- share your database here!
    I think there is a bug in the sharing feature between the german client. Normally Cartographer Quest Objectives save the german objectives with the english zone name. But the objectives you get from other players are saved with the german zone name. You can't see these objectives on the map.
    In the posted database of Mars are many of this problems. I think there is a lot of needless data. I think I posted this problem months ago, but the author didn't change something.

    Here is also my german database:
    Posted in: Map/Minimap AddOns
  • 0

    posted a message on RatingBuster
    The German localisation needs an update:

    Increases healing done by up to 382 and damage done by up to 128 for all magical spells and effects.

    in german: Erh\195\182ht durch s\195\164mtliche Zauber und magische Effekte verursachte Heilung um bis zu 382 und den verursachten Schaden um bis zu 128.
    Posted in: General AddOns
  • 0

    posted a message on VisualHeal - Official Thread
    I don't know what you have changed after my post, but now I see only the bar when I heal myself in bg. =/
    Posted in: General AddOns
  • 0

    posted a message on VisualHeal - Official Thread
    VH 5.49485 (German Client) only works for players in your own group in AV. If you heal another target you couldn't see VH =(
    Posted in: General AddOns
  • 0

    posted a message on VisualHeal - Official Thread
    I've got an error message: "HealComm-2.0-46080 (VisualHeal):355: attempt to perform arithmetic on local 'endTime' (a nil value)\n\n ---"
    Posted in: General AddOns
  • 0

    posted a message on VisualHeal - Official Thread
    This is not as simple as it sounds, since a heal is not an "atomic operation". The green bar changes everytime the target's health change - that's just the way it is. An event is fired by the game engine when this happens, but there is no way to tell what caused the health change, so the bar must be updated to reflect the new health. In this process the HealComm library is consulted to determine whether any heals are incoming, and if so, these are rendered too. When the heal exactly lands cannot be predicted, you can only get an estimate by calling an API function, and therefore the health change may come before or after the heal is known to land (because this "known" time is inaccurate). I've been annoyed by this, and one of the latest modifications is that HealComm measures the client-server roundtrip latency everytime a spellcast is done on the client. This value is then used to compensate the "known" landing time of all heals incoming from others. Of course this is still an estimate, and it will remain impossible to exactly predict when the heal will land, and therefore it will remain impossible to let the two bars seemlessly update when heals land. However, there is a constant multiplier to the measures time, that i've been tweaking to find the visually most pleasing compensation. If you want to play with it, go to line 299 of the HealComm-2.0.lua file and change the second constant:

    Latency = 0.5 * Latency + 0.65 * currentLatency

    The higher it is, the later the heals will be "known" to land.


    Between disappearing the grey bar and the arriving healing is a relatively constant Time gap of a half second I think (I am not a stop clock =) ). If I find the time, I will try some other values.



    Messages are only sent when heals are cast (1 message per heal), or if someone requests versions info. In theory it is possible to do the version inqury during login, and then alert the user if some one else are using a newer version, but i don't like the sound of that. It's rather annoying, and i don't want to annoy users - but i'll consider the options and maybe come up with something that isn't annoying. However, there are no incompatibilities between versions of VisualHeal on different clients since there has been no significant changes to the protocol (only a slight change to the semantics, but this is invisible to all versions of the client since the prefix used in communication was changed too, and separate handlers exists for the two prefixes in use). I've no idea what caused this problem, but i've recently (weeks ago) fixed a bug that could be causing what you're describing in some circumstances. To fix that, only you need to upgrade to the latest version, since the info sent out on the communication channel is, and has always been correct in all released clients.


    Before I start WoW I use first the WoWAceUpdater. So it should be always the current version. I try to force my guild members to updating and look if the error still arise.
    Posted in: General AddOns
  • To post a comment, please or register a new account.