• 0

    posted a message on WoW UI Updater (Win/OSX/Linux, supports multiple sites), 1.6 thread
    Quote from lejordet »

    Thanks, will try that in the next version (I've actually heard of some other people with problems in Ubuntu - might be the same reason :D


    Thanks for the fix, but you fixed just one of the two places that used to give that error - there's still a call to "map(int, platform.python_version().split("."))" on line 78, when you check for Python version 2.5, that gives the same error.

    (Sorry for the long response time, and thanks for this great tool)

    BTW, any plans for adding git support? I have at least one addon (TourGuide) I upgrade with git, it would be nice to do upgrade it along with the other hundred or so I handle with WUU.
    Posted in: Updaters
  • 0

    posted a message on WoW UI Updater (Win/OSX/Linux, supports multiple sites), 1.6 thread
    I'm having a little trouble with WUU here (Ubuntu 8.04 Beta). The function platform.python_version() returns '2.5.2a0', which crashes your version checks in WUU.py .
    It can be solved by restricting the array range in the version comparison, for example, change "platform.python_version().split(".")" to "platform.python_version().split(".")[:2]".
    Posted in: Updaters
  • To post a comment, please or register a new account.