• 0

    posted a message on JasonQuest - Official Thread
    Try using the WoWAceUpdater and updating JasonQuest with forced embeds. The issue you're seeing is related to an old version of embeds.

    Alternatively, you can grab JasonQuest from here: http://www.wowinterface.com/downloads/info9561-JasonQuest.html as I've just updated the zip with the most recent embeds.
    Posted in: General AddOns
  • 0

    posted a message on JasonQuest - Official Thread
    JasonQuest v1.04.72005:
    - Fixed semi-rare Comm.lua:3 bug

    r73115
    - Fixed not-so-rare Comm.lua:40 bug

    r73320
    - Hopefully fixed objective completion for non numbered objectives (i.e. Energize
    a Crystal Ward for Arm the Wards!)
    - Various cleanup
    - Reduced ping frequency
    Posted in: General AddOns
  • 0

    posted a message on Baggins_Search
    http://www.wowace.com/wiki/Baggins_Search

    r73047:
    -Changed strfind to plain search to avoid errors when typing regex chars
    -Updated toc
    Posted in: General AddOns
  • 0

    posted a message on JasonQuest - Official Thread
    JasonQuest v1.04.71815
    + Added version notifications on-frame
    + Modified playersOnQuest functions to ignore debug mode
    + Modified playersOnQuest indicator to be colored a light blue when you're one of the players on the quest
    Posted in: General AddOns
  • 0

    posted a message on JasonQuest - Official Thread
    JasonQuest v1.04.70752
    - Modified the way LightHeaded_JasonQuest is supported

    LightHeaded_JasonQuest v1.04.70754
    - Support for LightHeaded r230
    - Requires JasonQuest v1.04.70752
    - LOD
    - There is now a tab on the main JasonQuest frame to show/hide LH. It still forces a detach however, as that's really the only way this works.
    Posted in: General AddOns
  • 0

    posted a message on JasonQuest - Official Thread
    Thanks, I'll take care of it. I don't use LightHeaded (I prefer 2 monitors) so I wasn't aware.
    Posted in: General AddOns
  • 0

    posted a message on JasonQuest - Official Thread
    JasonQuest v1.04.70617:
    - Added support for QuestLinks
    - Added Dewdrop to Embeds.xml
    - Disabled use in raids do to unreliable results

    http://files.wowace.com/JasonQuest/JasonQuest.zip
    Posted in: General AddOns
  • 0

    posted a message on JasonQuest - Official Thread
    Part of the problem is that JasonQuest hasn't been updated in a while, so the WoWAceUpdater isn't touching them and updating the libs. Force an update with embeds and it'll grab the most recent libs for JQuest. This is what I've been doing and I'm not experiencing any issues with ~70 addons.

    Anyway, as to the question to the unwieldiness of my code, I feel that some 'splainin may help. Unfortunately because of the way Blizzard sends those events, I have very specifically crafted the QUEST_LOG_UPDATE code.

    There are a few issues related to this event...

    Expanding / Collapsing quests changes quests available through the Blizzard API, and it makes the QUEST_LOG_UPDATE event unreliable. So my workaround was to unregister the event when looking at the log (since I have to expand them all out first to make sure I get them all) and then re-register afterwards. Of course then I ran into a strange issue where AceEvent would not always properly re-register the event if the call to re-register came from within the event function (even when that call was a call to another function that would call the AceEvent function). It would say it did, but in fact would not trigger the function. So my workaround for that was to set up a recurring function that would register it, completely separate from the QUEST_LOG_UPDATE event functions.

    Moving forward, I may rewrite the event code in JQuest to just not use AceEvent altogether. I haven't had time to look at Ace3 yet though so that may be an option as well. I didn't even know it was out there and being used yet!
    Posted in: General AddOns
  • 0

    posted a message on JasonQuest - Official Thread
    I'll do some testing throughout the week and post back here.
    Posted in: General AddOns
  • 0

    posted a message on JasonQuest - Official Thread
    I would suggest updating all Ace mods to make sure your Ace embeds are all up to date. I ran into the exact issue you're having and that cleared it up for me.
    Posted in: General AddOns
  • 0

    posted a message on JasonQuest - Official Thread
    That's what I did when my Ace install got messed up. I kept getting AceComm errors so I just used WowAceUpdater and updated everything. Your mileage may vary.
    Posted in: General AddOns
  • 0

    posted a message on JasonQuest - Official Thread
    I haven't been able to reproduce this error. It looks like AceComm on your installation is screwed though.

    Try running just JQuest and see if you still get the error. If not, start enabling the other addons in small batches until you start getting the error again.

    Let me know if you're able to narrow it down and I'll take a look for a workaround.
    Posted in: General AddOns
  • 0

    posted a message on JasonQuest - Official Thread
    That's an interesting error. I haven't run across it and I don't see how watchLine can be nil at that point. How often does it happen and is there something specific you do before it happens?
    Posted in: General AddOns
  • 0

    posted a message on JasonQuest - Official Thread
    Without JasonQuestFu installed I don't recall how I handle the minimap button. I only just started playing again so I'll have to take a closer look.
    Posted in: General AddOns
  • 0

    posted a message on JasonQuest - Official Thread
    If you right-click the icon you can hide it by going to Fubar Options > Hide plugin. You can also remove it completely by disabling the Fubar - JasonQuest addon.
    Posted in: General AddOns
  • To post a comment, please or register a new account.