• 0

    posted a message on Acolyte - Warlock AddOn
    What is your stance on the users adding code to it? I've made a few changes to my personal files, but everytime I run the wowace updater, its gets overwritten. Is there a way I can contribute to the "official" releases of the addon?

    Basically, I just added a mount summoner for the dreadsteed and I am working on a fubar plugin, but I need to learn that framework more solidly before I can impliment a working version of that. I realize it has the gui from /aco, but thinking a fubar button to bring up that menu would be helpful.
    Posted in: General AddOns
  • 0

    posted a message on Acolyte - Warlock AddOn
    I have isolated the problem, and I am sorry, but this will probably confuse you more.

    I deleted everying in my acolyte1 folder except the libs folder and acolyte.toc.

    Inside the libs folder I meticulously removed then added each folder until acolyte2 was working. The following 3 items in the libs folder I kept:

    AceDebug-2.0
    AceLibrary
    AceOO-2.0

    so, in my acolyte1 folder, all I have in there is acolyte.toc and my libs folder, inside the libs folder I have those 3 libraries. Acolyte2 works fine with those changes. I have no idea why since acolyte2 uses those 3 libraries itself. I was going to play around with the acolyte2.toc file, but thought it best if you did it instead.


    I know that doesn't make a whole lot of sense, but maybe narrowing that problem down will give you a better idea of what is causing the bug.

    Please keep in mind that I usually have problems that are specific to me that makes veterans of the software say "wow, I've never seen that error before". You should have seen the my first attempt at Gentoo.
    Posted in: General AddOns
  • 0

    posted a message on Acolyte - Warlock AddOn
    I have went over the code myself and couldn't find any reason why. Although, I dont know lua that well, (I just haven't sat down and learned it) I am a J2SE dev. I also cleaned out my WTF folder, and that didnt fix anything. Here is the screenshots.

    With acolyte1 disabled (character loading screen and in-game)

    http://img340.imageshack.us/img340/8938/acolyte1disabledsb2.jpg
    http://img515.imageshack.us/img515/5332/ingameaco1disabledef4.jpg


    Notice in the in game screenshot, there is a "type /help for a list of a few commands" in the chatlog. That is when I tried /acolyte2

    And here is the screenshots of when acolyte1 is enabled.

    http://img340.imageshack.us/img340/8862/acolyteenabledlf1.jpg
    http://img515.imageshack.us/img515/8272/ingameaco1enabledua4.jpg

    It isnt a big deal, as I jsut move acolyte1 off the screen and lock it, but that is the issue I am having, and I can live with it. I jsut thought you may want to know about it. Also, possibility to have a fubar plugin for it?

    I hope those screenshots help, if more info is needed, jsut post back.
    Posted in: General AddOns
  • 0

    posted a message on Acolyte - Warlock AddOn
    It works well, but appearently I need acolyte1 enabled in order to get acolye2 to work. I don't know if this is inteded, but other than that, it is perfect.
    Posted in: General AddOns
  • 0

    posted a message on Acolyte - Warlock AddOn
    On my addons tab at the char slection screen, acolyte2 shows up and is checked, but it is as if it isn't loaded when i log in. What is the slash command to bring it up? /acolyte /aco /acolyte2 /aco2 all dont work and there is no fubar plugin. I am just trying to see if it loads up and installed correctly.

    Once again, thanks for putting in the time and effort for writing this.
    Posted in: General AddOns
  • 0

    posted a message on Acolyte - Warlock AddOn
    Quote from GitS »

    I'll may recode Acolyte. :)


    I am seeing updates for Acolyte coming out on the wowaceupdater, so I will post issues I have been having. I like this addon a lot, but there are a few tweaks/fixes that should be made. I would make them myself, but I don't know lua well enough, nor do I know the wowace api that well, and would prefer not to jump right into it by tweaking this code. That being said, I only ahvea couple issues:

    1. Non-working buttons. I see the tooltip for "A click let you mount up" and the image is there, but the mount buttons doesn't do anything. I have both summon felsteed and summon dreadsteed spells. The button with a soul shard count doesn't cast drain soul. I would like it to use that button to cast drain soul rank 1.

    2. Selecting buffs - This is fine except for it is missing demon armor. I have both a 60 and a 70 lock, For the 70 lock, only fel armor shows up. For the 60 lock, demon armor shows up. My guess is that Acolyte overrides demon armor when the warlock learns fel armor at level 62. Granted, I very rarely use demon armor, but it would be nice to have both fel armor and demon armor show up on the drop down.

    3. In combat interaction - I cannot interact with the buttons in combat. This is annoying as I will often forget to do something like put on a soulstone or re-apply fel armor during a fight. I will also sometime be battle-rezzed (rarely) and need to get my pet out during a boss fight. It would jsut be easier to do this from acolyte than to have to go to my spellbook and find the spell.

    4. possible spell additions - Add the option to create a soul-well, that is jsut one less button on my actin bars to be filled up. An added button for soul shatter and/or banish would be great also.

    A fix with these problems would be great. The non-interaction while in combat is the most annoying thing for me.
    Posted in: General AddOns
  • To post a comment, please or register a new account.