• 0

    posted a message on PitBull 4.0
    Hello Shefki and gang,

    Amazing addon!

    2 Questions:
    1)
    Lately, i've been on a mission to try to find a setting that lets me adjust incoming health on the frames (Color, Placement, enable/disable, etc). To be more clear, if I cas't renew on myself (or any frame for that matter), a hot tick (+1275) in green shows up in my player frame (or the frame to which i cast to)... please tell me that's adjustable?

    It's overwhelmingly distracting in raids to see green numbers from aoe heals, hots, etc., flying around on my frames! I'll be in heaven if that's adjustable, or even the ability to disable :D

    I feel like I shut it off in PB3, but it's been so long I couldn't even say with much certainty.

    2)
    Is there a way to shut off auto-switching to targets that cause you damage?

    Thanks for all your dedication to your addons and the addon community!
    -Stoobs
    Posted in: Unit Frames
  • 0

    posted a message on PitBull 4.0
    I can't seem to get range finder working for neutral targets...

    As an ele shaman i've tried:
    class abilities: seems about 5 yards and opacity starts to fade off (come into range)
    lightning bolt: about the same really.

    red targets work as expected... anything i can do to change this?
    -stoobs
    Posted in: Unit Frames
  • 0

    posted a message on PitBull 4.0
    I've set the party frames to show while in 5-man party or 5-man raid (so I can use party frames instead of raid frames during arenas). When in a party all works as intended, but when I convert to a raid with five or less (including myself) it adds myself to the party frames


    so you have a set of party frames (which happens to include you) and a set of 5man raid frames when you're in a 5man raid?

    (so I can use party frames instead of raid frames during arenas


    Wouldn't party frames be the natural way for arena? You join a party and queue as a group correct?

    I'm confuzzled as to what you're tryin to do ultimately...
    Posted in: Unit Frames
  • 0

    posted a message on PitBull 4.0
    Class abilities option is working as intended for shaman via PitBull4-v4.0.0-beta5-16-g8e38c70

    Can't thank you enough for helping me Shefki! Let's hope you never hear from me again :D
    Posted in: Unit Frames
  • 0

    posted a message on PitBull 4.0
    Quote from Shefki »
    Ok I identified a typo that was breaking the long range check for class abilities for enemy targets for Shaman and Warriors. If you can test the latest alpha build the class abilities should work properly for you now.


    Will do. Let me get some rest and what not, and i'll have a crack at it tomorrow.

    Quote from Shefki »
    Right. This is just the way these tests work. We're limited to what Blizzard makes available. I can probably improve this to a certain extent but the helpful spell test is intended to be used on raid/party frames. The custom spell/item tests are mostly just there for unique situations where someone may want that behavior.

    I can differentiate between invalid target and out of range. But it's unclear what the behavior should be. Should it be out of range or should it be to just use the in range opacity if the target is invalid for the spell. I'm inclined to think that it should be the way it is now since you're asking if you can do those specific things and if you can't well you probably don't want it shown fully.


    I suspect they're working as intended. What seemed odd is that i could get a correct range for a helpful spell and a correct range for a harmful spell, but couldn't get an auto-sensing correct range. This may be due to the typo. Again, I'll get ya some feed back asap.

    Thanks alot for your attention.
    Posted in: Unit Frames
  • 0

    posted a message on PitBull 4.0
    maybe these photos can better explain: 5% opacity - class ablilities chosen

    1 - nothing targeted: just a pic to test against
    2 - something targeted: action bar out of range / target frame out of range
    3 - scooted forward a little: action bar IN range / target frame out of range
    4 - scooted forward some more: action bar IN range, PURGE(C)[30yd spell] in range / target out of range
    5 - scooted forward: target finally in range
    6 - tested 40yd range option labeled "helpful spells": out of range
    7 - on top of target: still out of range

    Hopefully that helps you see where i'm coming from. The pauses between screens were significant enough to catch any fade times.

    1) http://i694.photobucket.com/albums/vv303/stoobinator/1.jpg
    2) http://i694.photobucket.com/albums/vv303/stoobinator/2.jpg
    3) http://i694.photobucket.com/albums/vv303/stoobinator/3.jpg
    4) http://i694.photobucket.com/albums/vv303/stoobinator/4.jpg
    5) http://i694.photobucket.com/albums/vv303/stoobinator/5.jpg
    6) http://i694.photobucket.com/albums/vv303/stoobinator/6.jpg
    7) http://i694.photobucket.com/albums/vv303/stoobinator/7.jpg

    I was trying Lesser Healing Wave as the custom spell that wouldn't work. Trying Lightning Bolt got it to work. *shrug*

    Apparently photobucket sucks. If you'd like the original pics send me a pm and i can email them or something.

    Last edit:
    Here's what i've figured out, feel free to advise. Class abilities option is identical to 28yd option "follow".

    custom spell:
    If a helpful spell is chosen only friendly targets will come into range at the appropriate yardage, all others stay opaque.
    If a harmful spell is chosen only enemy targets will come into range at the appropriate yardage, all others stay opaque.
    Testing was based on Lesser Healing Wave and Lightning Bolt.
    Posted in: Unit Frames
  • 0

    posted a message on PitBull 4.0
    I don't think i have it in me to thumb through 126 pages, so my appologies if this has been asked/addressed.

    Range finder doesn't seem to work unless you use either the first or last options (i think "class specific spells" or "full view - 100yd"). The problem i'm having is that as an elemental/resto shaman the first option is off by 5yds or so and everything is faded even though in range. I can't get custom spell to work either.

    I'm just wondering if i should be patient because this still needs to be worked on, or take it a step further and submit a ticket.

    Thanks for your time all...
    Stoobs

    p.s. Great job to everyone who has contributed toward this addon. Awesome work guys...
    Posted in: Unit Frames
  • To post a comment, please or register a new account.