• 0

    posted a message on moveFrames
    I commented out lines 79 and 80 of core.lua and the errors have stopped. No guarantees that it will work correctly. Hopefully the author will see this thread and properly correct the problem as it appears to be a very nice addon.

    Here's what the corrections look like:

    -- Hook the SetCenterFrame and SetLeftFrame so we can throw skipSetPoint.
    -- self:Hook("MovePanelToCenter", "MovePanelToCenter", true)
    -- self:Hook("MovePanelToLeft", "MovePanelToLeft", true)
    Posted in: General AddOns
  • 0

    posted a message on moveFrames
    I'm getting the following error:

    [2007/05/22 14:34:55-717-x1]: moveFrames-1.0\core.lua:79: AceHook-2.1: Attempt to hook a non-existant function "MovePanelToCenter"
    <in C code>: ?
    AceEvent-2.0-36174 (Ace2):2146: in function <Interface\AddOns\Ace2\AceEvent-2.0\AceEvent-2.0.lua:2109>
    AceEvent-2.0-36174 (Ace2):2342: in function <Interface\AddOns\Ace2\AceEvent-2.0\AceEvent-2.0.lua:2283>
    Posted in: General AddOns
  • 0

    posted a message on FuBar - QuestsFu
    Quote from Kemayo »

    Quote from Snarfle »

    The questgiver information is not showing up anywhere. I have the option checked and I can see the data in the data file, but it's not displayed anywhere in the quest pane. It did at one time, but with one of the patches over the past few weeks it stopped.


    Strange -- I'll try to reproduce that. (I logged in over the weekend to check, and it seemed to be working then.)


    Here's some of the data from my saved variables. It appears to be correct and updating for all my chars. Just no display in game.

    BTW, please don't take my posts as any kind of negative comment about the work you have done. This addon is very nice and has made the game more enjoyable to play. I really appreciate the effort you have put into making the game better.

    ["Snarflock - Korgath"] = {
    ["questgivers"] = {
    ["Trouble at Auchindoun"] = "Spymistress Mehlisah Highcrown in Shattrath City (50,45)",
    ["The Book of Fel Names"] = "Altruis the Sufferer in Nagrand (27,43)",
    ["Seer Udalo"] = "Akama in Shadowmoon Valley (58,48)",
    ["The Cipher of Damnation"] = "Oronok Torn-heart in Shadowmoon Valley (53,23)",
    ["The Cipher of Damnation - Borak's Charge"] = "Borak, Son of Oronok in Shadowmoon Valley (47,57)",
    ["Zuluhed the Whacked"] = "Karynaku in Shadowmoon Valley (69,61)",
    ["The Cipher of Damnation - The Third Fragment Recovered"] = "Borak, Son of Oronok in Shadowmoon Valley (47,57)",
    ["Ally of the Netherwing"] = "Karynaku in Shadowmoon Valley (69,61)",
    Posted in: FuBar AddOns
  • 0

    posted a message on FuBar - QuestsFu
    The questgiver information is not showing up anywhere. I have the option checked and I can see the data in the data file, but it's not displayed anywhere in the quest pane. It did at one time, but with one of the patches over the past few weeks it stopped.

    In addition the latest build is giving me these errors...and it's impossible to open the configuration menu.

    [2007/05/09 18:46:55-571-x5]: FuBarPlugin-2.0-34599:1080: Dewdrop-2.0: args.Sound.args.progress.args.toggle: "type" must be a string.
    Ace2\AceLibrary\AceLibrary.lua:96: in function `error'
    Dewdrop-2.0-34665 (DewdropLib):2771: in function `Register'
    FuBarPlugin-2.0-34599:1080: in function `OpenMenu'
    FuBarPlugin-2.0-34599:951: in function <...\FuBarPlugin-2.0\FuBarPlugin-2.0\FuBarPlugin-2.0.lua:949>
    FuBar-33424\FuBar.lua:1115: in function <Interface\AddOns\FuBar\FuBar.lua:1109>
    Tablet-2.0-33319 (TabletLib):2498: in function <Interface\AddOns\TabletLib\Tablet-2.0\Tablet-2.0.lua:2496>
    Posted in: FuBar AddOns
  • 0

    posted a message on FuBar - QuestsFu
    Is anyone supporting this addon? Just wondering if the remember questgiver function was being looked at?
    Posted in: FuBar AddOns
  • 0

    posted a message on FuBar - QuestsFu
    Still can't get remember questgiver to work. Anyone having issues?
    Posted in: FuBar AddOns
  • 0

    posted a message on FuBar_WhisperFu
    Problem still continues. Am I the only person using this addon...or having this issue?
    Posted in: FuBar AddOns
  • 0

    posted a message on FuBar_WhisperFu
    Latest patch causes WhisperFU to stop recording whispers. Going back to previous version corrects the issue.
    Posted in: FuBar AddOns
  • 0

    posted a message on Converting from Internal to External Libs
    Thank you very much. The procedure went just fine and the patient is doing great :)
    Posted in: General AddOns
  • 0

    posted a message on Converting from Internal to External Libs
    Right now all of my Ace addons have a copy of the Ace Libs in their folder. I assume there's a way to just have a single copy of the Ace libs in my addon folder and have them all use that copy rather than individually stored versions.

    Can anyone give me a quick way of converting over to that method?

    How do the addons know where he Ace libs are stored? Do they look at the "root" of the addon folder first and then their individual folder or vice versa?

    I'm interested in doing this because of recent lib incompatibilities. I figure if I have one copy of the libs it'll be easier to keep track of and easier to keep updated.

    Thanks in advance.
    Posted in: General AddOns
  • 0

    posted a message on all wowace mods not working
    I had the same problem today. I use externals and had version check set to false.

    I was able to fix the issue by going to each of the addons that got updated this morning and replacing the Ace Event library in them.
    The addons that were updated were:

    Prat, Periodic Table-3.0, FuBar_PerformanceFu, BigWigs and FuBar.

    A couple of those don't have Ace Event included. My best guess is it was the update to FuBar itself that caused the issue.

    This even caused non Ace addons like Bongos to not load.

    Posted in: General AddOns
  • 0

    posted a message on all wowace mods not working
    Thanks Lord,

    Anyone have a more elegant solution to fix the mess the latest update has caused?

    The problem does appear to be Ace Event file. I did basically what the previous posted stated on all of the addon folders that had been updated since 4/19.

    I would suggest not using the WowAce updater.
    Posted in: General AddOns
  • 0

    posted a message on FuBar - QuestsFu
    Quote from Cordelia »

    Quote from Snarfle »

    So, has anyone got the remember questgiver functionality working?


    It is working fine, if you open the quest log in QuestFu's own tracker, you'll see a line like "Given by" followed by the quest giver's name and location (with coordiantes) in the next line.


    I know where it is supposed to be...it's not showing up. Something became borked over the last few versions and it's not working. Am I missing a library or something possibly? I checked and the addon is saving the locs of the questgivers in the saved variables file...they're just not making it to the quest frames...either Blizzards or the Addon's own.
    I tried deleting the addon and reinstalling and still no luck.
    Must be a conflict of some sort.
    Posted in: FuBar AddOns
  • 0

    posted a message on FuBar - QuestsFu
    So, has anyone got the remember questgiver functionality working?
    Posted in: FuBar AddOns
  • 0

    posted a message on Chronometer (Ace2'ed AceTimer)
    It happened again when I was mounting my epic mount (flying)

    [2007/04/16 22:11:26-318-x1]: Chronometer-0.10\Core\Chronometer.lua:726: bad argument #1 to 'gmatch' (string expected, got nil)
    <in C code>: ?
    AceEvent-2.0-32527 (BigWigs):322: in function `TriggerEvent'
    AceEvent-2.0-32527 (BigWigs):1009: in function <...ce\AddOns\BigWigs\Libs\AceEvent-2.0\AceEvent-2.0.lua:1002>

    --------------------------------


    Quote from Bhattu »

    Quote from Snarfle »

    After the latest update tonight I got the following error.
    [2007/04/16 21:31:05-317-x1]: Chronometer-0.10\Core\Chronometer.lua:726: bad argument #1 to 'gmatch' (string expected, got nil)
    <in C code>: ?
    AceEvent-2.0-32527 (BigWigs):322: in function `TriggerEvent'
    AceEvent-2.0-32527 (BigWigs):1009: in function <...ce\AddOns\BigWigs\Libs\AceEvent-2.0\AceEvent-2.0.lua:1002>


    Okay, I think I fixed it, but I don't know how to duplicate what you were doing to test it. If it still happens, please let me know what exactly you're doing to cause it (spell you're using, etc.)
    Posted in: General AddOns
  • To post a comment, please or register a new account.