• 0

    posted a message on Omen3
    Feature Request: Omen should remember it's visible state when you log out. Currently, it is always visible when I log in. (Note: I have auto show/hide disabled.)
    Posted in: Raid AddOns
  • 0

    posted a message on Prat 3.0 Chat Mod Framework
    Hi, I need some assistance with the Alias module. I used it extensively before wotlk hit without any problems. I did an AddOn wipe at the expansion, and I am just now setting my aliases back up. This time around, no matter how I try to do it, my character will always simply speak the contents of the alias aloud instead of actually running the command. I'm probably just missing something obvious, so sorry about that, but I appreciate if someone can set me straight.

    For example,
    /alias /foo /run DEFAULT_CHAT_FRAME:AddMessage("test alias");
    


    When I type in /foo (by itself, no leading space before the slash), I would expect "test alias" to be echoed in my local chat window. Instead, my character embarrassingly says (in whatever channel I'd most recently spoken to) "/run DEFAULT_CHAT_FRAME:AddMessage("test alias");"
    Posted in: General AddOns
  • 0

    posted a message on Omen3
    Feature Request: Can there please be an option added under the "Show when..." configuration to *never* automatically toggle the display? I want to manually control this and no matter what I set, Omen decides on its own to show or hide itself when I don't want it to. I hope you consider this suggestion, and thanks for your work on the new Omen.
    Posted in: Raid AddOns
  • 0

    posted a message on FuBar, some addons not integrating properly
    Fixed. Many thanks durcyn.
    Posted in: AddOn HELP!
  • 0

    posted a message on FuBar, some addons not integrating properly
    Hi, I've got a problem with a few FuBar capable AddOns that are refusing to recognize the fact that I have FuBar installed and so are attaching to the mini-map instead.

    The specific AddOns are Omen, and ClockFu. Omen has an attach-to-minimap checkbox, which when clicked does nothing (the checkmark won't even go away). Niether one of them are showing up anymore under FuBar's menu (where it lists available AddOns sorted by category).

    This started happening about a week ago, when I used Window's "Restore to System Checkpoint" thing for something not WoW-related. Apparently the restore uninstalled a few of my AddOns, so I simply reinstalled them. Their settings in WTF where intact, and the problem I'm describing is the only ill-effect I'm aware of.

    Does anyone have any ideas I can try to get these things off my minimap and back onto the FuBar, short of blowing away my WTF entirely? I'd very much like to avoid that, if there is anything else I can possibly try first.

    Sorry if this is documented someplace on the wiki or in a post on these forums, I was unable to find an answer in my searches.
    Thanks,
    Bryan

    PS Maybe worth mentioning, right-clicking on the FuBar now brings up the pop-up menu of options for that bar -- before I did the restore, it used to open the Rock config window. (I can still pull up Rock with /rock). I actually prefer the popup but since that changed at the same time, thought I would mention it.
    Posted in: AddOn HELP!
  • 0

    posted a message on ZOMGBuffs Official Thread
    Quote from Zeksie »

    I would guess you have some other mod which is setting the Mousewheel binding after ZOMGBuffs loads. Try this once you're loaded:
    /print GetBindingAction("MOUSEWHEELUP")

    It should give you 'CLICK ZOMGBuffsButton:MOUSEWHEELUP', otherwise something is re-binding after ZOMG.


    You were right, thanks. /run SetBinding to that command makes it work fine.
    Thanks!
    Posted in: General AddOns
  • 0

    posted a message on ZOMGBuffs Official Thread
    Is there a way to configure ZOmgBuffs so that buffs with charges get flagged as "needs rebuff" when low, even if they have plenty of time left on them? For example, Inner Fire -- currently the AddOn only wants to rebuff if it runs out entirely, I prefer to rebuff if I've only got a few charges left.

    Unrelated problem: using the mousewheel for the activation just won't work for me. Nothing happens at all. If I change to some other activation key, it works perfectly. I even tried changing to a custom activation key, but putting "mouse-wheel up" in there... ZomgBuff was clever enough to notice and set the "Mousewheel Buff" option on (but still doesn't do anything when I flip my mousewheel).
    Posted in: General AddOns
  • 0

    posted a message on Omen2
    Sometime in the last 2 days, my Omen seems to have decided that I do not have FuBar installed and is attaching itself to the minimap. Under the options panel, trying to uncheck the "Attach to mini-map" option does nothing, the checkmark will not go away.

    I tried removing my SavedVariables/Omen.lua(.bak) files. Both the account-wide and character-specific ones. Didn't fix it. Any suggestions?
    Posted in: Raid AddOns
  • 0

    posted a message on FuBar - QuestsFu
    Noticed a little odd behaviour the other day: If you complete quest objectives with your UI hidden (ALT-Z), then when you bring your UI back, the QuestsFu does not reflect the progress you've made. Clicking on the quest name in the tracker does cause it to update and show the correct info, but also causes an error. As far as I could tell, the error didn't cause any further problems though.
    Posted in: FuBar AddOns
  • 0

    posted a message on Prat 2.0 Chat Mod Framework (Official Thread)
    I've got a minor Feature Request -- or Bug Report, depending on your point of view =)

    I use the Alias module extensively, and it is inconvienent that the /listaliases function converts everything to lower case when displaying the aliases. The correct case is stored (all of my aliases /run some lua, and they do work), so it is just a display problem. But it makes it impossible to copy/paste an existing alias, because the lua I put in the aliases is case sensitive.

    I found the appropriate place in the code to disable this, and doing so didn't introduce any problems. I'd like to see the change made officially though, so I don't have to edit the code after every update.

    I guess it could be an option, but I honestly don't know why it would ever be desireable for the contents of your alias to be converted.

    Thanks for considering my suggestion.

    Posted in: General AddOns
  • 0

    posted a message on PitBull 2.0
    Quote from Gahlok »

    I just auto-updated PitBull and I'm now getting errors (and it's not loading).


    Ditto. Try downgrading a few revisions, I went back to r59451 and got it working again, I'm sure they'll commit a fixed version soon.

    The embedded LibDogTag appears in the current version is messed up. It doesn't even parse as valid LUA.

    edit: PS same problem reported in this thread, in case you want to follow it http://www.wowace.com/forums/index.php?topic=11129.0
    Posted in: Unit Frames
  • 0

    posted a message on Bartender3 - Action Bar AddOn for WoW 2.0
    Bartender3 will show you the Hotkeys that are bound for a each button on the bars, but I use Spellbinder to set hotkeys for a lot of things, and I wanted to be able to see those hotkeys. (e.g. the key bound to the spell/item/macro, regardless of which button it was on).

    Below is a snippet of code I added that accomplishes that, which I'm posting in case anyone is interested. It will show the binding set for the spell/item/macro if (and only if) there is no binding for the button it is sitting on. I'm sure it could be cleaner, but there you go.

    I added this in the function UpdateHotkeys() just after the call to GetBindingKey() and just before the call to GetBindingText().

    if key == nil then -- Try looking it up
        local actType, actId = GetActionInfo(self.action);
        if actType == BOOKTYPE_SPELL then
            actName = GetSpellName(actId, actType);
            key = GetBindingKey(actType.." "..actName) or GetBindingKey(actType.." "..actName.."(Rank 1)");
        end
        if actType == "macro" then
            actName = GetMacroInfo(actId);
            if not actName == nil then
                key = GetBindingKey(actType.." "..actName);
            end
        end
        if actType == "item" then
            actName = GetItemInfo(actId);
            key = GetBindingKey(actType.." "..actName);
        end
    end

    Posted in: General AddOns
  • 0

    posted a message on FuBar_MailFu
    Quote from OttoDeFe »

    Just got MailFu functioning...

    Removed the LOD entry from SpecialEvents_Mail-2.0 's toc file.


    Thanks a ton. This also made it start working again for me.

    I'm nervous that the problem was only avoided, but not fixed... I hope that the workaround doesn't stop whoever has the knowhow from investigating the underlying problem. (I sure don't have the knowhow...)
    Posted in: FuBar AddOns
  • 0

    posted a message on waypoints module hide/show the hud arrow
    the point is that I want it "in my way" at certain times... but at other times I would prefer it not to be in my way (without having to do a /noway ... I want the way points to still be there, just hide the arrow).

    happy to toggle it manually, just don't know how (short of /noway).
    Posted in: Map/Minimap AddOns
  • 0

    posted a message on waypoints module hide/show the hud arrow
    This is an easy question...

    [ ] yes
    [ ] no

    anyone know the answer?
    Posted in: Map/Minimap AddOns
  • To post a comment, please or register a new account.