• 0

    posted a message on Prat 3.0 Chat Mod Framework
    Unsure if this thread is monitored, but there's a ticket of the issue dating back to May that seems unanswered and i'm still having the issue so maybe someone can help me figure it out.

    Trying to copy URLs in Prat seems to fail now. When someone pastes a URL and I try to click it or right click and select copy, the pop up only gives me a fraction of the URL. No amount of reloading the UI or running with just Prat seems to fix this.

    For example, if you were to link me some rando youtube video, I would usually get something about: http://www.you

    The only way I can workaround it is if I right click the line and select copy to editbox and manually copypasta the entire line and edit out the channel and playername and brackets and stuff to get the URL myself.
    Posted in: General AddOns
  • 0

    posted a message on Shadowed Unit Frames [official]
    Minor issue with mushroom bar. Since my druid alt is feral and I never use mushrooms (maybe i'm bad! idk!), I figured I would disable it but not before playing with it.

    I dropped a mushroom to see the red tick indicating one mushroom, swapped back to cat so I had my blue mana bar and then a 1 of 3 red bars for the mushroom bar. If you disable the mushroom bar at this point with a mushroom still active, it removes the bar but that red tick gets pushed upwards and stays there permanently until you explode the mushroom and then re-enable and then redisable the mushroom bar.

    I'm including screenshots since being sick, I may not be wording the description of the problem in an understandable fashion.

    #1 - Here is just the mushroom bar + feral mana bar enabled with 1 mushroom active while in cat form, you can see the mushroom indicator has now shifted into the portrait: http://i.imgur.com/1PHpD.jpg

    #2 - Here is being in cat form with 1 mushroom active, feral mana bar enabled but with mushroom bar disabled: http://i.imgur.com/kEdMD.jpg

    #3 - Here is shifting to caster form with mushroom bar disabled after exploding the mushroom, you can still notice the red indicator of the mushroom is still there (though I guess worgen portrait is too fat and almost covers it all): http://i.imgur.com/N6saw.jpg
    Posted in: Unit Frames
  • 0

    posted a message on Shadowed Unit Frames [official]
    Latest alpha seems to have broken the config. Posted a ticket though it seems the LUA error got chopped off by BugSack so I posted all that I could ;x
    Posted in: Unit Frames
  • 0

    posted a message on Spammed with errors when in WSG, though not addon specific?
    Quote from Xinhuan
    try to remember what addons you installed recently.


    Aw shucks. It's a clean install so the answer to that is all of them. rofl.

    What really confused me is that i'm pretty much running the same batch of addons as I was running previously (though short a few addons I guess).

    Thanks for the reply though, guess I get to test!
    Posted in: AddOn HELP!
  • 0

    posted a message on Spammed with errors when in WSG, though not addon specific?
    Annoyingly, this problem seems to be affecting other addons as well with it now referencing even the Ace3 libraries ;x

    ["message"] = "[ADDON_ACTION_BLOCKED] AddOn \"Ace3\" tried to call the protected function \"AlwaysUpFrame3:SetPoint()\".",
    ["time"] = "2011/04/16 19:40:22",
    ["stack"] = "<in C code>\nFrameXML\\WorldStateFrame.lua:153: in function <FrameXML\\WorldStateFrame.lua:113>\n<in C code>\nFrameXML\\WorldStateFrame.lua:109: in function <FrameXML\\WorldStateFrame.lua:102>",
    ["session"] = 127,
    ["counter"] = 740,
    }, -- [23]
    {
    ["message"] = "[ADDON_ACTION_BLOCKED] AddOn \"Ace3\" tried to call the protected function \"AlwaysUpFrame3:Show()\".",
    ["time"] = "2011/04/16 19:40:22",
    ["stack"] = "<in C code>\nFrameXML\\WorldStateFrame.lua:189: in function <FrameXML\\WorldStateFrame.lua:113>\n<in C code>\nFrameXML\\WorldStateFrame.lua:109: in function <FrameXML\\WorldStateFrame.lua:102>",
    ["session"] = 127,
    ["counter"] = 740,
    }, -- [24]
    Posted in: AddOn HELP!
  • 0

    posted a message on Spammed with errors when in WSG, though not addon specific?
    I built a new PC about 2 weeks ago so I did a clean WoW install for the first time after about 5 years (I know, I know *gasp!* Horrible maintenance habits!).

    Part of what I did was try to trim down the amount of addons I ran by simply downloading the few I thought I absolutely needed as a raider and arena player and then slowly downloading addons one by one as I played to see if I actually used it or not (like trying to play without Atlasloot and then freaking out when I started trying to type /atlasloot in game and NOTHING HAPPENING).

    When I entered Warsong on my hunter alt, in the middle of the game, a note in my chat suddenly mentioned that Buggrabber stopped capturing errors because it was spamming too many. So I went to look and there were just a huge amount of like 190x some errors with Dominos so I reported that to Tuller.

    The error was:

    ["message"] = "[ADDON_ACTION_BLOCKED] AddOn \"Dominos\" tried to call the protected function \"DominosClassButton1:SetAttribute()\".",
    ["time"] = "2011/04/06 08:20:48",
    ["stack"] = "<in C code>\nDominos\\classBar.lua:177: in function \"UpdateSpell\"\nDominos\\classBar.lua:233: in function <Dominos\\classBar.lua:230>",
    ["session"] = 24,
    ["counter"] = 1,

    But the problem was, the next day, I did WSG again and this time I got spammed with errors again except it wasn't Dominos, it was Shadowed Unit Frames:

    ["message"] = "[ADDON_ACTION_BLOCKED] AddOn \"ShadowedUnitFrames\" tried to call the protected function \"SearchLFGLeave()\".",
    ["time"] = "2011/04/11 04:49:20",
    ["stack"] = "<in C code>\nFrameXML\\LFRFrame.lua:389: in function \"LFRBrowseFrame_OnUpdateAlways\"\n<string>:\"*:OnUpdate\":7: in function <string>:\"*:OnUpdate\":1",
    ["session"] = 80,
    ["counter"] = 1,

    So I restarted WoW and then the next time I did Warsong, it was Auctionator:

    ["message"] = "[ADDON_ACTION_BLOCKED] AddOn \"Auctionator\" tried to call the protected function \"AlwaysUpFrame3:Hide()\".",
    ["time"] = "2011/04/12 01:30:14",
    ["stack"] = "<in C code>\nFrameXML\\WorldStateFrame.lua:195: in function <FrameXML\\WorldStateFrame.lua:113>\n<in C code>\nFrameXML\\WorldStateFrame.lua:109: in function <FrameXML\\WorldStateFrame.lua:102>",
    ["session"] = 89,
    ["counter"] = 106,

    Being that I have no idea how to interpret these at all to figure out what the problem is and they're non-addon specific, does anyone have any idea what the problem could be?
    Posted in: AddOn HELP!
  • 0

    posted a message on Random addons blocking removing glyphs?
    Quote from Rabbit
    The problem is that any addon that uses a StaticPopupDialog (the window that asks if you really want to replace a glyph or not) will taint it.

    This is a Blizzard problem and there's not much an individual addon can do about it.

    However, I have a sort-of solution in the works in the form of a small library that replicates the SPD functionality and allows authors to easily drop it in their addon and replace the usage of the Blizzard one with mine.

    It's a "sort-off" solution because it only solves the problem if all your addons start using it.

    I am off to work in a minute, but I'll upload it tomorrow.


    Curious on what became of this.
    Posted in: AddOn HELP!
  • 0

    posted a message on Random addons blocking removing glyphs?
    So this is an issue that's been driving me (and my guildmates) nuts.

    Every time I want to try to remove a glyph (the shift-right click option), I get the error saying it's blocked and an addon is blamed. Each time it's an Ace related addon. For me it used to always blame Talented. When I run on characters that didn't run Talented, it would blame Ace3 itself. For my raid leader, it blames Skada.

    Since I don't get a LUA error just the BLOCKED, I have no idea which addon is actually causing the issue mostly because the enabling one by one option came up inconclusive (it ended up going back and blaming random addons).

    The search for this issue had a thread back in November that hinted at Auctionator, but I tried disabling that to no avail and that thread hasn't seen a post since then.
    Posted in: AddOn HELP!
  • 0

    posted a message on ElkBuffBars v2 (finally Ace3 version)
    Can you bring back the option of the 3 click thing where we could right click the buff and it brought the buff to the center and we could click to cancel or right click to hide the giant middle frame again?

    Limiting buff cancel to out of combat only wasn't a problem until I noticed I would need to make a separate macro every time I wanted to cancel BoPs or hand of WSG flags. And if I needed to go through all that trouble, I might as well use the default buff frame.
    Posted in: General AddOns
  • 0

    posted a message on Skinner
    I don't know if it is Skinner that is doing this or not. I updated to the most recent skinner available on WoWAce. I tried disabling all the player and ui skins too but nothing helped.



    Any ideas?
    Posted in: General AddOns
  • 0

    posted a message on GridStatusRaidDebuff
    1x AceLocale-2.2-91094 (Ace2):487: AceLocale(Grid): Translation "Border" does not exist.
    GridStatusRaidDebuff-v3.01\Core.lua:691: in function `CreateMainMenu'
    GridStatusRaidDebuff-v3.01\Core.lua:250: in function `RegisterStatuses'
    GridStatusRaidDebuff-v3.01\Core.lua:168: in function <GridStatusRaidDebuff\Core.lua:166>
    <in C code>: in function `pcall'
    AceAddon-2.0-91096 (Ace2):24: in function <Ace2\AceAddon-2.0\AceAddon-2.0.lua:23>
    AceAddon-2.0-91096 (Ace2):669: in function `InitializeAddon'
    AceAddon-2.0-91096 (Ace2):541: in function <Ace2\AceAddon-2.0\AceAddon-2.0.lua:518>
    <in C code>: ?
    AceEvent-2.0-91097 (Ace2):298: in function `TriggerEvent'
    AceEvent-2.0-91097 (Ace2):910: in function <Ace2\AceEvent-2.0\AceEvent-2.0.lua:903>
    
      ---


    1x AceLocale-2.2-91094 (Ace2):487: AceLocale(Grid): Translation "Center Icon" does not exist.
    GridStatusRaidDebuff-v3.01\Core.lua:703: in function `CreateMainMenu'
    GridStatusRaidDebuff-v3.01\Core.lua:250: in function `RegisterStatuses'
    GridStatusRaidDebuff-v3.01\Core.lua:168: in function <GridStatusRaidDebuff\Core.lua:166>
    <in C code>: in function `pcall'
    AceAddon-2.0-91096 (Ace2):24: in function <Ace2\AceAddon-2.0\AceAddon-2.0.lua:23>
    AceAddon-2.0-91096 (Ace2):669: in function `InitializeAddon'
    AceAddon-2.0-91096 (Ace2):541: in function <Ace2\AceAddon-2.0\AceAddon-2.0.lua:518>
    <in C code>: ?
    AceEvent-2.0-91097 (Ace2):298: in function `TriggerEvent'
    AceEvent-2.0-91097 (Ace2):910: in function <Ace2\AceEvent-2.0\AceEvent-2.0.lua:903>
    
      ---


    Since 3.3.5
    Posted in: Grid & Grid2
  • 0

    posted a message on Prat 3.0 Chat Mod Framework
    It looks like the /tt shortcut for sending tells to your target also appears to be a function that is missing.

    Man, how did I even function in this game before Prat?
    Posted in: General AddOns
  • 0

    posted a message on Prat 3.0 Chat Mod Framework
    Quote from Torhal
    You can hold ALT for that


    It seems so miniscule that you take it for granted but once it's taken away and you accidentally walk off a cliff because you forgot to hold down alt to scroll back (NOT THAT I DID THAT) it makes you really wonder how people could possibly have the audacity to be hostile towards addon writers that you so frequently see on addon forums.

    Having to hold down alt makes me want to pummel Blizzard's interface designer.
    Posted in: General AddOns
  • 0

    posted a message on ButtonFacade (was LibButtonSkin-1.0)
    Realize r303 is an Alpha but figured I would post, spams me with errors (buggrabber reports it's more than 20 per second), posting the first one:

    LibButtonFacade-1.0-?:597: attempt to index a nil value
    LibButtonFacade-1.0-?:657: in function <...ade\Libs\LibButtonFacade-1.0\LibButtonFacade-1.0.lua:627>
    LibButtonFacade-1.0-?:827: in function <...ade\Libs\LibButtonFacade-1.0\LibButtonFacade-1.0.lua:763>
    LibButtonFacade-1.0-?:897: in function `AddButton'
    Dominos-1.15.1\actionBar.lua:199: in function `Skin'
    Dominos-1.15.1\actionBar.lua:119: in function `Create'
    Dominos-1.15.1\actionBar.lua:55: in function `New'
    Dominos-1.15.1\actionBar.lua:344: in function `LoadButtons'
    Dominos-1.15.1\actionBar.lua:303: in function `New'
    Dominos-1.15.1\Dominos.lua:214: in function <Dominos\Dominos.lua:212>
    <in C code>: in function `Load'
    Dominos-1.15.1\Dominos.lua:86: in function <Dominos\Dominos.lua:84>
    (tail call): ?:
    <in C code>: ?
    <string>:"safecall Dispatcher[1]":9: in function <[string "safecall Dispatcher[1]"]:5>
    (tail call): ?:
    AceAddon-3.0-5 (Ace3):539: in function `EnableAddon'
    AceAddon-3.0-5 (Ace3):629: in function <Ace3\AceAddon-3.0\AceAddon-3.0.lua:615>
    <in C code>: in function `LoadAddOn'
    Interface\FrameXML\UIParent.lua:234: in function `UIParentLoadAddOn':
    Interface\FrameXML\UIParent.lua:257: in function `CombatLog_LoadUI':
    Interface\FrameXML\UIParent.lua:481: in function <Interface\FrameXML\UIParent.lua:453>:
    
      ---
    Posted in: General AddOns
  • 0

    posted a message on Skada: a damage meter
    Quote from KnThrak
    I suspect from an author-POV the issue is: Do you want to have special code for "some" abilities. Notice "some" is a very mushy word, it won't be long before people ask for DoTs to be summed into over-entire-DoT-damage and such perks.


    Scourge Strike is unique, though, in this area of being a single attack that is split into two. The DoT damage argument as a lump-sum is fairly meaningless overall and you'd get that information from "Corruption". You'd also have a fairly accurate "Average" tick damage as well as having an accurate Crit value.

    You're not really getting that for ScS. With ScS, you're getting half your crit value (since only the Physical damage portion can crit) while getting an absolutely useless "Average" value since it places your Average at a point between your Physical and Shadow damage portions rather than what your average ScS actually is (nor would it help you determine your average Physical or average Shadow portions so really, it's an average at an imaginary point that you will never actually attain). It also gives a fairly useless minimal and maximum damage values since your shadow portion will never be considered for minimal hit and your physical portion will never be considered for maximum hit.
    Posted in: General AddOns
  • To post a comment, please or register a new account.