• 0

    posted a message on LibFilter-1.0 - Generic Item Filter Library
    Quote from sano2
    Perhaps I'm being a bit dense here, but how do you enable the adapters? I've got the latest versions of ClosetGnome, Combuctor, and LibFilter installed and I don't see any new tabs in combuctor.


    Assuming you have Combuctor_Config installed, go to game menu => interface => AddOns tab. Select "Combuctor" and turn on the check mark next to ClosetGnome with frame set to Inventory and then do the same for frame set to Bank and click okay.
    Posted in: Libraries
  • 0

    posted a message on ItemValue
    Quote from nomad_wanderer
    When I enable Itemvalue, I get many errors in bugsack (35)...

    Heres one

    [2008/11/14 01:24:27-603-x1]: Ace2\AceLibrary\AceLibrary.lua:435: cannot change a protected metatable
    Ace2\AceLibrary\AceLibrary.lua:435: in function <Interface\AddOns\Ace2\AceLibrary\AceLibrary.lua:423>
    Ace2\AceLibrary\AceLibrary.lua:451: in function <Interface\AddOns\Ace2\AceLibrary\AceLibrary.lua:423>
    Ace2\AceLibrary\AceLibrary.lua:451: in function <Interface\AddOns\Ace2\AceLibrary\AceLibrary.lua:423>
    Ace2\AceLibrary\AceLibrary.lua:451: in function 


    Very strange. Are you running r1093 of Ace2?
    As of r1093
    Line 435: "if not data then"
    Line 423: "if m then"
    And Line 451 is blank

    I don't see how any of those lines could be from that stack traces, so I'm assuming it might be a different version of Ace2? I would have expected that error be on a line that calls setmetatable
    Posted in: General AddOns
  • 0

    posted a message on ItemValue
    Quote from Mokhtar
    Same here, I've got massive errors popping up all over the place...


    Could you quote the at least the first few errors? (BugSack or Swatter is a good way to capture them.)
    Posted in: General AddOns
  • 0

    posted a message on ItemValue
    Quote from nomad_wanderer
    I can't get your embedded version of itemvalue to work...

    As soon as I put in your version of ItemValue, massive explosion.. 32 errors in bugsack from a variety of addons..

    Can I run your branch Disembedded? or something?


    Should be able to, though I run embed myself. You will need:
    Ace2
    Babble-Class-2.2
    Dewdrop-2.0
    Deformat-2.0
    Gratuity-2.0
    LibItemBonus-2.0
    TipHooker-1.0
    Waterfall-1.0

    For ItemValue_DrDamage you'll need (besides DrDamage):
    StatLogicLib
    Posted in: General AddOns
  • 0

    posted a message on Baggins - Official Thread
    I'm planning on taking that out eventually (actually make it only shown from the alphas and not the releases), but as some of the initialization code is still new I had put those messages in to help trace down some possible problems.
    Posted in: General AddOns
  • 0

    posted a message on Baggins - Official Thread
    Quote from saltorio
    [2008/11/08 13:07:52-2798-x12]: ...\modules\LibFilter_Outfitter\LibFilter_Outfitter.lua:513: bad argument #1 to 'pairs' (table expected, got nil):
    ...\modules\LibFilter_Outfitter\LibFilter_Outfitter.lua:513: in function <...\modules\LibFilter_Outfitter\LibFilter_Outfitter.lua:504>:
    (tail call): ?:
    (tail call): ?:
    Baggins-Beta 1\Baggins-Filtering.lua:1630: in function <Interface\AddOns\Baggins\Baggins-Filtering.lua:1602>
    Baggins-Beta 1\Baggins-Filtering.lua:1679: in function `OnSlotChanged'
    Baggins-Beta 1\Baggins-Filtering.lua:1592: in function `CheckSlotsChanged'
    Baggins-Beta 1\Baggins-Filtering.lua:1742: in function `ForceFullUpdate'
    Baggins-Beta 1\Baggins.lua:2826: in function `OpenBag'
    Baggins-Beta 1\Baggins.lua:2855: in function `OpenAllBags'
    Baggins-Beta 1\Baggins.lua:2873: in function <Interface\AddOns\Baggins\Baggins.lua:2869>
    (tail call): ?:
    <string>:"OPENALLBAGS":1: in function <[string "OPENALLBAGS"]:1>
    
      ---


    That's weird.... I'll can fix that error message but it should only happen if Outfitter is not loaded and initialized. Found the problem, initialization code made an assumption that is no longer true.
    Posted in: General AddOns
  • 0

    posted a message on Baggins - Official Thread
    Quote from saltorio
    I'm using Baggins_LibFilter, and it's not showing any of my Outfitter sets in the "Outfitter" filter settings. I only see "Any" and "None".

    I'm trying to setup (as I had with Baggins_Outfitter) an Armor category for my main bags that includes my Armor settings (as "Category: Armor" "AND Outfitter Set: Any") so that only armor that is part of an Outfitter set shows up in that filter. This worked under Baggins_Outfitter, but nothing goes into this filter at all. I tried rebuilding the filter to no avail. If I switch the "AND" to "OR", than all armor goes into the filter (which isn't what I want). And I have set the priority of this filter to 20, so that's not the issue.

    This is all occurring under Baggins r407, Baggins_LibFilter 2008-10-25B, and with Outfitter 4.3beta12.


    Give r28 of LibFilter-1.0 a try and let me know what you get. I put some changes in there to detect some setup problems and display an error in the settings dialog in those cases, but haven't released them to curse or Baggins_LibFilter yet.
    Posted in: General AddOns
  • 0

    posted a message on Baggins - Official Thread
    I wrote the other one that gave you the option to pick individual sets. LibFilter takes it a step further and allows you to pick multiple sets in the same filter.
    Posted in: General AddOns
  • 0

    posted a message on Baggins - Official Thread
    r28 should fix it. Or you can remove the older Baggins_Outfitter, which should then cause the one from LibFilter to take over. You can also remove Baggins_LibFilter, Baggins_Professions and Baggins_Usable, since LibFilter-1.0 has all of those built in.
    Posted in: General AddOns
  • 0

    posted a message on Baggins - Official Thread
    Quote from Kiber_
    I got error with new Libfilter :'-


    Okay I see the problem. There was a slight error in the code path for when a non-LibFilter was detected and it was determining if it should be replaced or not. Should be fixed in r28 though I haven't been able to test it in the game yet.
    Posted in: General AddOns
  • 0

    posted a message on Baggins - Official Thread
    Quote from Kiber_
    I wrote this scheme:
    So, i want to filter 1+2+3 and 4+5.
    Now i can filter only 1+2+3+4 and 5, because i cant find filter on KNOWN primary professions.


    Give LibFilter-1.0 r27 a try. I added an extra option to the Professions filter to allow it to apply only to primary professions or to both primary and secondary. Still might tweak the options a bit further.
    Posted in: General AddOns
  • 0

    posted a message on Combuctor: All in one, filterable displays for your inventory and bank
    FYI. Latest alpha of LibFilter-1.0 also has ClosetGnome and ItemRack filter support for Combuctor.
    Posted in: General AddOns
  • 0

    posted a message on Solving the library saved data problem?
    Quote from dafire
    yeah .. and that new version would then get an other named saved variables addon ?
    A user has to know which addons use which folders to know when he can remove them.
    Always when I think about it, it gets even worse :9


    Think we might be talking cross-ideas. Was talking about my alternative to Mikk's suggestion, there would be no new addon folder.

    Say you have an embedded lib LibBooFar-1.0 it needs savedvariable BooFarVar which using something like the tiny bit of code above keeps in sync with multiple containing addons even if they load on demand etc. (Assuming data is stored with transactions / date stamps etc if necessary.)

    A way to improve/rearchitect LibBooFar is found but needs a new data layout. LibBooFar-2.0 is created and request savedvariable BooFar2Var. BooFarVar is removed from the saved variable list. When LibBooFar-2.0 is loaded it watches for the variable BooFarVar which still should be loaded even if no longer saved (at least if I recall), merges into the new format as necessary.
    Posted in: Libraries
  • 0

    posted a message on Solving the library saved data problem?
    Quote from dafire
    Yeah.. the problem is with embedded libraries you will get into heavy trouble if you want to change the data structure for example.


    If you're going to use a saved data with part of an embedded library it's layout (even if private) should be treated as part of the API. If a change that isn't backwards compatible is made it's time to go to a new major version.
    Posted in: Libraries
  • 0

    posted a message on ItemValue
    Should be fixed in r105.

    Edit: Looks like the packager hasn't picked it up yet.
    Edit 2: Packager is running again. The changes for r105 are in r106.

    Let me know if that doesn't fix the errors.
    Posted in: General AddOns
  • To post a comment, please or register a new account.