• 0

    posted a message on Skinner
    I've been getting this error for quite a few revisions now:


    Date: 2011-01-30 11:23:11
    ID: 1
    Error occured in: Global
    Count: 1
    Message: ..\AddOns\Skinner\SkinMe\Auctionator.lua line 7:
    Usage: SecureHook([object], method, [handler]): Attempting to hook a non existing target
    Debug:
    (tail call): ?
    [C]: ?
    Ace3\AceHook-3.0\AceHook-3.0.lua:211:
    Ace3\AceHook-3.0\AceHook-3.0.lua:118
    Ace3\AceHook-3.0\AceHook-3.0.lua:344: SecureHook()
    Skinner\SkinMe\Auctionator.lua:7:
    Skinner\SkinMe\Auctionator.lua:3
    (tail call): ?
    [C]: xpcall()
    Skinner\UtilFuncs.lua:88:
    Skinner\UtilFuncs.lua:86
    Skinner\UtilFuncs.lua:145: checkAndRunAddOn()
    Skinner\AddonFrames.lua:298: ?()
    ...Ons\Ace3\CallbackHandler-1.0\CallbackHandler-1.0.lua:147:
    ...Ons\Ace3\CallbackHandler-1.0\CallbackHandler-1.0.lua:147
    [string "safecall Dispatcher[1]"]:4:
    [string "safecall Dispatcher[1]"]:4
    [C]: ?
    [string "safecall Dispatcher[1]"]:13: ?()
    ...Ons\Ace3\CallbackHandler-1.0\CallbackHandler-1.0.lua:92: Fire()
    Ace3\AceEvent-3.0\AceEvent-3.0.lua:120:
    Ace3\AceEvent-3.0\AceEvent-3.0.lua:119


    I just updated to b4.13561.1 and the error is still there. Auctionator is being *mostly* skinned, but some buttons, dropboxes, etc are not.
    Posted in: General AddOns
  • 0

    posted a message on Skinner
    Quote from Jncl
    Hi cseg,
    Yes it does matter what version of Outfitter you use, as I posted previously, the skin is based upon Outfitter v5.0b8, earlier versions will throw skin errors.


    Hello,

    Sorry, I missed that previous post of yours. I updated both Skinner and Outfitter to their latest versions and the error message stopped happening. Thank you.
    Posted in: General AddOns
  • 0

    posted a message on Skinner
    Quote from Jncl
    @dogvetusa, Outfitter is fine for me[/indent]


    I have been getting a similar error as dogvetusa for quite a while now (I think it's been happening for the past 3 months or so, but not sure). I just made swatter not pop up when errors occur, but I still get a message saying "Skinner: Error running Outfitter".

    With the upcoming 3.3.5 patch in the works, I've decided on trying to make sure I don't bring any "unsolved problems" with my UI to whenever the patch hits, therefore this message gets my attention. Maybe it's an incompatible Ace3 lib with the one embedded in Skinner?

    The version I'm currently running is b3.11723.9. My Ace3 is r907, and I don't know if it even matters, but my Outfitter is version 4.10.

    Date: 2010-06-07 18:17:51
    ID: 1
    Error occured in: Global
    Count: 1
    Message: ..\AddOns\Skinner\SkinMe\Outfitter.lua line 158:
       Usage: SecureHook([object], method, [handler]): Attempting to hook a non existing target
    Debug:
       (tail call): ?
       (tail call): ?
       [C]: ?
       Ace3\AceHook-3.0\AceHook-3.0.lua:211:
          Ace3\AceHook-3.0\AceHook-3.0.lua:118
       Ace3\AceHook-3.0\AceHook-3.0.lua:344: SecureHook()
       Skinner\SkinMe\Outfitter.lua:158:
          Skinner\SkinMe\Outfitter.lua:3
       (tail call): ?
       [C]: xpcall()
       Skinner\UtilFuncs.lua:83:
          Skinner\UtilFuncs.lua:81
       Skinner\UtilFuncs.lua:132:
          Skinner\UtilFuncs.lua:108
       (tail call): ?
       [C]: ?
       [string "safecall Dispatcher[2]"]:9:
          [string "safecall Dispatcher[2]"]:5
       (tail call): ?
       Ace3\AceTimer-3.0\AceTimer-3.0.lua:164:
          Ace3\AceTimer-3.0\AceTimer-3.0.lua:138


    [edit]
    I just tried disabling Ace3 to see the results.. I get several errors about missing parts of Ace3 from other add-ons, and now Skinner gives me the same error running Outfitter, but with the error attached to AVR:

    Date: 2010-06-07 18:50:41
    ID: 7
    Error occured in: Global
    Count: 1
    Message: ..\AddOns\Skinner\SkinMe\Outfitter.lua line 158:
       Usage: SecureHook([object], method, [handler]): Attempting to hook a non existing target
    Debug:
       (tail call): ?
       [C]: ?
       ...nterface\AddOns\AVR\Libs\AceHook-3.0\AceHook-3.0.lua:211:
          ...nterface\AddOns\AVR\Libs\AceHook-3.0\AceHook-3.0.lua:118
       ...nterface\AddOns\AVR\Libs\AceHook-3.0\AceHook-3.0.lua:344: SecureHook()
       Skinner\SkinMe\Outfitter.lua:158:
          Skinner\SkinMe\Outfitter.lua:3
       (tail call): ?
       [C]: xpcall()
       Skinner\UtilFuncs.lua:83:
          Skinner\UtilFuncs.lua:81
       Skinner\UtilFuncs.lua:132:
          Skinner\UtilFuncs.lua:108
       (tail call): ?
       [C]: ?
       [string "safecall Dispatcher[2]"]:9:
          [string "safecall Dispatcher[2]"]:5
       (tail call): ?
       ...\AddOns\DataStore\libs\AceTimer-3.0\AceTimer-3.0.lua:164:
          ...\AddOns\DataStore\libs\AceTimer-3.0\AceTimer-3.0.lua:138


    And if I disable AVR, it goes to the next one on the list with an apparent incompatible Ace3 embedded (Bartender4, giving me the exact error dogvetusa gets).
    Posted in: General AddOns
  • To post a comment, please or register a new account.