• 0

    posted a message on GrindStatus
    Hi
    Been using this addon for a long time and like the simplicity of if.

    Was wondering if someone can update it a little as it still shows you that you need to get revered to get any of the heroic dungeon keys, don't know if anything else is wrong rerolled on a pvp realm and only just started getting near 70.

    So to the addon author or anyone who can could you give it a little update please, Or let me know of a better/better maintained replacement

    Tat
    Posted in: General AddOns
  • 0

    posted a message on Prat 2.0 Chat Mod Framework (Official Thread)
    Getting following on login :(

    [2008/03/22 10:19:39-818-x1]: Prat-2.0 63303.65317\Prat.lua:2220: AceLocale-2.2: Bad argument #2 to `?' (string expected, got nil)
    AceAddon-2.0-57245 (Ace2):926: in function <Interface\AddOns\Ace2\AceAddon-2.0\AceAddon-2.0.lua:919>
    <in C code>: ?
    AceEvent-2.0-63812 (Ace2):260: in function `TriggerEvent'
    AceEvent-2.0-63812 (Ace2):917: in function <Interface\AddOns\Ace2\AceEvent-2.0\AceEvent-2.0.lua:910>

    ---

    Tat
    Posted in: General AddOns
  • 0

    posted a message on TradeskillInfo Official Thread
    Hi Guys
    got a small problem with Tadeskill info why is it when i open it up and scroll through the list most of the items are red and my chat gets spammed with "no local cache info for [Item Name].

    Tat
    Posted in: General AddOns
  • 0

    posted a message on Skillet - Official Thread
    Trying you new version you attached looks interesting. Must admit i would prefer smaller icons :) and it doesn't seem to save the skill lvl when you hover over the icons even if you have looked at the skills

    Ever thought about adding baggins anywhere support for scanning whats in alts and altsbanks as i use baggins and none of the other supported addons :(
    Posted in: General AddOns
  • 0

    posted a message on Baggins - Official Thread


    I tried Baggins for the first time after seeing the above screenie.

    In it i see there is a section for scrolls, im trying to do the same, I use an all in One bag and have a section called Scrolls this has categories called scrolls, if i click on scrolls the rule is PTSet:Consumable.Scroll

    But his does not remove the scrolls from my Consumable section :(

    What am i doing wrong :(

    Tat
    Posted in: General AddOns
  • 0

    posted a message on Note addon
    Been using Omnibus for a long time like it alot had no real problems with it
    Posted in: General Chat
  • 0

    posted a message on Post useful/interesting DogTag-1.0 sequences here
    Updated a min ago as saw IsMaxDruidMP was added and now my power (mana out of form, energy in cat, rage in bear) texts aren't showing up now :(

    [~HasNoMP?FractionalMP]

    all i get is /

    i also get / for

    [~IsMana ? ~IsMaxDruidMP ? FractionalDruidMP]

    when i drop into form and want to see my mana on bottom right outside until it full then it should hide while in forms

    Thanks
    Tat
    Posted in: Unit Frames
  • 0

    posted a message on Post useful/interesting DogTag-1.0 sequences here
    Thanks for the repy

    Tried what you said and it gives me "IsMaxDruidMP" Unknown tag where the mana text is usually when im in form.

    Got the following settings
    Posioion: Outside, Right
    Sikze:25%
    Style: Custom
    Style - Custom: [~IsMana ? ~IsMaxDruidMP ? FractionalDruidMP]
    style - Type: Druid Mana

    Dont know if any of those would affect it? Not very good at all with DogTags :(

    Quote from Ellipsis »

    Try: [~IsMana ? ~IsMaxDruidMP ? FractionalDruidMP]
    Posted in: Unit Frames
  • 0

    posted a message on Post useful/interesting DogTag-1.0 sequences here
    I recently moved my mana display text when i was in cat or bear and now it no longer hides when it at full mana.

    I have not touched anything related to tags so not sure what happened

    [~IsMana ? FractionalDruidMP]

    Any ideas
    Posted in: Unit Frames
  • 0

    posted a message on UI Screenshots - Show us what you use!
    Quote from Tenelov »

    Coldfury, thanks. Its work!
    And im decrease buff size



    Nice Frames what addon is that
    Posted in: General Chat
  • 0

    posted a message on eePanels2 - Official Thread
    Quote from Evil Elvis »

    I just looked up the function call: http://www.wowwiki.com/API_UnitClass

    So, it's probably only fetching the first variable, which isn't in all caps, thus it's always evaluating to false. Try changing it to this:
    local _, class = UnitClass("player");

    That will get ignore the first variable, and fetch the second.


    Man Many Many Thanks EE that seems to have done the trick i log my pala and the stance panel is there when i log my lock its hidden,

    Final scrips:

    eePanel9:Hide()
    function eePanels2:StanceBarVisibility()
    local _, class = UnitClass("player");
    if class == "WARRIOR" or class == "PALADIN" or class == "DRUID" then
    eePanel9:Show()
    else
    eePanel9:Hide()
    end
    end

    eePanels2:RegisterEvent("PLAYER_ENTERING_WORLD", eePanels2.StanceBarVisibility)
    Posted in: General AddOns
  • 0

    posted a message on eePanels2 - Official Thread
    Many thanks for the reply EE, i made the changes you surgessted:

    Quote from Evil Elvis »

    It should probably be
    if class == "WARRIOR" or class == "PALADIN" or class == "DRUID" then

    Although your results don't exactly describe what I expect would happen if this were the only problem.


    eePanel9:Hide()
    function eePanels2:StanceBarVisibility()
    local class = UnitClass("player");
    if class == "WARRIOR" or class == "PALADIN" or class == "DRUID" then
    eePanel9:Show()
    else
    eePanel9:Hide()
    end
    end

    eePanels2:RegisterEvent("PLAYER_ENTERING_WORLD", eePanels2.StanceBarVisibility)

    And it hides the stance panel on my lock on login as it should the problem is now that it wont unhide the stance parented panel on my pala :(
    Posted in: General AddOns
  • 0

    posted a message on eePanels2 - Official Thread
    Quote from Seerah »

    @Tatia: Try adding
    THIS:Hide()
    at the very beginning of the script.

    @FlingWrinkle: are you certain you have the bottom panel set to have a gradient instead of a solid background? If so, try playing with alpha settings.


    Thanks for the reply Seerah it sort of works, i now have

    eePanel9:Hide()
    function eePanels2:StanceBarVisibility()
    local class = UnitClass("player");
    if class == "WARRIOR" or "PALADIN" or "DRUID" then
    eePanel9:Show()
    else
    eePanel9:Hide()
    end
    end

    eePanels2:RegisterEvent("PLAYER_ENTERING_WORLD", eePanels2.StanceBarVisibility)

    If i log out and log back in i can still see the stance panel but if i bring up the edit script window and click ok it hides the panel on my lock, if i do this on my pala it also hides the panel :(

    Maybe its not checking the class right, i dont know :( any ideas

    Tat
    Posted in: General AddOns
  • 0

    posted a message on eePanels2 - Official Thread
    Thanks Evil Elvis but that didn't hide the panel if i logged my lock with out a pet out.

    Thanks Seerah worked a treat at hiding the par by parenting it to the pet frame. As for:

    function eePanels2:StanceBarVisibility()
    local class = UnitClass("player");
    if class == "WARRIOR" or "PALADIN" or "DRUID" then
    THIS:Show()
    else
    THIS:Hide()
    end
    end

    eePanels2:RegisterEvent("PLAYER_ENTERING_WORLD", eePanels2.StanceBarVisibility)

    Afraid it didn't work the stance panel still shows up on my lock :( and i don't know enough about scripts to fix it :(

    Found the problem with the error that bugsack was catching it was a script looking for an addon frame of an addon that i disabled.

    Any help on the stance hiding issue would be appreciated.

    Tat
    Posted in: General AddOns
  • 0

    posted a message on eePanels2 - Official Thread
    Thanks for the reply

    I have tried the script and when i reload my ui the stance bar panel is still there :(

    As for the pet panel i tried anchoring and parenting it to BT3BarPET and when i mount up the panel is still there, thats why i had to use:

    function eePanels2:UNIT_PET()
    local petexists = UnitExists("pet")
    if (petexists) then
    eePanel8:Show()
    else
    eePanel8:Hide()
    end
    end

    eePanels2:RegisterEvent("UNIT_PET")

    But this doesnt hide the pet panel on my pala at all or on my lock when logging on without a pet, i have to summon/dismiss a pet and then it will hide the panel.


    I have been getting this error though:

    [2007/12/24 21:58:41-328-x1]: <string>:"-- Create a new ace2 addon for hooking...":9: AceHook-2.1: Bad argument #2 to `HookScript' (table expected, got nil)
    Ace2\AceLibrary\AceLibrary.lua:133: in function <Interface\AddOns\Ace2\AceLibrary\AceLibrary.lua:86>
    (tail call): ?:
    AceHook-2.1-40869 (Ace2):437: in function `HookScript'
    <string>:"-- Create a new ace2 addon for hooking...":9: in main chunk
    <in C code>: in function `RunScript'
    eePanels2-2.0\core.lua:2034: in function `ChangeScript'
    eePanels2-2.0\core.lua:517: in function `CreatePanel'
    eePanels2-2.0\core.lua:376: in function `InitPanels'
    eePanels2-2.0\core.lua:350: in function <Interface\AddOns\eePanels2\core.lua:349>
    <in C code>: in function `pcall'
    AceAddon-2.0-57245 (Ace2):24: in function <Interface\AddOns\Ace2\AceAddon-2.0\AceAddon-2.0.lua:23>
    AceAddon-2.0-57245 (Ace2):998: in function `ManualEnable'
    AceAddon-2.0-57245 (Ace2):926: in function <Interface\AddOns\Ace2\AceAddon-2.0\AceAddon-2.0.lua:919>
    <in C code>: ?
    AceEvent-2.0-56171 (Ace2):263: in function `TriggerEvent'
    AceEvent-2.0-56171 (Ace2):914: in function <Interface\AddOns\Ace2\AceEvent-2.0\AceEvent-2.0.lua:907>

    ---

    Is this what is causing the problem
    Posted in: General AddOns
  • To post a comment, please or register a new account.