• 0

    posted a message on TradeskillInfo Official Thread
    Current yellow recipe linking is as follows.
    shift+click on skill in list and alt+click on the item icon will yellow link if it's known my you or an alt and the enchantId(spellid) can be found in the data I added. Otherwise it prints out the info as plain text.

    shift+ctl+click on the list will force a yellow link if the enchantid can be found.

    [edit]
    I'll worry about bad static data after I get my dataminer working a little more reliably
    Posted in: General AddOns
  • 0

    posted a message on TradeskillInfo Official Thread
    You have to shift click the spell in the list not the icon with the tooltip on the right side.

    Ivan

    [edit]
    made it so that alt-clicking the item does the same as shift click in the list
    Posted in: General AddOns
  • 0

    posted a message on TradeskillInfo Official Thread
    So far if the skill is known and I have the enchantid(spellid) for the recipe shift-clicking the skill name inserts into the chat edit box:
    [Enchant Bracer - Minor Stamina]

    if either the skill is unknown or the enchantid(spellid) is unknown shift-clicking the skill name inserts into the edit box:
    Enchant Bracer - Minor Spirit : 2*Lesser Magic Essence : Enchanting(60)


    I'm fairly sure my dataminer missed a few of the enchantids(spellids) but it's at least a pretty good start.

    If you want to try it out I'm attaching a zip for tsi and tsiui, If you get dc'd try to remember what caused it. Don't want to commit this to the SVN just yet.
    Posted in: General AddOns
  • 0

    posted a message on TradeskillInfo Official Thread
    Ok, got most of the yellow links working, but now for the fun part. I have no way to tell if a link(or skill) has been seen before on the server. The safest would be to only allow skills that you know to be yellow linked and the rest the old style. Any thoughts?

    Ivan
    Posted in: General AddOns
  • 0

    posted a message on TradeskillInfo Official Thread
    Quote from stavmar »

    Is there something i should be looking out for. I did not receive any errors but I am not noticing anything different either seems to be functioning as it did before. Man I wish we could update teh recipes so the link would actually work in chat. :-)


    Regarding the recipe links, would you rather have the actual recipe link put in chat instead of the recipe name and reagents or how it is now but with the name as the link? Shouldn't be to hard to do if thats what you are thinking of.

    Ivan
    Posted in: General AddOns
  • 0

    posted a message on TradeskillInfo Official Thread
    I have it fixed now, a spelling error was causing TSI to try to update known recipes when a skill point in anything was gained, i.e. weapons or defense. Committing hopefully the last bug fix for the change. I will look into recipe links shortly


    Ivan
    Posted in: General AddOns
  • 0

    posted a message on TradeskillInfo Official Thread
    SVN should be updated now.

    Ivan

    [edit]
    lol first svn commit here and I mess it up, should be good now

    [edit]
    think I just found what was causing the error I was getting, will keep testing for a bit and commit after it doesnt show up anymore
    Posted in: General AddOns
  • 0

    posted a message on TradeskillInfo Official Thread
    Will commit changes later today, did a few more changes that I missed the first time and just want to test for any errors that may have popped up.

    Ivan
    Posted in: General AddOns
  • 0

    posted a message on GarbageFu
    Just a quick question, why do all the addons that use ItemPrice need to be optionaldeps when ItemPrice is providing the GetSellValue function.

    Ivan
    Posted in: FuBar AddOns
  • 0

    posted a message on GarbageFu
    I have to agree with the others here that the use of ItemPrice should not be forced and only included as on optionaldep. Not quite sure what the problem is/was with the getsellvalue api code, I have been running perfect with it on mine and several other guild members' PCs ever since I posted the change.

    Ivan
    Posted in: FuBar AddOns
  • 0

    posted a message on TradeskillInfo Official Thread
    Don't have svn write access yet. I have found that every once and a while with the change an UpdateKnownTradeRecipes debug message is printed. I've had it show up twice in the last 3 days, haven't looked into it much yet.
    Posted in: General AddOns
  • 0

    posted a message on TradeskillInfo Official Thread
    TSI wasn't updating known recipes with Manufac installed because the trade skill frame was never shown so I changed TSI to rely on GetTradeSkillInfo and GetCraftSkillInfo instead of a shown frame. Works great for me so far. Diff is attached.

    Hope this is of use to someone
    Ivan
    Posted in: General AddOns
  • 0

    posted a message on nQuestLog
    Testing a fix for the completed quest bug now, don't have svn access but will post the diff if it works properly now.

    Edit:
    Looks like its working pretty well so here's the diff for someone to merge
    Posted in: General AddOns
  • 0

    posted a message on GarbageFu
    Quote from Zidomo »

    Latest r43120 commit released on Saturday by "Smoere" is buggy.

    Log on with it and:
    "FuBar_GarbageFu-2.0.29812\\GarbageFu_Vendor.lua:283: attempt to index field '?' (a nil value)\n<in C code>: ?\nAceEvent-2.0-40601 (Ace2):329: in function <Interface\\AddOns\\Ace2\\AceEvent-2.0\\AceEvent-2.0.lua:310>\n\n"

    Updated to that revision from r36604 which I later modified to include ItemPrice (Tooltip) support via the LUA in this post.

    r36604 with the GarbageFu_Vendor.lua replacement from that post works flawlessly with ItemPrice, btw. You do need to have ItemPriceTooltip active as well for it to work, though, not just the ItemPrice-1.0 library.

    Still need a non-buggy implementation of generic GetSellValue support.


    Go back to the latest svn version and then delete your garbagefu savedvariable, it should fix that problem.
    Posted in: FuBar AddOns
  • 0

    posted a message on GarbageFu
    Quote from Zidomo »

    Quote from fieroivan »

    Here's my diff that adds the generic GetSellValue api. This works well with ItemPrice and does not need ItemPriceTooltip. It should also work with any other addon providing the GetSellValue function


    This diff doesn't work. Applied properly, with both ItemPrice-1.0 & SellFish (& ItemSync & KC_Items & Ludwig (WoW 2.1) & FuBar_GarbageFu_Prices)) active. Error at logon (3 different logons tested):

    "FuBar_GarbageFu-2.0.29812\\GarbageFu_Vendor.lua:282: attempt to index field '?' (a nil value)\n<in C code>: ?\nAceEvent-2.0-38824 (Ace2):427: in function <Interface\\AddOns\\Ace2\\AceEvent-2.0\\AceEvent-2.0.lua:403>"

    And every single time you mouse over the GarbageFu "Vendor price addon order" entry in the option menu flyout, the menu doesn't open and the following error occurs:

    "FuBar_GarbageFu-2.0.29812\\GarbageFu_Vendor.lua:311: attempt to index field '?' (a nil value)\nFuBar_GarbageFu-2.0.29812\\GarbageFu.lua:741: in function `OnMenuRequest'\nFuBarPlugin-2.0-34599:1104: in function <...\\FuBarPlugin-2.0\\FuBarPlugin-2.0\\FuBarPlugin-2.0.lua:1081>\nDewdrop-2.0-39294 (DewdropLib):1992: in function <...erface\\AddOns\\DewdropLib\\Dewdrop-2.0\\Dewdrop-2.0.lua:1941>\nDewdrop-2.0-39294 (DewdropLib):2871: in function <...erface\\AddOns\\DewdropLib\\Dewdrop-2.0\\Dewdrop-2.0.lua:2830>\nDewdrop-2.0-39294 (DewdropLib):548: in function <...erface\\AddOns\\DewdropLib\\Dewdrop-2.0\\Dewdrop-2.0.lua:532>"

    On the other hand, the ItemPrice-1.0 & ItemPriceTooltip dependent hack in this different post works just fine with no errors. Well, it loads properly, still need to see if it actually retrieves values from ItemPrice properly ;).

    Yes, adding a real (ItemPrice-1.0) library dependency instead of the way this hack works would be better. Would be good to have ItemPrice fully supported. Testing out SellFish with FuBar_Usage (CPU profiling active), it does not use much memory, like ItemPrice. But SellFish uses an incredible amount of CPU time. Nice work on the changes so far.

    You may have some bad values in your garbagefu's savedvariable. I saw similar things happen during testing when an invalid price source was present in there. It should be in the main savedvariables folder if im remembering correctly, but it might be in the char specific one.
    Posted in: FuBar AddOns
  • To post a comment, please or register a new account.