• 0

    posted a message on Unofficial oUF - methods used for layouts
    local updateName = function(self, event, unit)
    if(self.unit == unit or (not unit and self.unit)) then
    local unit = unit or self.unit
    local name = UnitName(unit)
    local index = GetRaidTargetIndex(self.unit)
    if(UnitIsTapped(unit) and not UnitIsTappedByPlayer(unit) or not UnitIsConnected(unit)) then
    self.Name:SetTextColor(.6, .6, .6)
    else
    self.Name:SetTextColor(1, 1, 1)
    end

    if(unit ~= "targettarget") then
    updateLevel(self, event, unit);
    end

    if(unit == "target") then
    if(index) then
    self.Name:SetText(ICON_LIST[index].."22|t"..name)
    else
    self.Name:SetText(name)
    end
    elseif(self:GetParent():GetName():sub(1, 8) =="oUF_Raid") then
    self.Name:SetText(strsub(name,0,4))
    else
    self.Name:SetText(name)
    end
    end
    end


    I would like a fix too, of course :O

    Btw, how do you do the "Code-Quote"? ^^
    Posted in: Unit Frames
  • 0

    posted a message on Unofficial oUF - methods used for layouts
    Quote from gooxen »

    ah! okay, I'll try that :)

    Edit: Put it at the buttom of the lua, now I can see my bars etc but I still get the error message and I dont get any "tick"


    Updated on WoWI, just wait a bit ;D Wanted to do it Yesterday but couldn't test it due some weird Internetprobs :S
    Posted in: Unit Frames
  • 0

    posted a message on UI Screenshots - Show us what you use!
    Just Some little Tweaks.

    klick me
    Posted in: General Chat
  • 0

    posted a message on Unofficial oUF - methods used for layouts
    Is there a way to set the bartexture from Powerbar different to what you use on the Powerbar? Messing around with Textures and found one that is "passable" but something else than Smoothv2, wich i had for nearly an half yoar now^^

    Just that the Powerbar is not clearly visible and therefore i would use another path, but whenever i used another Path, or another name for the texture than "statusbar" its not showing up at all, leaving the place blank :<

    Here's a Pic

    Posted in: Unit Frames
  • 0

    posted a message on UI Screenshots - Show us what you use!
    Quote from Velveeta »

    My Hunter low-mem attempt:

    *snip*


    Whats the Font you are using on SCT(or whatever it is)?
    Posted in: General Chat
  • 0

    posted a message on UI Screenshots - Show us what you use!
    Quote from Coldfury »

    add this to pBuff.lua and it should do the trick.
    function BuffButton_UpdateAnchors(buttonName, index, filter)
    	local rows = ceil(BUFF_ACTUAL_DISPLAY/BUFFS_PER_ROW);
    	local buff = getglobal(buttonName..index);
    	local buffHeight = TempEnchant1:GetHeight();
    
    	if ( filter == "HELPFUL" ) then
    		if ( (index > 1) and (mod(index, BUFFS_PER_ROW) == 1) ) then
    			-- New row
    			if ( index == BUFFS_PER_ROW+1 ) then
    				buff:SetPoint("TOP", TempEnchant1, "BOTTOM", 0, -BUFF_ROW_SPACING);
    			else
    				buff:SetPoint("TOP", getglobal(buttonName..(index-BUFFS_PER_ROW)), "BOTTOM", 0, -BUFF_ROW_SPACING);
    			end
    		elseif ( index == 1 ) then
    			buff:SetPoint("TOPLEFT", BuffFrame, "TOPLEFT", 0, 0);
    		else
    			buff:SetPoint("LEFT", getglobal(buttonName..(index-1)), "RIGHT", 5, 0);
    		end
    	else
    		-- Position debuffs
    		if ( (index > 1) and (mod(index, BUFFS_PER_ROW) == 1) ) then
    			-- New row
    			buff:SetPoint("TOP", getglobal(buttonName..(index-BUFFS_PER_ROW)), "BOTTOM", 0, -BUFF_ROW_SPACING);
    		elseif ( index == 1 ) then
    			if ( rows < 2 ) then
    				buff:SetPoint("TOPLEFT", TempEnchant1, "BOTTOMLEFT", 0, -1*((2*BUFF_ROW_SPACING)+buffHeight));
    			else
    				buff:SetPoint("TOPLEFT", TempEnchant1, "BOTTOMLEFT", 0, -rows*(BUFF_ROW_SPACING+buffHeight));
    			end
    		else
    			buff:SetPoint("LEFT", getglobal(buttonName..(index-1)), "RIGHT", 5, 0);
    		end
    	end
    end



    Works nealy perfect thanks cold =) The only thing is that the Enchants like oil or WF and that are bit messed up, because they are still being placed left to the buffs. But thats not that important, it works and i can place my buffs on the Topleft, thanks therefore ;)

    Modified the Roth texture to be a simple black and white edge.

    Looks nice, i'll give it a try =)
    Posted in: General Chat
  • 0

    posted a message on UI Screenshots - Show us what you use!
    Quote from p3lim »

    No can do, its the default blizzard buffs, just skinned.
    One day im gonna rewrite the whole mod, but not right now. Cant find the time


    Thats a Word. I will wait ;P oh, and thanks =)
    Posted in: General Chat
  • 0

    posted a message on UI Screenshots - Show us what you use!
    p3lim,

    Is there a way to mirror the buffs (let them grow from the left to the right), and scale? I didn't find anything but the TempEnchantFrame :S

    Edit: K, got the scale, just left to set the growth to the right.
    Posted in: General Chat
  • 0

    posted a message on UI Screenshots - Show us what you use!
    Quote from p3lim »

    Nice tooltip, id like to see the savedvariables for that one!


    TipTac, almost Default. Too Busy to Work on a more "lightweight-Standart" Version due other Addons keep bugging at me :O
    Posted in: General Chat
  • 0

    posted a message on UI Screenshots - Show us what you use!
    Still WiP, but it's near the completition =D

    http://s7.directupload.net/file/d/1344/l38s3tyo_jpg.htm
    Posted in: General Chat
  • 0

    posted a message on UI Screenshots - Show us what you use!
    http://s3.directupload.net/file/d/1332/oz6fbhvv_jpg.htm

    Got the Goal to 15mb memusage ;P
    But still, WiP.
    Posted in: General Chat
  • 0

    posted a message on UI Screenshots - Show us what you use!
    WiP:


    Trying to get at max 15mb memusage for now.
    Posted in: General Chat
  • 0

    posted a message on Unofficial oUF - methods used for layouts
    Wow! Thank you very much Cold! =)
    Posted in: Unit Frames
  • 0

    posted a message on Unofficial oUF - methods used for layouts
    Thanks.

    This is the code i used:
    local raid1 = oUF:Spawn"raid1"
    raid1:SetPoint("CENTER", 0, 0)
    raid1:SetHeight(18)
    raid1:SetWidth(130)
    local raid2 = oUF:Spawn"raid2"
    raid2:SetPoint("TOPLEFT", raid1, "BOTTOMLEFT", 0, -4)
    raid2:SetHeight(18)
    raid2:SetWidth(130)

    (just these two atm, for configuration)

    But there is an error (nil value) '~' I think thats why you said it depends the way the frames are spawned?^^
    Posted in: Unit Frames
  • To post a comment, please or register a new account.