• 0

    posted a message on WoW UI Updater (Win/OSX/Linux, supports multiple sites), 1.6 thread
    To get Auctioneer going again, I did the following:

    1) Right click -> Delete existing Auc-Advanced addon and all related addons
    2) Install via URL... -> http://wow.curse.com/downloads/wow-addons/details/auctioneer.aspx
    3) DONE
    Posted in: Updaters
  • 0

    posted a message on WoW UI Updater (Win/OSX/Linux, supports multiple sites), 1.6 thread
    Quote from lejordet »

    1.8.587 beta 1.8 RC1 (2008.08.18)


    I just upgraded but am still getting the same error on my XP box:
    2008-08-20 20:47:23: (WARN) Download of Auc-Advanced failed, URL=http://mirror.auctioneeraddon.com/dl/Packages/AuctioneerAdvancedSuite-5.0.PRE.3342.zip: [Error 32] The process cannot access the file because it is being used by another process: u'c:\\docume~1\\daddy\\locals~1\\temp\\Wurm\\Auc-Advanced-r20080811.zip


    I don't have this problem when updating on my Linux box. I'm guessing it has something to do with the order the file is being accessed since Windows has stupid file locking rules. Any ideas?
    Posted in: Updaters
  • 0

    posted a message on WoW UI Updater (Win/OSX/Linux, supports multiple sites), 1.6 thread
    I'm getting the following error when trying to update Auctioneer-Advanced:

    2008-08-17 19:05:09: (WARN) Download of Auc-Advanced failed, URL=http://auctioneeraddon.com/dl/Packages/AuctioneerAdvancedSuite-5.0.PRE.3342.zip: [Error 32] The process cannot access the file because it is being used by another process: u'c:\\docume~1\\daddy\\locals~1\\temp\\Wurm\\Auc-Advanced-r20080811.zip'


    The file it complains about doesn't exist until I start the update so I really have no idea what other process could be getting in the way. All of my other WowAce & Curse addons are updating without any problems.

    Any ideas?
    Posted in: Updaters
  • 0

    posted a message on WoW UI Updater (Win/OSX/Linux, supports multiple sites), 1.6 thread
    Quote from lejordet »

    ...
    1.7.567 beta (2008.04.30):
    ...
    * Bugfix: List control IDs (hashing removed, should fix problems on Linux 64 bit)


    Woot! This works! Thank you very much lejordet!
    Posted in: Updaters
  • 0

    posted a message on WoW UI Updater (Win/OSX/Linux, supports multiple sites), 1.6 thread
    Quote from kyleki »

    Here's what I get:

    shell$ python -i
    Python 2.5.1 (r251:54863, Oct 30 2007, 13:45:26) 
    [GCC 4.1.2 20070925 (Red Hat 4.1.2-33)] on linux2
    Type "help", "copyright", "credits" or "license" for more information.
    >>> hash(0xFFFFFFFF0)
    68719476720
    >>> hash(hash(0xFFFFFFFF0))
    68719476720


    Python installed on my Fedora 8 box from the following RPM (via regular yum updates):
    python-2.5.1-15.fc8.x86_64


    lejordet, did this information help narrow down the 64-bit linux sorting issue? Is there anything else I can provide?
    Posted in: Updaters
  • 0

    posted a message on WoW UI Updater (Win/OSX/Linux, supports multiple sites), 1.6 thread
    Quote from lejordet »

    Could you run "python -i" and try the following for me?

    >>> hash(0xFFFFFFFF0)
    -2
    >>> hash(hash(0xFFFFFFFF0))
    -2



    Here's what I get:

    shell$ python -i
    Python 2.5.1 (r251:54863, Oct 30 2007, 13:45:26) 
    [GCC 4.1.2 20070925 (Red Hat 4.1.2-33)] on linux2
    Type "help", "copyright", "credits" or "license" for more information.
    >>> hash(0xFFFFFFFF0)
    68719476720
    >>> hash(hash(0xFFFFFFFF0))
    68719476720


    Python installed on my Fedora 8 box from the following RPM (via regular yum updates):
    python-2.5.1-15.fc8.x86_64
    Posted in: Updaters
  • 0

    posted a message on WoW UI Updater (Win/OSX/Linux, supports multiple sites), 1.6 thread
    Quote from lejordet »


    1.7.556 beta (2008.04.23):
    ...
    * Bugfix: List sorting


    Does this mean the sorting issue on 64-bit Linux machines is supposed to be fixed? If so, it's not working for me. I still can not click the different column headers to sort. :(
    Posted in: Updaters
  • 0

    posted a message on WoW UI Updater (Win/OSX/Linux, supports multiple sites), 1.6 thread
    Quote from lejordet »

    New beta:

    WUU 1.7.553 source/linux
    ...
    A massive list of changes this time, most of them by Jncl - I haven't had much time lately (the usual story :( ), so I half-implement a lot of features, and when bug reports come in I have to finish what I started before I get to look at the new bugs :|


    It appears that the 64bit Linux sort bug is back. :( It only worked for me in the one beta release prior to this one (1.7.548). Any chance of getting sort working again? Simply sorting by AddOn name (Directory) would be *very* helpful.

    Thanks.
    Posted in: Updaters
  • 0

    posted a message on WoW UI Updater (Win/OSX/Linux, supports multiple sites), 1.6 thread
    Quote from lejordet »

    WUU 1.7.547 win32
    WUU 1.7.547 osx
    WUU 1.7.547 osx light version
    WUU 1.7.547 source/linux

    MD5 sums:
    e2fc4347ae6331f98b987cbbbb00cbd4 *WUU-1.7.547.zip
    4ff18e45016f6052290864297e42a0dd *WUU-1.7.547.dmg
    691e55ece510e03b55acdabc94559ddc *WUU-1.7.547-light.dmg
    270dd9ba697d391b328d9f80c32d6224 *WUU-1.7.547-src.zip


    1.7.547 beta (2008.04.03):

    * Bugfix: RAR handling
    * Bugfix: List sorting on 64 bit Linux(+Windows?)
    * Made dependency check case insensitive
    * Added display of which addons are missing the dependencies in the popup

    (Yes, I'll eventually add a setting to disable the automatic dependency checking, and add a manual version of it to the menu)


    WOOT! Sorting on my 64bit Linux box finally works! Thank you! Thank you! Thank you!!!
    This awesome program is now feature complete for me. Check your paypal account for a little "thank you". ;-)
    Posted in: Updaters
  • 0

    posted a message on WoW UI Updater (Win/OSX/Linux, supports multiple sites), 1.6 thread
    It appears the auctioneeraddon site has changed slightly. WUU was able to see that there was a new version available, but couldn't download it. I kept seeing the following error in the log:

    2007-11-29 15:23:54 (WARNING) Download of Auc-Advanced failed, URL=http://media.auctioneeraddon.com/dl/Packages/AuctioneerAdvancedSuite-5.0.PRE.2603.zip: HTTP Error 404: Not Found


    To fix this, I modified line 1228 in Wurm.py and took out the 'media' part of the url so it now looks like this:
    self.dlURLprefix = "[url]http://auctioneeraddon.com/dl/Packages/"[/url]


    Now Auctioneer is updating like a champ!
    Posted in: Updaters
  • 0

    posted a message on WoW UI Updater (Win/OSX/Linux, supports multiple sites), 1.6 thread
    I can't figure out how to sort the list of addons in the client on Linux. Running in WindowsXP, I get a little arrow icon in the column header showing what is being sorted on. In Linux, this icon is never shown.

    I've tried double-clicking and right-clicking the column headers, but nothing happens.

    Here's what I'm running from:
    WUU 1.6.477
    Fedora 8
    Python 2.5.1
    wxPython 2.8.4

    BTW, the link at the top of wuu.vagabonds.info into this forum should link to this thread rather than the one for the old version as it does now.

    Thanks,
    Kyle
    Posted in: Updaters
  • 0

    posted a message on WoW UI Updater (Win/OSX/Linux, supports multiple sites), 1.6 thread
    Quote from Jncl »

    Hi kyleki,

    Try using the settings in the attached picture, it worked for me :)


    Thanks! That gave me enough info to figure it out, although I had to use some slightly different values. See the attached image. The truncated value is:
    http://media.gathereraddon.com/dl/GathererDB/%(name)s%(ver)s.%(ext)s

    (since the dialog isn't resizable) :(
    Posted in: Updaters
  • 0

    posted a message on WoW UI Updater (Win/OSX/Linux, supports multiple sites), 1.6 thread
    Quote from lejordet »

    I tried this, and I found that I could use the settings you had above, but after that I had to set the [Related] folder Auc-Advanced (which is the real main folder) to the following:
    AddonDirectory: Auc-Advanced
    Friendly Name: Auc-Advanced
    Source Site: Auctioneer
    SiteID: AuctioneerAdvancedSuite

    Finally I deleted the old AuctioneerAdvancedSuite addon (which will delete all related, too), and re-updated Auc-Advanced.


    This worked great! Thanks!

    Is there a similar "trick" to get GathererDB_Wowhead working? I've tried a few things, but I can't get WUU to manage this AddOn.
    Posted in: Updaters
  • To post a comment, please or register a new account.