CurseForge and Overwolf are joining forces!
Awesome More Information
  • 0

    posted a message on WoW UI Updater (Win/OSX/Linux, supports multiple sites), 1.6 thread
    New thread over here

    Posted new version 1.9.640 there, with these changes:
    1.9.640 (2009.04.29):
    • Feature fix: Applied MacPorts compatibility patch by WoWAce forums user hamaw
    • Bug fix: Crash when the download "guess" found multiple possible matches
    Posted in: Updaters
  • 0

    posted a message on WoW UI Updater 1.9 Thread (Windows/OSX/Linux, multiple sites)


    WUU is a program to keep your WoW addons up-to-date, regardless(well, almost, see the FAQ further down) of which site you get them from - WoWAce, WoWInterface, CurseGaming, AuctioneerAddon, GathererAddon, CosmosUI, CTMod, CapnBry, GoogleCode (plus SVN) and DeadlyBossMods are explicitly supported, while the OtherSites module can be used to update addons from, well, other sites. There is also some general Git support.

    Some of the features are:

    • One-button update of your addons (except Curse, due to recent changes)
    • Works on Windows, Linux and Mac OS X
    • Simple interface for installing from CosmosUI
    • Changelog report after updating
    • Can use the Coral CDN to save the sites' bandwith, and make patch day upgrading faster
    • Automatic self-updater (with cryptographically signed download)


    Download the newest (stable) version here:
    WUU 1.9.640 win32
    WUU 1.9.640 osx
    WUU 1.9.640 osx light version
    WUU 1.9.640 source/linux
    WUU 1.6.446 osx/Tiger (it will self-update to the latest version, but includes Tiger versions of libraries)

    To get the Windows version of 1.8.605 (and above) to run, you might need this package from Microsoft: Visual C++ 2008 SP1 Redistributable Package - especially if you get an error message about "Windows Side-by-Side" or "application configuration".

    MD5 sums:
    651f0e3e73cd1c57dabeca99f24e6f79 *WUU-1.9.640.zip
    8d49c99b1d88806a0c9d45d63daf4fe0 *WUU-1.9.640.dmg
    4879a99c30d310fb71517a8d24124c6d *WUU-1.9.640-light.dmg
    207d2967eb306ce143af31a96a8cf934 *WUU-1.9.640-src.zip
    
    052fb14d25762672977a51de14301936 *WUU-1.6.446.dmg
    (Beta versions are usually posted in the thread, and/or WUU can tell you about them if you enable "Allow WUU beta version" in Preferences)

    Version history

    Getting started
    Due to addons being available from multiple sites, WUU can be a bit tricky to get started with.
    There are some instructions here, which should at least get you most of the way :) Backup your addons before you try WUU, just in case ;)

    Relevant links:
    WUU home page
    WUU wiki
    SourceForge project
    WUU FAQ

    First WoWAce thread
    WoWAce thread for WUU 1.6-1.8

    SA thread for WUU 1.6-1.8
    Posted in: Updaters
  • 0

    posted a message on WoW UI Updater (Win/OSX/Linux, supports multiple sites), 1.6 thread
    Quote from eNTi
    that's something that would interest me too.


    If you have the folder DBM-Core, set it to site "DBM" and site id "1" (of course without the quotes)
    Posted in: Updaters
  • 0

    posted a message on WoW UI Updater (Win/OSX/Linux, supports multiple sites), 1.6 thread
    Quote from Kring
    I have an old copy of 1.8.605 on my disk. With this version, I can check the curse version. With 1.9.635 I cannot. What changed? :-(


    Nothing in the version check AFAIK :/ Have you tried clearing out %USERPROFILE%\WUU (after a backup ofc :))?
    Posted in: Updaters
  • 0

    posted a message on WoW UI Updater (Win/OSX/Linux, supports multiple sites), 1.6 thread
    Quote from hamaw
    quick hack for MacPorts.

    diff -c WUU-1.9.635-src/RarFile.py WUU-1.9.635-src_MacPorts/RarFile.py
    *** WUU-1.9.635-src/RarFile.py    2009-04-21 19:33:12.000000000 +0900
    --- WUU-1.9.635-src_MacPorts/RarFile.py    2009-04-28 19:32:38.000000000 +0900
    ***************
    *** 42,51 ****
    --- 42,56 ----
      # try the default directory
      if not rar and sys.platform == 'darwin':
          ulb = '/usr/local/bin'
    +     olb = '/opt/local/bin'
          if os.path.isfile(os.path.join(ulb, 'unrar')):
              rar = os.path.join(ulb, 'unrar')
          elif os.path.isfile(os.path.join(ulb, 'rar')):
              rar = os.path.join(ulb, 'rar')
    +     elif os.path.isfile(os.path.join(olb, 'unrar')):
    +         rar = os.path.join(ulb, 'unrar')
    +     elif os.path.isfile(os.path.join(olb, 'rar')):
    +         rar = os.path.join(ulb, 'rar')
    diff -c WUU-1.9.635-src/WurmCommon.py WUU-1.9.635-src_MacPorts/WurmCommon.py
    *** WUU-1.9.635-src/WurmCommon.py    2009-04-21 23:16:10.000000000 +0900
    --- WUU-1.9.635-src_MacPorts/WurmCommon.py    2009-04-28 19:31:25.000000000 +0900
    ***************
    *** 577,582 ****
    --- 577,585 ----
              if os.path.isfile(os.path.join('/usr/local/bin', scmClient)):
                  scmClient = os.path.join('/usr/local/bin', scmClient)
                  hasClient = True
    +         elif os.path.isfile(os.path.join('/opt/local/bin', scmClient)):
    +             scmClient = os.path.join('/opt/local/bin', scmClient)
    +             hasClient = True


    Thanks! Applied!

    (I assume you meant the following:
    +     elif os.path.isfile(os.path.join(olb, 'unrar')):
    +         rar = os.path.join([COLOR=SeaGreen][B]olb[/B][/COLOR], 'unrar')
    +     elif os.path.isfile(os.path.join(olb, 'rar')):
    +         rar = os.path.join([COLOR=SeaGreen][B]olb[/B][/COLOR], 'rar')
    Posted in: Updaters
  • 0

    posted a message on WoW UI Updater (Win/OSX/Linux, supports multiple sites), 1.6 thread
    Quote from kring1
    For me, it stopped working sice the version after WUU 1.9.615.

    I get these errors when I check the version of a curse add-on:
    2009-04-25 14:01:36: (WARN) Could not find AHsearch update date on page - is site ID correct?
    2009-04-25 14:01:37: (WARN) Could not find AllPlayed update date on page - is site ID correct?
    2009-04-25 14:01:38: (WARN) Could not find AltClickToAddItem update date on page - is site ID correct?
    2009-04-25 14:01:39: (WARN) Could not find Atlas update date on page - is site ID correct?
    2009-04-25 14:01:42: (WARN) Could not find AuctionMeOff update date on page - is site ID correct?
    2009-04-25 14:01:43: (WARN) Could not find AuctionProfit update date on page - is site ID correct?


    That seems to indicate WUU can't reach any web site at all; can you update non-Curse addons fine?
    Posted in: Updaters
  • 0

    posted a message on WoW UI Updater (Win/OSX/Linux, supports multiple sites), 1.6 thread
    WUU 1.9.635 win32
    WUU 1.9.635 osx
    WUU 1.9.635 osx light version
    WUU 1.9.635 source/linux

    MD5 sums:
    84d3d47c8649403f5e2862c032b47530 *WUU-1.9.635.zip
    8f1871941470fc9e586cd78e24038e22 *WUU-1.9.635.dmg
    9a592023186d0ee75caede139407cca3 *WUU-1.9.635-light.dmg
    a5562654d227a847b0a113c1d63f2772 *WUU-1.9.635-src.zip

    • 1.9.655 (2009.04.24):
      • Bug fix: Identify from URL for Curse
      • Feature: Added support for Git Public Clone URLs
      • Bug fix: Preferences error when using a translation

    EDIT2: It's done uploading now! :)
    Posted in: Updaters
  • 0

    posted a message on WoW UI Updater (Win/OSX/Linux, supports multiple sites), 1.6 thread
    Quote from o_o
    A nice options I would like to see in WUU is one to delete the hand downloaded files after the "F9 procedure". ^^


    Take a look in Preferences then :D (it's called "Delete after Install")
    Posted in: Updaters
  • 0

    posted a message on WoW UI Updater (Win/OSX/Linux, supports multiple sites), 1.6 thread
    Quote from doxxx
    Using 633 on Vista 64...

    - Still got that error during the upgrade.
    - After upgrade, when I started WUU the window wasn't visible even though there was a button for it on the taskbar. I guessed that it was offscreen and was able to get it back onscreen by right-clicking the taskbar button and choosing Move.
    - Install from URL for Curse could do with a prompt to select the file. I managed to guess that I needed to use Update from file on the new entry in the addon list but not everybody will get that.


    The error would come on that version, yes; your current version of WUU is run to verify the new downloaded version, and that triggers the error - but next time it'll be better :)

    Some of the positioning code might be wonky - and/or might not make sense on Windows (WUU remembers its last position). I'll try without, and/or making an option to never remember.

    More stuff is coming to make the installations easier - the main priority now is to get the ideas out there and see what sticks :D
    Posted in: Updaters
  • 0

    posted a message on WoW UI Updater (Win/OSX/Linux, supports multiple sites), 1.6 thread
    Pshaw! That's clearly the un-cool way of updating your addons on Linux 8)

    Anyhow, Jncl has been busy coding, and the result is:

    WUU 1.9.633 win32
    WUU 1.9.633 osx
    WUU 1.9.633 osx light version
    WUU 1.9.633 source/linux

    MD5 sums:
    7be9fc04025afe4e726a974f8cd29141 *WUU-1.9.633.zip
    6b893a7b0532a68589e1442ab543ee46 *WUU-1.9.633.dmg
    77622a7ad0988a72599e05a5e4c2e992 *WUU-1.9.633-light.dmg
    1e31b76d3c918fea8fd7a991f8280c96 *WUU-1.9.633-src.zip
    1.9.633 (2009.04.21):

    * Libraries: The Windows build is now based on Python 2.6.2 (should fix the "side-by-side" error) and wxPython 2.8.9.2
    * Bugfix: Fixed DeprecationWarning messages in Windows version
    * Feature: Install from URL for the "new" Curse
    * New site: wowui.incgamers.com
    * Feature: Update multiple selected (Curse-only) addons from files
    * Site change: Old WoWAce code removed, support for new WoWAce site added
    * Bug fix: Some missing progress bars were added
    * Feature: Added option to delete downloaded file after successful install

    Of course there are more changes than that under the hood, but these are the major ones :)
    Posted in: Updaters
  • 0

    posted a message on WoW UI Updater (Win/OSX/Linux, supports multiple sites), 1.6 thread
    Quote from lysistrate
    ... I don't know.. He just mentioned a couple of minutes ago that at least something was updated...
    now a question to for lejordet2:

    Is there a way to set the default browser in wuu? which environment variable are you reading on linux?

    I always get konqueror popping up in 1.9 but really like to have firefox....

    edit... ok found the fix myself... after grep'ing your files and reading http://docs.python.org/library/webbrowser.html nvm

    export BROWSER='firefox'
    python ./WUU-1.9.615/main.py

    does the trick..



    Thanks! Adding to the FAQ! :D
    Posted in: Updaters
  • 0

    posted a message on WoW UI Updater (Win/OSX/Linux, supports multiple sites), 1.6 thread
    WoWI seems to have some kind of problems/blocking so that you can't smart-update addons from there, half of them time out if they come in sequence. Updating one and one works just fine.

    There's also reported some problems with addons that have extra folders (where the second folder doesn't have a .toc file). Looking into it.
    Posted in: Updaters
  • 0

    posted a message on WoW UI Updater (Win/OSX/Linux, supports multiple sites), 1.6 thread
    Quote from Mita1
    Does overridesettings.wurm still work ok? I use it to build mod packs. So I have a couple copies of it.


    Yes, I run my test set as overridesettings, so it's one of those features that never go away :)

    However, installing fresh addons from Curse is not working 100% yet, we've just concentrated on the updating - we'll get something working soon.
    Posted in: Updaters
  • 0

    posted a message on WoW UI Updater (Win/OSX/Linux, supports multiple sites), 1.6 thread
    Install from URL is broken for Curse at the moment; It'll be install-from-file later, I think.
    Posted in: Updaters
  • 0

    posted a message on WoW UI Updater (Win/OSX/Linux, supports multiple sites), 1.6 thread
    Quote from o_o
    Work flawlessly


    Awesome :D I'll make a new thread when the eventual simple bugs are ironed out :P
    Posted in: Updaters
  • To post a comment, please or register a new account.