• 0

    posted a message on WoW UI Updater (Win/OSX/Linux, supports multiple sites), 1.6 thread
    Quote from vithos »

    WUU 1.8.587 on Vista64. two problems. first, this error message is misleading:

    2008-09-08 11:48:44: (WARN) Download of oUF failed, URL=snapshot/oUF-master.zip: [Error 32] The process cannot access the file because it is being used by another process: u'c:\\users\\vith\\appdata\\local\\temp\\Wurm\\oUF-r200809071153.zip'

    the problem was actually that i needed to prepend %(site)s to Download Name Expression, whereas earlier i had to remove it from Addon Information Page

    second issue is this is what it said when it worked:

    2008-09-08 11:57:34: (WARN) No TOC file for oUF
    2008-09-08 11:57:39: (WARN) Skipping forbidden file LICENSE
    2008-09-08 11:57:39: (WARN) Skipping forbidden file elements/
    2008-09-08 11:57:39: (INFO) oUF is updated to 200809071153

    1) why is it skipping the license file?
    2) it didn't really skip that folder, and it shouldn't try to


    The misleading message is a problem yes, it seems it's what Python reports when the file is not a "real" zip file.

    As for the "forbidden" files, I'm not sure: files that have no extension should be accepted (WUU uses a white list for file extensions when unpacking, to prevent potentially dangerous files from being extracted). Not sure why that happens though.

    Quote from vithos »

    Getting errors like this whenever an update on WoW-Interface is "pending approval" (the download link opens a popup with a list of older versions). It also stalls the rest of the updates when using One-Button Update.

    2008-09-17 16:13:41: (ERROR) Installation of SSPVP3 failed: File is not a zip file


    Yeah, I know OBU is a bit "fragile" - fixing it is a tough task at this point, but I'll look at it.

    Quote from sysrage »

    lejordet, I don't suppose you're going to start playing WAR and update this EXCELLENT app to support WAR addons? I've been a huge fan of WUU for a long time. Sad that I can't use it for WAR now. Either way, thanks for an invaluable app.


    The thing is, I barely have time for WUU as it is ;) Such as right now - my last post in this thread was a month ago, where I "promised" to release 1.8 within the next day or so :( Unfortunately (or fortunately) I got some new tasks/new position at work, so I've been trying to finish some old tasks to prepare for it, and generally been working much, and for some reason, I prioritize WUU quite low ;)

    Fixing some of the long-standing bugs in WUU would require ripping out a lot of code and almost writing parts of it from scratch (due to either bad decisions from my side when I started WUU, conditions changing (websites, etc.) so that the original idea doesn't fit the current situation, or plain old "the code grew too complex to maintain").

    Anyhow, I've been stuck on RAR unpacking on Vista 64, and found the issue: 32-bit Python (which I use for WUU) can't use 64-bit 7-zip to unpack files, since I don't get any "feedback" from 7z.exe then. So if you have Vista64, install 32-bit 7-zip ;)

    Anyhow, looking through Jncl's last changes, and releasing 1.8 (non-beta) today!
    Posted in: Updaters
  • 0

    posted a message on WoW UI Updater (Win/OSX/Linux, supports multiple sites), 1.6 thread
    Quote from mita »

    2008-08-22 14:18:40: (WARN) c:\docume~1\mita\locals~1\temp\Wurm\BetterGuild-r20070703.zip is really a RAR file - renaming
    2008-08-22 14:18:40: (ERROR) Installation of BetterGuild failed: need more than 3 values to unpack

    I keep getting this error

    7315-BetterGuild from wowinterface

    http://www.wowinterface.com/downloads/info7315-BetterGuild.html



    Thanks! I've FINALLY traced this bug, but have problems fixing it :( Will work on it some more tomorrow (kinda need it fixed for 1.8)
    Posted in: Updaters
  • 0

    posted a message on WoW UI Updater (Win/OSX/Linux, supports multiple sites), 1.6 thread
    Quote from pastafarian »

    Hi, I seem to have a problem. Currently, when I use the release version (1.6 something) everything works fine, but when I upgraded to the newest beta version (1.8 something) the program doesn't launch at all. I have deleted all the .wurm files on my computer, and that didn't help any. Then I temp. renamed my interface folder and made a new one, and then the program launched.

    I currently have a little over a thousand addons in my interface folder, which I really don't have time to delete as I get new ones, I just keep the old ones I never use in there.

    I don't know if there is a special command or what that I can use to run a debug log when the program runs or anything.


    There should be a log in %USERPROFILE%\WUU with some debug info - I've tested WUU (early 1.7 at least) with 600 addons, but there shouldn't be any limits unless I've forgotten something :) I'll try a couple thousand addons tomorrow, delaying 1.8 for a day.
    Posted in: Updaters
  • 0

    posted a message on WoW UI Updater (Win/OSX/Linux, supports multiple sites), 1.6 thread
    Quote from thorkull »

    Hey, lejordet, I have a problem on my iMac when trying to run WUU. It was working fine, but a couple of weeks ago I reinstalled the latest beta (at the time). Ever since, it crashes when I try to run it, regardless of the version. It doesn't matter if it's the latest stable version or the newest beta. Here's the output from the crash report:

    Any suggestions on how to fix this?

    btw, thanks for making the best updater for WoW :)


    Have you tried the light version? Also, the log seems to indicate you run it directly from the .dmg (which should be supported, but still), could you copy it somewhere else and try it from there?

    Regardless of this, I'll push 1.8 as release later today :)
    Posted in: Updaters
  • 0

    posted a message on WoW UI Updater (Win/OSX/Linux, supports multiple sites), 1.6 thread
    WUU 1.8.587 win32
    WUU 1.8.587 osx
    WUU 1.8.587 osx light version
    WUU 1.8.587 source/linux

    MD5 sums:
    7378c0d08f5efb7d3d3ca1c7af613ada *WUU-1.8.587.zip
    34a3879619fbfd3c9f412c239d3f48d8 *WUU-1.8.587.dmg
    24dea76eac36b1d52949ac1d369d53cc *WUU-1.8.587-light.dmg
    3e6109414087eb3c69fe51dd09a2a1e4 *WUU-1.8.587-src.zip


    1.8.587 beta 1.8 RC1 (2008.08.18):

    * Site fix: AuctioneerAddon now uses mirrors
    * Site fix: Curse download (submitted by Grep/WoWAce forums)

    If all goes well, I push this version as release on Wednesday :D
    Posted in: Updaters
  • 0

    posted a message on WoW UI Updater (Win/OSX/Linux, supports multiple sites), 1.6 thread
    Quote from Grep »

    Not entirely blocked. When I go directly to the URL above for Auc-Advanced, I get the following text:

    --- snip ---

    The URL that you accessed was trying to anonomously download a file from our primary server.

    This can occur if you are using an automated method to download the files, have a firewall that blocks the passing of certain request headers or you are using an anonymizing service.

    We do not currently permit this action when downloading from our primary server.

    If you wish to download our files anonomously, please access the files from the mirror.auctioneeraddon.com server farm insead which distributes the load evenly across our webfarm and helps us manage our bandwidth consumption.

    --- snip ---

    It then provides a link to the file.

    So this should be rather easy to fix, I'd bet.



    That worked perfectly :P One-line fix: change http://auctioneeraddon.com to http://mirror.auctioneeraddon.com in the code.

    Just gotta boot my Mac and I'll release what's most likely 1.8 release candidate 1.
    Posted in: Updaters
  • 0

    posted a message on WoW UI Updater (Win/OSX/Linux, supports multiple sites), 1.6 thread
    Quote from Mrs. Steele »

    This is definitely my favorite updater. Live long and prosper! :)


    Thanks! :D

    Quote from kyleki »

    I'm getting the following error when trying to update Auctioneer-Advanced:

    2008-08-17 19:05:09: (WARN) Download of Auc-Advanced failed, URL=http://auctioneeraddon.com/dl/Packages/AuctioneerAdvancedSuite-5.0.PRE.3342.zip: [Error 32] The process cannot access the file because it is being used by another process: u'c:\\docume~1\\daddy\\locals~1\\temp\\Wurm\\Auc-Advanced-r20080811.zip'


    The file it complains about doesn't exist until I start the update so I really have no idea what other process could be getting in the way. All of my other WowAce & Curse addons are updating without any problems.

    Any ideas?


    I got the same error yesterday, going to debug later today - I hope.
    Posted in: Updaters
  • 0

    posted a message on WoW UI Updater (Win/OSX/Linux, supports multiple sites), 1.6 thread
    Quote from gi2k15 »

    At least now we know lejordet didn't die! lol

    Keep up the goor work, man! =)


    Nope, not dead :) Just a rather spontaneous vacation last week :D

    I have a plan for a full re-code of WUU, but I don't think it's "worth it" before we see what happens with WoWAce and Curse (also, I have a lot of other projects, not to mention actually playing the game - WUU was started when I took a break from playing :))
    Posted in: Updaters
  • 0

    posted a message on WoW UI Updater (Win/OSX/Linux, supports multiple sites), 1.6 thread
    Quote from mita »

    Will the changes to Wowace and curse having their own updater affect Wowui?

    Also curse is not updating for me also.




    To be honest, I don't know much about the changes - I barely glanced at the threads earlier this morning, but couldn't get a full picture. I'll probably look into it when I get time, but WUU (and any other "third-party" addon manager) is pretty much a freeloader on this site, so I guess we won't get high priority.

    As for me, I'll keep updating WUU as long as it actually does some work and people use it - and if that day comes when it's basically useless (and/or the number of bugs overtake the number of active users ;)) I'll release whatever I have as the "final" version and let that be the end of it.

    To quote the "future of WoWAce" thread:
    Quote from Kaelten »

    No the new WowAce will have project pages. As far as the third party updaters, in the future we are looking at the possibility of having an api for third party updaters. However it'd be a feature for Premium users. I'm not sure of any timelines on when that'll become a reality and I can't promise anything, but I am working to get this pushed through.

    (emphasis mine)

    I'll probably implement this API when it becomes available - I try to keep WUU as friendly to the addon pages as possible (with regards to bandwidth usage and general hitting of pages), but other than that I guess WUU development won't be very active after I release 1.8 - there's little new to do, and the major bugs/problems require huge changes in code to "work right" (the things you've learnt to accept as "WUU peculiarities", and that every new user posts in this thread when they start using the program ;))
    Posted in: Updaters
  • 0

    posted a message on WoW UI Updater (Win/OSX/Linux, supports multiple sites), 1.6 thread
    Thanks, Grep!

    I just got home from vacation, and I'm dead tired from being on the move for about 10 hours, but I pushed your change to SVN and auto-update, so all clients should have it now :)
    Posted in: Updaters
  • 0

    posted a message on WoW UI Updater (Win/OSX/Linux, supports multiple sites), 1.6 thread
    WUU 1.7.584 win32
    WUU 1.7.584 osx
    WUU 1.7.584 osx light version
    WUU 1.7.584 source/linux

    MD5 sums:
    7332c05e11b5e0279118d8cde583e0d1 *WUU-1.7.584.zip
    26e3092284c35319649ab3e29c91e4eb *WUU-1.7.584.dmg
    a619bf2581dceeb5db8ca608dd01fd62 *WUU-1.7.584-light.dmg
    d4cd813b7478a5fb237c54c2d3958c5b *WUU-1.7.584-src.zip


    1.7.584 beta (2008.08.05):

    * Bugfix: "NoneType is not iterable"
    * Better handling of website issues when smartupdating
    * Bugfix: RAR file unpacking on non-Windows platforms

    I still have some minor bugs to fix here, but they require lots of fine tuning to work correctly :(
    Posted in: Updaters
  • 0

    posted a message on WoW UI Updater (Win/OSX/Linux, supports multiple sites), 1.6 thread
    Quote from OrionShock »

    thread = TLDR, sorry.

    Wondering / 2 feature requests

    1) Generic SVN Support, so that all you put in for a Site ID is a proper svn path - or it auto detects the directory (or it's flaged) and just does a svn up on it.

    2) Generic git Support. Either same, automatic interaction or flagging of the directory. because git is much more complicated than svn we figured out that it should do a few things first so it dosn't mess things up.
    IIRC and someone is going to need to correct me, but it was "git fetch" then do a compare of the local structure and make sure it's not been locally modified then do a "git pull" else warn the user and keep moving. as a beta tester we're prolly not going to be making local changes but if it's an author we don't want to loose local changes.


    1) SVN is definitely something I'll implement, since that's fairly easy to handle (revision numbers are ever increasing, so a newer version is easy to detect)

    2) Git, however, is something I don't know much about - I played a bit with Git on Windows, and it doesn't have any "version numbers" per se, so I guess a major change on some level would have to be done to handle "version number-less" addons (looking for changes would be one way to do it, the other way is to assume it's updated and just "git fetch" every time)

    Uploading a new version with some bug fixes right now, hoping to get 1.8 out before September ;)
    Posted in: Updaters
  • 0

    posted a message on WoW UI Updater (Win/OSX/Linux, supports multiple sites), 1.6 thread
    Quote from gi2k15 »

    Both unchecked.

    EDIT: I did as Shadout said, selected manually the addons and tried to identify them. It worked.


    Okay, have tracked and fixed this error; just deleted my own addons.wurm.xml and re-identified all addons ;)

    Going to check the bug reports on Sourceforge one last time, fix any problems from there, and do a quick new release.
    Posted in: Updaters
  • 0

    posted a message on WoW UI Updater (Win/OSX/Linux, supports multiple sites), 1.6 thread
    Quote from gi2k15 »

    Now I'm getting this error message when checking the online DB:

    Addons are still flagged as "unknown".



    What are your settings for no-ext and automatic dependency check?
    Posted in: Updaters
  • 0

    posted a message on WoW UI Updater (Win/OSX/Linux, supports multiple sites), 1.6 thread
    WUU 1.7.583 win32
    WUU 1.7.583 osx
    WUU 1.7.583 osx light version
    WUU 1.7.583 source/linux

    MD5 sums:
    0d971e078d38fefff0ebe77c5725af7f *WUU-1.7.583.zip
    2fc6c64e84f29db33456aec2df867ced *WUU-1.7.583.dmg
    15cd1dc540c91bc10e19d0440f1b8ade *WUU-1.7.583-light.dmg
    5201581a59b278a5547c3cce4f5062e9 *WUU-1.7.583-src.zip

    1.7.583 beta (2008.07.27):

    * Bugfix: Delete works again
    * Bugfix: "not enough values to unpack" when updating from WoWAce
    * Bugfix: Crash in type-ahead search
    Posted in: Updaters
  • To post a comment, please or register a new account.