• 0

    posted a message on WoW UI Updater (Windows/Linux/Mac) - supports multiple sites
    Quote from Purity »

    Looking forward to what you do! =) (crosses fingers) =)


    WUU on linux:



    Seems to work just fine - which means it should work just as well on Mac.

    Rough instructions for usage on Mac/Linux:
    1-mac) Install Python 2.4.4 (direct link to the .dmg)
    and wxPython 2.8.
    1-linux) Install Python (preferrably 2.4.4) and wxPython ("emerge wxpython" is all you need on gentoo, for instance)
    2) Download the latest source from the WUU webpage and extract it to a folder
    3) cd into your new folder
    4) python WUU.py
    5) use WUU :D
    6) take a screenshot for me, will ya? (if it works)

    (Note that autoupdating and RAR files won't work on other than Windows, but it should handle them gracefully, at least)

    EDIT2: Simpler instructions without SVN ;)
    Posted in: Updaters
  • 0

    posted a message on WoW UI Updater (Windows/Linux/Mac) - supports multiple sites
    Quote from rophy »

    Small request: if a mod is set to 'ignore', then please don't modify it when I use the 'Update with master list'.


    Ah, right, that's a bug :( I'll fix it in the next release :)
    Posted in: Updaters
  • 0

    posted a message on WoW UI Updater (Windows/Linux/Mac) - supports multiple sites
    Quote from Purity »

    I am an intel mac user also. I am very interested in this!

    At the moment, there are over 140+ files in my addon folder, lol. In my group, I am the addon finder, tester, distributer....this would make my life so much easier and with more time to play. =) ( With addons of course!)


    Anyways, I would be happy to test your mac version to speed things along.


    I'm thinking of making a "lite edition" of the WUU source with minimal external dependencies - that way you can run it in Python on your intel mac ;)

    Some parts of WUU are rather "Windows specific" - the crypto library is only used by the auto-updater (which only works on Windows, for the moment), the unRAR library only works with the supplied .dll, which makes it Windows-only.

    My original post on wuu.vagabonds.info:

    [I]f you want to look at the source, it's freely available from the SVN at SourceForge - you'll need the following to run it:

    * Python (I use 2.4, since some of the libraries below aren't compatible with 2.5 yet)
    * wxPython - GUI library (I use 2.6.3.3 due to compatability issues)
    * PyUnRAR - for unpacking .RAR files
    * ctypes - needed by PyUnRAR (I use 1.0.1)
    * PyCrypto - for digital signatures (I use this Win32 distribution of PyCrypto)
    * ezPyCrypto - a PyCrypto wrapper to do the dirty work (don't install the bundled PyCrypto version)


    ...with few changes, I can eliminate the 4 last libraries, which makes running WUU on Mac/Linux simple :D
    Posted in: Updaters
  • 0

    posted a message on WoW UI Updater (Windows/Linux/Mac) - supports multiple sites
    /dance WUU 1.0.100 /dance


    1.0.100 (2006.12.19):

    * Preliminary icon added (1.0.100)

    Finally :D

    (nope, nothing changed from 0.11.98, except the icon ;))
    Posted in: Updaters
  • 0

    posted a message on WoW UI Updater (Windows/Linux/Mac) - supports multiple sites
    Quote from Malfeus »

    lejordet,
    Thanks, deleting the addons.wurm.xml file did the trick. One issue that came up with updating is that when I update my mods for WoWAce it gives me the embedded versions. Is it possible to have an option setup where it can download without the embedded libraries. Also is there a way to add additional addons sites. (ie: Auctioneeraddon.com)

    Thanks
    Malfeus



    Yeah, I didn't know about the "non-embedded" versions when I started on WUU :) I'll try to make "site specific flags" after I get 1.0 out.

    Also, I made this earlier today:
    ;) (Will be in 1.0, the only feature added, actually)

    (didn't dare to add it in 1.0)
    Posted in: Updaters
  • 0

    posted a message on WoW UI Updater (Windows/Linux/Mac) - supports multiple sites
    Quote from Metacortex »

    Nice Prog,
    is there a way to use it on a MAC?
    That would be fantastic.

    Metacortex


    You can, in theory, run it on Mac/Linux (all the libraries I use are cross-platform), but I've never tested it - the webpage lists what libraries you need. I'm looking into PyInstaller to simplify Linux usage, and py2app to make the equivalent for Mac :) (just have to find someone to lend me some Mac-time, as it's not a platform I'm used to ;))

    I'm also thinking of setting up a Wiki, but I dunno how much use it would get...I've got many functions planned for post-1.0, so I can't wait to get 1.0 out :D
    Posted in: Updaters
  • 0

    posted a message on WoW UI Updater (Windows/Linux/Mac) - supports multiple sites
    Quote from Malfeus »

    Hello-
    I am having a problem with the updater starting. I downloaded and unzip it into a temp directory and ran it a couple times and it worked. So I then just moved it to a different directory. I got an error telling me a file I was trying to move was stilling being used I had to kill task the program and then I completed the rest of the move. When I reopened the updater it ask where my wow directory is just like the very first time I ran it. Once that happens it crashes and pops up a brief error message. (One I couldn't see) So I deleted the directory thinking I could just unzip and start fresh again - but for some reason I keep getting the same error.
    ---
    2006-12-17 17:15: (INFO) Loading UI settings from C:\Games\World of Warcraft\Interface\WUU\settings.wurm.xml
    2006-12-17 17:15: (INFO) Autoloading settings
    2006-12-17 17:15: (INFO) Loading settings
    ---
    When I look in the directory I don't even see a file settings.wurm.xml
    So I am thinking that is the problem but don't know how to fix it.

    Thanks in Advance,
    Malfeus


    Hmm, try deleting C:\Games\World of Warcraft\addons.wurm.xml too, in addition to the other files, and reinstall - also, you can disable the autoupdater in the options (you'll get a friendly dialog with a link to the download page if there's a newer version, instead ;)), seems there's some people the auto updater just plain screws up the install for (or doesn't work at all).

    You can also try using the attached settings file (it's a minimal file with only WoWDir set)
    Posted in: Updaters
  • 0

    posted a message on WoW UI Updater (Windows/Linux/Mac) - supports multiple sites
    Whee, doubleposting!

    WUU 0.11.98 ("1.0 release candidate")

    * Bugfix: Resorting the list while a task is modifying it won't give wrong addons the new version numbers (0.11.98)
    * All files related to WUU internal settings will be saved in the same directory as WUU.exe/.py now (0.11.98)

    ...I think that took care of most of the bugs - if I don't get any bug reports the next couple of days, I'll release it as 1.0 pretty much unchanged :)
    Posted in: Updaters
  • 0

    posted a message on WoW UI Updater (Windows/Linux/Mac) - supports multiple sites
    Quote from ariose »

    I'd try it out, but I already set all my addons manually during a boring AV (I have two monitors :))


    Hahah, welcome to the ONLY way of using WUU before I added the master list (in version 0.8.35, according to my changelog ;))

    Could you send me an export somehow, in case you have addons I can add to the master list? My mail address is on the web page

    EDIT:
    My current UI is defined by these addons: http://wuu.vagabonds.info/files/lejordet20061216.wurm.xml

    And looks like this: (my first attempt at soloing Balinda ;))
    Posted in: Updaters
  • 0

    posted a message on WoW UI Updater (Windows/Linux/Mac) - supports multiple sites
    WUU 0.11.96

    * Bugfix: Merging with master list works again (0.11.96)

    ...yeah.
    Posted in: Updaters
  • 0

    posted a message on WoW UI Updater (Windows/Linux/Mac) - supports multiple sites
    Quote from ariose »

    Looking in the master.addons xml file, right around that column was "Sairén", so I changed it to "Sairen". That sorta fixed it. I loaded it, did addon->scan, addon->update with master list.

    2006-12-16 13:21: (INFO) Merging settings
    2006-12-16 13:21: (INFO) Set Blizzard_AuctionUI to [Ignore]
    ... (Other Blizzard_X lines ommitted)
    2006-12-16 13:21: (INFO) Set Blizzard_TrainerUI to [Ignore]
    2006-12-16 13:21: (INFO) Merged settings, 13 addons updated



    What am I doing wrong?




    It seems the merging is broken right now :( gotta fix that. I've fixed the "Sairén-bug" in the master list, too (manually, yes :P )
    Posted in: Updaters
  • 0

    posted a message on WoW UI Updater (Windows/Linux/Mac) - supports multiple sites
    :o WUU 0.11.95 :o

    * Bugfix: WoWI addons now work correctly (0.11.95)
    * Bugfix: Won't try to auto-update WUU on a non-Windows OS (0.11.95)
    * Curse/WoWI now show correct addon links in the side panel (0.11.95)
    * Added "Upgrade all" menu option (under Addons) - will automatically upgrade all addons with newer online versions (0.11.95)
    Posted in: Updaters
  • 0

    posted a message on WoW UI Updater (Windows/Linux/Mac) - supports multiple sites
    Quote from ariose »

    I tried it, but I couldn't get the master file to work.

    Addon->Scan
    Addon->Update with master list

    All of my addons are [Unknown] except for the Bliz ones which are [Ignore].

    I'm running all the popular ace2 mods and some other popular WowI mods. Any ideas?


    I've seen this happen sometimes due to WUU being strictly case sensitive (as in "ace2" is not an addon, while "Ace2" is...) - I've yet to find a good way to handle that, but it's "on my list" :/

    Anything specific in the log? (There should be a WUU.log in your WUU dir)
    Posted in: Updaters
  • 0

    posted a message on WoW UI Updater (Windows/Linux/Mac) - supports multiple sites
    I should note that I didn't know about WAU when I started on this ;)

    Also, it's specifically coded to use equal or less HTTP requests than a "human browsing" to get the addons/versions, to minimize the load on the respective servers; I think I can tweak it even more with the new layout on http://www.wowace.com/files/ ;D, so that'll be in version 1.0
    Posted in: Updaters
  • 0

    posted a message on WoW UI Updater (Windows/Linux/Mac) - supports multiple sites
    I'll start with a disclaimer and a guarantee:

    While I cannot guarantee that WUU won't destroy your computer and screw up your WoW installation, I can guarantee that it won't steal your passwords and/or identity
    (It's up to you to decide whether you trust me or not :))

    In other words: Try this at your own risk, but I haven't deliberately coded anything that'll do any harm :) Backup your AddOns-directory, at least, before you try it!



    It supports WoWAce, WoWInterface, Curse-Gaming, AuctioneerAddon, GathererAddon, CosmosUI, CTMod, CapnBry, GoogleCode and AceSVN :)

    Download the newest version here:
    WUU 1.6.446 win32
    WUU 1.6.446 os x
    WUU 1.6.446 source

    MD5 sums:
    96c9634839e2eb5001517763c3916bb2 *WUU-1.6.446-src.zip
    da518185adf2c80b4a2819bcc7ab5dae *WUU-1.6.446.zip
    052fb14d25762672977a51de14301936 *WUU-1.6.446.dmg



    The WUU webpage has the description on how to set up and use WUU (plus a comprehensive change log)

    Also, WUU SourceForge project

    For Linux and Mac compatability, see this post - still experimental, and there are some problems, but it's usable :)

    OSX

    (Thanks, Purity!)

    Linux

    Posted in: Updaters
  • To post a comment, please or register a new account.