CurseForge and Overwolf are joining forces!
Awesome More Information
  • 0

    posted a message on Cartographer Error
    Have you found a solution? I, too, am seeing this every time I log in.

    Neph
    Posted in: Map/Minimap AddOns
  • 0

    posted a message on wowace.py - lightweight, cross-platform addon updater
    I am still seeing the unicode problem when trying to update:

    INFO Upgrading Cartographer_Quests from 49771 to 49771
    Traceback (most recent call last):
    File "/home/travis/bin/wowace.py", line 494, in <module>
    _dispatch()
    File "/home/travis/bin/wowace.py", line 490, in _dispatch
    updater.update_all(get_deps=options.get_deps, unpackage=options.unpackage, delete_old=options.delete_old, force=options.force, script=options.script, optimize=options.optimize)
    File "/home/travis/bin/wowace.py", line 130, in update_all
    self.update_addon(addon, get_deps, unpackage, script, delete_old, force, optimize)
    File "/home/travis/bin/wowace.py", line 119, in update_addon
    toc.save()
    File "/home/travis/bin/wowace.py", line 316, in save
    f.write("## %s: %s\n" % i)
    UnicodeEncodeError: 'ascii' codec can't encode characters in position 15-31: ordinal not in range(128)


    In addition, I am getting this error on various plugins:


    INFO Upgrading Cartographer_Mining from 53573 to 53573
    WARNING Cartographer_Mining has a dependency (DewDropLib) which is not installed locally and cannot be found on the server


    I think this is a case-sensitivity issue, as I have "DewdropLib" installed. This is probably more of a bug in the other addons, but it might be worth trying to be less case-restrictive for us Linux (and I suppose those Mac) users.

    Thanks for the help/work on this!

    Neph @ Sentinals
    Posted in: Updaters
  • To post a comment, please or register a new account.