• 0

    posted a message on Plow King - Anyone who wants it, read this and reply.
    Yeah, I totally get where you're coming from - this particular add on is the potential home to so many design pitfalls that it boggles the mind. :)

    I wish I had the clearheadedness (nice word I just made up) to take on the challenge, but I'm afraid the best I can do is offer you my encouragement :)

    Christmas suddenly became worth waiting for this year!
    Posted in: Addon Ideas
  • 0

    posted a message on Plow King - Anyone who wants it, read this and reply.
    Any hope for the desperate among us Wobin? :)
    Posted in: Addon Ideas
  • 0

    posted a message on Prat: Chat Mod Framework
    Quote from krtek »

    ince I'm not using this modules, I haven't tested it. It's merely dry coded. I haven't actually the time to debug it, but feel free to hack and commit a fix if you want. Sorry, but this is not on my priority list, I plan to fix others bugs and add others feature before correcting ChannelsSeparator.

    I've been poking about Confab which has this functionality working flawlessly. In Confab the settings are saved by hooking FCFMessageTypeDropDown_OnClick, and saving the checked custom chat types manually to the user profile, and then reapplying them on login. It should be fairly straightforward to add to ChannelSeparator, but since I'm not really familiar with the Ace2 API, I'm going to pass that up for now - I'll probably have a day off next week, and this could be a fun project to get working!

    The Confab author seems to have had his share of hairpulling over this. First lines of the hooked FCFMessageTypeDropDown_OnClick:  :)
    -- For some reason the game refuses to save these in chat-cache.txt so I have to save them myself.
       if (this.value == "RAID" or this.value == "OFFICER") then
    Posted in: General AddOns
  • 0

    posted a message on Prat: Chat Mod Framework
    I've done some more testing on ChannelSeparator, and I've come to the conclusion that it just doesn't work :) Helpful huh? :)

    Seriously though, I've tried it on clean WoW on two different PCs now, several characters, but only one account though. All of these symptoms are reproducable by me on clean WoW 1.12.1 and newest prat from /files.

    It simply doesn't save settings. Also, while selecting only Officers chat correctly filters out normal Guild spam, selecting Guild always allows Officer to get through too.

    Furthermore, there is no name for the Battleground submenu of the ChatFrame context menu - it's simply a blank space which leads to the submenu containing Battleground and Battleground leader.

    I've kinda spammed this topic with this problem, I'm fully aware of that - but I have yet to receive any acknowledgement or dismissal of what I'm experiencing.
    Posted in: General AddOns
  • 0

    posted a message on Prat: Chat Mod Framework
    Still having the problem that ChannelSeparator doesn't save settings across sessions, I have to reenable Officer in my Officer chatframe each login. Also, while enabling Officer for a ChatFrame will show Officer correctly, selecting Guild still shows both Guild and Officer.
    Posted in: General AddOns
  • 0

    posted a message on Detox
    Quote from Soulmagae »
    and also i seem to be bugged at Hexxer in ZG
    the curse isn't showing in the livelist


    Sounds more like a feature than a bug to me :) when is decursing that one ever a good idea?
    Posted in: General AddOns
  • 0

    posted a message on MageFu
    I've hit a few snags, that you're probably already aware of, but here goes:


    With food amount set to 20, and type set to maximum, I never get more than 10 food.


    Consumes water off of the biggest stack, which means if you have 10 stacks of water you will end up with 10 stacks of 19, then 18, etc

    Error if I don't have any food in my bags and try consuming with <100% hp:
    Core.lua:1278 Attempt to index field 'location' (a boolean value)

    Menu doesn't close after clicking a transport, slightly annoying. I know DewDrop has a "'closeWhenClicked', true" kind of a thing going on, but I don't know how you are building the menu.

    /Quan
    Posted in: FuBar AddOns
  • 0

    posted a message on Plow King - Anyone who wants it, read this and reply.
    Any news from the front on this one? By now, I'm down to DAB and engInventory as the only two of my addons that I'm not quite happy with :)
    Posted in: Addon Ideas
  • 0

    posted a message on Buffalo
    MAJOR bug found!!

    In the .toc you have "Buffalo" instead of "Buffalo |cff7fff7f -Ace2-|r" - my WoW kept crashing and rebooting my pc until I found this issue and corrected it. :P

    Thanks for the clarification on WAU, it had me pulling my hair last night :)
    Posted in: General AddOns
  • 0

    posted a message on CoC
    As far as I can tell from the code, short of some local test prints, it doesn't actually do anything yet.
    Posted in: General AddOns
  • 0

    posted a message on cgCrafty-2.0
    Quote from chuckg »
    You still didn't answer a few of my questions. Give me an example of a common reagent that causes, ie: Large Radiant Shard (I don't have a high lvl enchanter to test).  Is the screen scrolled to another entry? Also, do you have any other mods that might be modifying the crafting frame?  I've tested again and again searching for reagents on crafting and cannot get it to hardlock for me.  I need a common example to work from.


    I guess I wasn't clear.

    It doesn't matter what reagent i search for, what skill I have selected - the narrowest I can get is "searching for reagents in the enchanting tradeskill window". It happens every time, and with EVERYTHING but cgCrafty disabled.

    It must have something to do with enchanting specifically - is enchanting the only tradeskill that doesn't have any categories AT ALL? Everything is at the "root" so to speak. I haven't investigated it much, since I always found the tradeskill API confusing at best, but could the lack of categories be it?
    Posted in: General AddOns
  • 0

    posted a message on cgCrafty-2.0
    Tried 2.0b, same error.

    Sadly I can't get a screenshot of the debug spam, not even with fraps or normal windows prntscrn, but the steps i have to take to reproduce the bug are:

    Log in
    Open enchanting
    Select reagent search
    Type in a reagent

    The window now shows the correct trade skills, and then spams the chatwindow every 7-8ms with:

    Entered cgCrafty:Update
    self.found[1].type=optimal
    self.found[2].type=trivial

    It doesn't matter what I do before, I can search to my heart's content on everything in all my trade windows, but as soon as I search for reagents in enchanting (and only enchanting) it hardlocks wow.

    I tried resizing my chatwindow too see how extensive the spam actually is, and it turns out it already hardlocks after maybe 10 or 12 updates.

    Small "bug" that I fixed myself - when linking crafts that use many reagents it will link 4 reagents at a time - however the crafter item is linked as well, so it's assuming that 5 item links will fit in the 255 char limit, which is very rarely the case. I changed it to 3 reagents instead, and haven't been able to make it "skip" reagents yet.

    if ( mod(i,4) == 0 or i == getn(reagentLinks) ) then

    to
    if ( mod(i,3) == 0 or i == getn(reagentLinks) ) then


    2.0b did fix a "for"-clause bug when 0 name search results were found for me though.

    I love this addon so much... the enchanting UI is probably the worst bit of UI in all of WoW, and that says a lot :) this really takes the sting out of it!
    Posted in: General AddOns
  • 0

    posted a message on AutoRaidIcons
    While I see the usefulness of an addon like this, for Faerlina this would be rather useless - sure Faerlina, one worshipper, and one follower would have the correct marks, but the remaining 4 mobs wouldn't receive one.

    There's no way of distinguishing between mobs with the same name.
    Posted in: Addon Ideas
  • 0

    posted a message on cgCrafty-2.0
    I just had a WoW hard lock - searched for reagents in enchanting, typo'ed "naxus", it updated the window to say "No search results" or something similar, and then after like 0.5s my client froze completely.
    Posted in: General AddOns
  • 0

    posted a message on cgCrafty-2.0
    Thank you! Enchanters are very pleased with you! :)
    Posted in: General AddOns
  • To post a comment, please or register a new account.