CurseForge and Overwolf are joining forces!
Awesome More Information
  • 0

    posted a message on mHud - Official Thread
    I still see this error each time when I for the first time target a mob:
    It happened after I followed your advice about hostile alpha, few posts back.
    Then I added Hostile, Friendly and Neutral to the alpha templates.
    Before that I never got this error.

    Can you look into that please Merl?

    Date: 2008-04-03 18:09:22
    ID: 59
    Error occured in: Global
    Count: 1
    Message: ...nterface\AddOns\mHud\GradientAlpha\GradientAlpha.lua line 92:
    Usage: <unnamed>:SetBlendMode("mode")
    Debug:
    (tail call): ?
    [C]: SetBlendMode()
    ...nterface\AddOns\mHud\GradientAlpha\GradientAlpha.lua:92: ?()
    ...gos\libs\CallbackHandler-1.0\CallbackHandler-1.0.lua:146:
    ...gos\libs\CallbackHandler-1.0\CallbackHandler-1.0.lua:146
    [string "safecall Dispatcher[2]"]:4:
    [string "safecall Dispatcher[2]"]:4
    [C]: ?
    [string "safecall Dispatcher[2]"]:13: ?()
    ...gos\libs\CallbackHandler-1.0\CallbackHandler-1.0.lua:91: SendMessage()
    mHud\mBar.lua:121: SetValue()
    mHud\mBar.lua:17:
    mHud\mBar.lua:17
    [string "safecall Dispatcher[2]"]:4:
    [string "safecall Dispatcher[2]"]:4
    [C]: ?
    [string "safecall Dispatcher[2]"]:13: ?()
    ...gos\libs\CallbackHandler-1.0\CallbackHandler-1.0.lua:91: SendMessage()
    mHud\mHud.lua:184: UpdateBarsForUnit()
    mHud\mHud.lua:198: OnEvent()
    mHud\mHud.lua:128:
    mHud\mHud.lua:128
    [C]: CameraOrSelectOrMoveStop()
    [string "CAMERAORSELECTORMOVE"]:4:
    [string "CAMERAORSELECTORMOVE"]:1

    Posted in: General AddOns
  • 0

    posted a message on Parrot 1.0
    I see the warrior Bloodthirst attack restoring health on both sides.
    Posted in: General AddOns
  • 0

    posted a message on mHud - Official Thread
    Is it correct that I dont see any rage or mana on the Powerbar of the Target? I only checked in PVE btw.
    Posted in: General AddOns
  • 0

    posted a message on InfiniBar-2.0 - Official Thread
    About the Group textboxt edit issue:

    I have a couple of bars.
    One or more use Shift to page:

    When I try to edit another Groupname textbox, and I use the shift key to give me a capital char, then editing stops.
    The moment I press the Shift key, I see the other paging bars page, and Im out of the editbox.
    Posted in: General AddOns
  • 0

    posted a message on InfiniBar-2.0 - Official Thread
    Another error I got when using a Silk bandage:

    Date: 2008-04-03 11:36:34
    ID: 61
    Error occured in: Global
    Count: 1
    Message: ..\AddOns\InfiniBar-2.0\IB_Button.lua line 724:
    GetSpellName(): Invalid spell slot
    Debug:
    [C]: ?
    [C]: GetSpellName()
    InfiniBar-2.0\IB_Button.lua:724: ChannelingStart()
    InfiniBar-2.0\IB_Button.lua:320: ?()
    InfiniBar-2.0\IB_Button.lua:184:
    InfiniBar-2.0\IB_Button.lua:182
    InfiniBar-2.0\IB_Button.lua:1323:
    InfiniBar-2.0\IB_Button.lua:1322
    Posted in: General AddOns
  • 0

    posted a message on PitBull 2.0
    Often I get this error:

    Date: 2008-04-03 11:15:21
    ID: 60
    Error occured in: Global
    Count: 1
    Message: ..\AddOns\PitBull\Spark\Spark.lua line 150:
    attempt to index upvalue 'powerSpark' (a nil value)
    Debug:
    ...tographer\libs\LibRockEvent-1.0\LibRockEvent-1.0.lua:473:
    ...tographer\libs\LibRockEvent-1.0\LibRockEvent-1.0.lua:414
    (tail call): ?

    <3 Pitbull
    Posted in: Unit Frames
  • 0

    posted a message on InfiniBar-2.0 - Official Thread
    Quote from Phanx »

    If you just download the .zip with embedded libs ("externals") there are no dependencies. If you use standalone libs, just look at what's included in the libs subfolder when you download the .zip with embeds, and there's your dependency list; the embeds include not only libs that are directly used by the addon, but also libs that are required by other libs. This strategy works for all addons that use embeddable libs.


    Thx Phanx,
    Im just a newbie at using these kind addons.
    A question then (abit ot, sry):
    How do I use standalone libs if the dependencies are in the addon anyway?
    Do I need to delete the dependencie subfolders of the addon if I use standalone libs?
    Posted in: General AddOns
  • 0

    posted a message on InfiniBar-2.0 - Official Thread
    Quote from jjsheets »

    LibRock-1.0
    LibRockConfig-1.0
    LibRockDB-1.0
    LibRockEvent-1.0
    LibRockTimer-1.0
    LibSpecialEvents-Aura-3.0
    LibRockConsole-1.0
    LibRockHook-1.0
    LibRockModuleCore-1.0
    LibFuBarPlugin-3.0
    LibSharedMedia-3.0
    LibDogTag-3.0
    LibDogTag-Unit-3.0

    These libs themselves may have additional requirements.


    It just needed LibSharedMedia 3.0.
    Ok, I made a new char and loaded just IB + lib and I could edit the textbox without problem.
    Then I logged in om my warr and disabled all addons cept IB + lib and got the same problem on warr profile.
    On empty Default profile all is fine.
    So I gues its somethng in the 'old' settings and think I need to delete it.
    Posted in: General AddOns
  • 0

    posted a message on InfiniBar-2.0 - Official Thread
    Quote from jjsheets »

    As for your issue with the Group Name, I do not experience the same issue. First disable all other addons besides InfiniBar, then test. Tell me if it does the same thing. If not, then one of your other addons is somehow causing this. Find out which one and you can solve your problem. If, however, it acts the same, then I suggest you go into Blizzard's Keybind UI and Reset to Defaults. If you are still having issues after that, then again, I suggest you disable InfiniBar and try the same process in another addon's configuration. If it happens there, it is again, not IB2 causing the problem. I also suggest you clear out your saved variables and remake your ui from scratch.

    Your Possess bar may need to be remade. Also make sure you have the latest Revision of IB2.

    Im trying to run just IB but get all kinds of errors.
    What dependencies do I need to install to run IB?
    Posted in: General AddOns
  • 0

    posted a message on InfiniBar-2.0 - Official Thread
    Still a bug in the textbox at Groupname:

    When I backspace the default text, and wanna start with a capital char (pressing Shift-[char]), the default text pops back in and Im thrown out of the textbox.
    Can you verify that please jj?

    Not sure if you have looked into it already, but I still have it that the possesbar I make for my warrior wont fade out.
    Posted in: General AddOns
  • 0

    posted a message on InfiniBar-2.0 - Official Thread
    Another issue:

    I should setup a possessionbar on every char in case I get a quest mob to posses right?

    When setting up a possession bar on my warr. I check Posses in State Page screen. And at State hiding screen I uncheck both Possess and Fade out, Fade Amount to 0. I setup 12 buttons to Possession. Buttons are empty cus I figure warriors have no pet.
    But, the bar wont fade out.
    It fades out when I do emulation. But when I disable emulation the bar is back.
    Posted in: General AddOns
  • 0

    posted a message on InfiniBar-2.0 - Official Thread
    Another error I receive In Infinibars:

    It happened even after I updated with WAU.

    I cant setup Infinibar anymore...getting this error as soon as I touch anything.

    Edit: it happened after I deleted the whole groupname.
    There is an issue with the first char in a textbox.

    Edit: I solved this by giving the group some name. But it was hard cus each time I tried to type I got thrown out of the editbox. I managed it tho but
    not sure how.

    I guess there should be a check on empty fields?

    Date: 2008-04-01 19:25:06
    ID: 64
    Error occured in: Global
    Count: 1
    Message: ...grapher\libs\LibRockConfig-1.0\LibRockConfig-1.0.lua line 3975:
    attempt to index a nil value
    Debug:
    [C]: ?
    ...grapher\libs\LibRockConfig-1.0\LibRockConfig-1.0.lua:3975:
    ...grapher\libs\LibRockConfig-1.0\LibRockConfig-1.0.lua:3971
    [C]: ?
    ...grapher\libs\LibRockConfig-1.0\LibRockConfig-1.0.lua:3999:
    ...grapher\libs\LibRockConfig-1.0\LibRockConfig-1.0.lua:3993
    ...grapher\libs\LibRockConfig-1.0\LibRockConfig-1.0.lua:3721:
    ...grapher\libs\LibRockConfig-1.0\LibRockConfig-1.0.lua:3666
    ...grapher\libs\LibRockConfig-1.0\LibRockConfig-1.0.lua:3640:
    ...grapher\libs\LibRockConfig-1.0\LibRockConfig-1.0.lua:3602
    Posted in: General AddOns
  • 0

    posted a message on InfiniBar-2.0 - Official Thread
    Quote from codepoet »

    I can't save Target unit in the button config. The txtbox will clear itself if I select another txtbox.
    A addition to the feature would be sequential targeting checking if the target exist, if not try next.
    So you could write "mouseover, target, pet". If mouseover target doesn't exist, try target. Then try pet.

    Keep up the excellent work, you make world of warcraft so infinitely more playable!


    I had this same issue with text boxes...and still have actually.
    Now what happens is...when I try to change the name of a Button Group, at the first couple of chars I type in I get thrown out of the Infinibar setup back to the gamewindow. And after that I cant select any option anymore and have to reload UI.
    Posted in: General AddOns
  • 0

    posted a message on InfiniBar-2.0 - Official Thread
    I got this error while trying to set up a possession bar:

    Date: 2008-04-01 18:58:52
    ID: 63
    Error occured in: Global
    Count: 1
    Message: ..\AddOns\InfiniBar-2.0\IB_Button.lua line 789:
    Usage: IsAttackAction(slot)
    Debug:
    [C]: ?
    [C]: IsAttackAction()
    InfiniBar-2.0\IB_Button.lua:789: HighlightAutoCasting()
    InfiniBar-2.0\IB_Button.lua:599:
    InfiniBar-2.0\IB_Button.lua:584
    InfiniBar-2.0\IB_Button.lua:1290:
    InfiniBar-2.0\IB_Button.lua:1289
    [C]: SetAttribute()
    InfiniBar-2.0\IB_Button.lua:1380: SetCurStateAttr()
    InfiniBar-2.0\IB_Button.lua:1762:
    InfiniBar-2.0\IB_Button.lua:1746
    [C]: ?
    ...Bar-2.0\libs\LibRockConfig-1.0\LibRockConfig-1.0.lua:1978:
    ...Bar-2.0\libs\LibRockConfig-1.0\LibRockConfig-1.0.lua:1900
    ...Bar-2.0\libs\LibRockConfig-1.0\LibRockConfig-1.0.lua:2273:
    ...Bar-2.0\libs\LibRockConfig-1.0\LibRockConfig-1.0.lua:2254
    Posted in: General AddOns
  • 0

    posted a message on mHud - Official Thread
    @Merl:

    That gradient error I talked about few posts back, occurs only once when I enter the game and target someone. After that you wont see the error anymore.
    So, just once at entering game and targetting someone.

    Maybe you have a clue what this can be?
    Posted in: General AddOns
  • To post a comment, please or register a new account.