• 0

    posted a message on JWowUpdater - A new java addons updater for ace2
    Ok, version 1.90 is up now, compiled for java 1.5

    Sorry to everyone who had problems.

    /Rolf
    Posted in: Updaters
  • 0

    posted a message on JWowUpdater - A new java addons updater for ace2
    To everyone having problems with 1.89.

    Im affraid that somehow my java installation got updated to 1.6 whithout me registrering that it happened.

    So i happily compiled 1.89 for 1.6 instead of 1.5 which ive been doing for all the other versions.

    Ill get a 1.5 version up asap, just downloading java 1.5 as we speak.

    /Rolf
    Posted in: Updaters
  • 0

    posted a message on JWowUpdater - A new java addons updater for ace2
    Finally i found the time to put together and finalize some of the suggestions there has been made to JWU.

    I give you:

    1.89:
    - Corrected file browser filter, so it now correctly shows .xml files, and directories. (Package creating/importing)
    - Addons in the list of handled non ace addons, will now block updating that addon from wowace, if it is named precisely as the wowace addon.
    - JWU will now show which addons depend on a lib/embed when its automatically installed.
    - If some error occurs that prevents an addon from updating, JWU should no longer just cycle infinitely.
    - Possible fix for error with access denied in vista, if Wow is installed under Program Files...

    /Rolf
    Posted in: Updaters
  • 0

    posted a message on JWowUpdater - A new java addons updater for ace2
    Quote from Hellno »

    Been using JWoWupdater for a while now.... thanks for bringing sanity to the mod update grind.

    ...

    I am running Vista, Java Version 6 Update 5 with JWoWUpdater.

    Here is a cut and paste from the UI, while it spits out the errors.

    Babble-2.2 was external version, but no-ext flag is set. Scheduling for update.
    BigWigs was external version, but no-ext flag is set. Scheduling for update.
    Name: Babble-2.2 Your Version: 74512.0, Latest: 74512.0 (Out of date)
    Updating....Error: java.io.FileNotFoundException: C:\Program Files\World of Warcraft\Interface\AddOns\Babble-2.2\babblelod.bat (Access is denied)

    ...



    The problem is related to Vista's virtual store, because "Profram Files" is a protected directory windows wont let anything that isnt elevated in UAC touch the files. So its being redirected to a "safe" store, where its allowed to put the files. Unfortunately there is a bug where sometimes, JWU dosent seem to follow the virtual path correctly. As of yet, i can reproduce this error, but cant figure out why its not following the virtual path in some cases, but are in others.

    Your saying you have been using it for a while?

    So this error has only recently started to occour?

    (Maybee we can crack this error then, if we can find what has changed since you started getting errors)

    /Rolf
    Posted in: Updaters
  • 0

    posted a message on Poppins - Official Thread
    When creating a new button and then setting its layout to Around, i get this error:

    [2008/05/15 09:50:15-34-x1]: Poppins-1.0\PopButtons.lua:305: attempt to call method 'SetFramePoint' (a nil value)
    Poppins-1.0\PopButtons.lua:138: in function `Setup'
    Poppins-1.0\Frames.lua:146: in function `AddPopButton'
    Poppins-1.0\Frames.lua:100: in function `Setup'
    Poppins-1.0\Poppins.lua:278: in function `UpdateButtons'
    Poppins-1.0\Poppins.lua:396: in function <Interface\AddOns\Poppins\Poppins.lua:392>
    (tail call): ?:
    <in C code>: ?
    <string>:"safecall Dispatcher[2]":9: in function <[string "safecall Dispatcher[2]"]:5>
    (tail call): ?:
    AceConfigDialog-3.0\AceConfigDialog-3.0.lua:705: in function <...nfig-3.0\AceConfigDialog-3.0\AceConfigDialog-3.0.lua:526>
    (tail call): ?:
    <in C code>: ?
    <string>:"safecall Dispatcher[3]":9: in function <[string "safecall Dispatcher[3]"]:5>
    (tail call): ?:
    AceGUI-3.0\AceGUI-3.0.lua:217: in function `Fire'
    ...ns\Ace3\AceGUI-3.0\widgets\AceGUIWidget-DropDown.lua:68: in function <...ns\Ace3\AceGUI-3.0\widgets\AceGUIWidget-DropDown.lua:64>:
    ...ns\Ace3\AceGUI-3.0\widgets\AceGUIWidget-DropDown.lua:96: in function <...ns\Ace3\AceGUI-3.0\widgets\AceGUIWidget-DropDown.lua:90>:
    
     ---


    Also when i unlock the buttons to drag them, it colors my chat blue, ie. as if it was a button i could drag with.

    /Rolf
    Posted in: General AddOns
  • 0

    posted a message on JWowUpdater - A new java addons updater for ace2
    Quote from Funkydude »

    I just noticed a very odd, and probably rare bug. So I open up 'Non WoWAce Addons' and add in like 6 or 7 addons from WOWINT that didn't exist in my addons folder, then 'Accept'.

    Nothing happens, yet.

    I open 'Install New Addons' and tick a wowace addon, then click 'Install'.

    The updater starts downloading all the WoWINT addons, then the wowace addons, and then freezes.

    http://i25.tinypic.com/n209vm.jpg
    (The bar looks stopped, but it's moving left/right, stuck at 100%)

    Besides the wierd 'freeze', everything seemed to download ok, apart from the mysterious appearance of a '__MACOSX' folder in my addons folder containing a 'PerfectRaid' folder and a '._PerfectRaid' file. This was one of the addons I ticked from WOWINT, but it did add a normal copy into my addons folders, this seems to be an extra.


    Sounds like its just the Swing thread in jave that is crashed. This will result in wierd behaviour of the ui, but addon updating should still be ok.

    Regarding the __MACOSX and _PerfectRaid folders, that must be something that is actually present in the zip file it downloads from wowint, because JWU should not make such folders by itself :)

    /Rolf
    Posted in: Updaters
  • 0

    posted a message on JWowUpdater - A new java addons updater for ace2
    Quote from poturta »

    I to am having the problem of when checking for updates it just falls over and says it can't connect. I see it trying to connect to 69.72.129.35:80 and since I can browse to that ip then it means there is nothing stopping the updater reaching that ip (80 is the default http port your browser uses) and there must be something wrong in the code.

    also on a side note if I ping files.wowace.com it resolves to 69.72.129.35 but if I put this in my browser I end up at the curse ace listing odd


    First i would like to point out, that just because you can reach the ip from your browser, dosent mean that you cant have a firewall preventing other programs from reaching it.

    Programs like Zonealarm, Outpost Firewall and many other software firewalls prevent internet access on a per program basis, so 1 program can be alowed to use port 80, while others are not.

    So first check that if you have a software firewall, that its allowing JWU to get to the internet.

    Secondly make sure you shouldnt be using a proxy, if your using a proxy within your browser, you could try and copy the proxy settings over to JWU's proxy setting.

    /Rolf
    Posted in: Updaters
  • 0

    posted a message on JWowUpdater - A new java addons updater for ace2
    Quote from Skru »

    Hi all, sorry if this is a noob question but over the last week I am getting the info below on all my updates:
    Update started: AUTO externals (29/04/2008 9:56:20 a.m.)
    Temp Directory (C:\Users\biff\AppData\Local\Temp\WowAceUpdater), Skip Version Checks (False)
    Updating from: http://files.wowace.com/
    Cache age is 3557 min. (TTL=10 min)
    Updating cached file index... done.
    AckisRecipeList - Updated to rev WITHOUT Externals 71911 UNSTABLE
    CandyBar - Updated to rev WITHOUT Externals 71907 UNSTABLE
    AtlasLoot - Updated to rev WITH Externals 70372.5 UNSTABLE
    BigWigs - Updated to rev WITH Externals 71997 UNSTABLE
    ClassTimer - Updated to rev WITH Externals 71967 UNSTABLE
    Cartographer_QuestObjectives - Updated to rev WITH Externals 71526.1 UNSTABLE
    Cartographer - Updated to rev WITH Externals 70829.5 UNSTABLE
    CraftList2 - Updated to rev WITH Externals 70041.2 UNSTABLE
    FuBar_ClockFu - Updated to rev WITH Externals 65604.6 UNSTABLE
    Decursive - Updated to rev WITH Externals 71842.1 UNSTABLE
    FuBar_HonorFu - Updated to rev WITH Externals 70186.2 UNSTABLE


    This goes on for every update.
    Could someone explain:
    1) Is this a problem
    2) Have I done something wrong?

    In game there doesnt seem to be an issue...... confused



    Affraid i cant help you, this is JWU's thread, and thats WAU your using.

    /Rolf
    Posted in: Updaters
  • 0

    posted a message on JWowUpdater - A new java addons updater for ace2
    Quote from Throndorin »

    Hi

    first: a very nice tool!!

    2 little change requests

    1. store deleted addons during update in a separate folder or in recycle bin , so it is possible to undo the last update
    2. possibility to see list of installed addons (or is this possible and I should buy new glasses)

    a little bug

    other windows as the main window can't be closed via the x Button of the Window (Windows)

    Throndorin


    You can see a list of installed addons, just go to Delete addons. Since it will only let you delete addons you have installed :)

    About closing windows by pressing X, this isnt a bug, its delibrately disabled atm, since some of the windows have actions that happens when closing the window, and i havent gotten round to implementing them to happen if you press the X.

    /Rolf
    Posted in: Updaters
  • 0

    posted a message on JWowUpdater - A new java addons updater for ace2
    Quote from Nekzar »

    "No addons found on wowace.com, check internet connection or that wowace isn't offline atm."
    I get this message as soon as I run the updater when it starts scanning and also if I try to rescan.
    Currently my addons folder is empty besides the blizzard ones. And adding an addon to the folder doesn't make it show in the updater either -so basically this thingy doesn't work in any way it should atm. - for me

    I can see no addons on the "install new addons"
    I did try to change timeout to 30 - doesn't work.
    I do have perfect connection to www.files.wowace.com - I have no problems downloading from this site at all.

    Before I used WAU. I wanted to try out JWU because my WAU suddenly stopped working.(and because I can get the few addons from curse in this updater so I only need to use 1 and not 2 updaters) As a matter of fact I think the error message was something about the same as the one I have now. That it can't connect to wowace.com ..

    soo, what's wrong?



    Sounds to me like a firewall issue, your browser is allowed through, but WAU and JWU isnt. If you have a firewall, check that it allows the updater your trying to use to connect to the internet.

    /Rolf
    Posted in: Updaters
  • 0

    posted a message on JWowUpdater - A new java addons updater for ace2
    Quote from Magrov »

    I have a newbie (from JWoWUpdater point of view) question. I have used WAU and Netherpanel and though I should give JWoWUpdater a go so I fired it up and got a long list of missing embeds that needed to be updated. Here is where I got confused. I checked all the addons and they had the libraries in their libs folders so I couldnt see any reason that JWoWUpdater should download all these libraries by
    itself. But JWoWUpdate thought diferently and downloaded all the libraries so my AddOns-folder is now filled with LibXxxx. Now, here is my question: if I select no-ext shouldnt JWoWUpdater skip downloading these libs? I may have misunderstood this but I thought it was up to every addon to have this libs in their folder.

    Please teach a noob how things work and I will keep quiet in my little hole... =)

    //Magrov


    No-Ext means that you want the addons downloaded without included externals. Which results in what you described, that the externals will be seperately downloaded.

    So if you want embedded libs in the addon directories, then you should decheck no externals.

    /Rolf
    Posted in: Updaters
  • 0

    posted a message on JWowUpdater - A new java addons updater for ace2
    Quote from Melikae »

    Just had a problem when installing addons for leveling my little mage...
    Was setting up my nonace addons from WOWINT and with Carbonite Quest there's a problem with their versioning, as they use Trial1.xx in their .toc and 1.xx on WOWINT the updater doesn't recognize the version of Carbonite at all and with that want's to update it every time I update.

    Changing the version in the conf file as a workaround seems to corrupt it, so that the updater changes back to initial settings...


    Just tried installing Carbonite Quest via JWU. And it installs nicely, and then dosent update since its at the newest version.

    Could you explain a little more how your problem is showing itself?

    /Rolf
    Posted in: Updaters
  • 0

    posted a message on JWowUpdater - A new java addons updater for ace2
    Quote from Funkydude »

    Me neither, it wasn't me that had the problem. :P


    Hehe alright then :)

    /Rolf
    Posted in: Updaters
  • 0

    posted a message on JWowUpdater - A new java addons updater for ace2
    Quote from Funkydude »

    If you look at OmniCC for example, it has OmniCC and OmniCC_Options.
    I think you should add a 'delete' button for the non wowace addons, the None then apply isn't easy to just figure out.


    Just tried adding OmniCC from curse to my non ace list, and it installs fine, with both OmniCC and OmniCC_Options. So not sure what the problem is.

    /Rolf
    Posted in: Updaters
  • 0

    posted a message on JWowUpdater - A new java addons updater for ace2
    Quote from Funkydude »

    There doesn't appear to be a way of removing non wowace addons from the list.

    EDIT: ok you change it to 'none', that's not particularly easy to figure out :)

    Also I've been told it might not be handling mutiple addons in1 zip properly from externals websites, such as OmniCC from curse.


    Removing non ace addon from list: Set updater site to None.

    Multiple addons in 1 zip? havent really looked into supporting this. If i get some time soon ill look into what its about.

    /Rolf
    Posted in: Updaters
  • To post a comment, please or register a new account.