• 0

    posted a message on Bugs in WAU or...
    I have solved a problem... The problem is "DrWeb Spider Guard". While he is active in Windows Vista(in Win XP all works normally), WAU does not unpack addons completely. If it to switch off, all becomes normal.
    Posted in: Updaters
  • 0

    posted a message on Bugs in WAU or...
    I do nothing manually. Right now, I delete ALL addons (except Blizzard_*) from addon folder. After I launch WAU and install ONLY BigWigs without externals, without "Automatic Dependency Download" and with "Unpack Addons"... All config is attached.
    After installation WAU has not unpack BigWigs completely. Folders "Outland" and "Plugins" have not been unpacked.
    Okey, I mark BigWigs in WAU and click on "Reinstall Marked Addons". Now folder "Outland" have been unpacked, but "Plugins" have been not.
    Okey, I mark BigWigs again... Again click on Reinstall. Now again folders "Outland" and "Plugins" have not been unpacked.
    Okey, I mark BigWigs again... Again click on Reinstall. Now folder "Plugins" have been unpacked, but "Outland" have been not.

    Damn, this is crazy... Maybe my Vista is bugged? Or maybe WAU algorithm for Unpack Addons is bugged?

    UPDATED:
    I think WAU algorithm is bugged, because right now I try update installed BigWigs with WoW UI Updater. He unpack BigWigs completely...
    Posted in: Updaters
  • 0

    posted a message on Bugs in WAU or...
    Sorry for my bad english... Little example:
    1) I wish to download Prat. If i download it from |" target="" data-ensure-absolute>http://files.wowace.com" manually, and unzip, then i shall receive folder named "Prat".
    2) Let's assume, that my addon folder have path: "D:/World of Warcraft/Interface/Addons".
    3) I copy my "Prat" folder to addon folder. Now full path to Prat is: "D:/World of Warcraft/Interface/Addons/Prat".
    4) Inside "Prat" folder contains 3 "modules": "Prat_AutoLoD", "Prat_Modules" and "Prat_Modules_AutoLoD".
    5) Prat will work correctly if this 3 modules will be cuted form "Prat" folder to Addon folder.
    6) Prat will work correctly if my addon folder contains following:
    • "D:/World of Warcraft/Interface/Addons/Prat"
    • "D:/World of Warcraft/Interface/Addons/Prat_AutoLoD"
    • "D:/World of Warcraft/Interface/Addons/Prat_Modules"
    • "D:/World of Warcraft/Interface/Addons/Prat_Modules"_AutoLoD

    So. All these actions should do WAU. But, after update/full reinstall addons some "modules" wich contain in Prat, BigWigs, PitBull and etc. not cuted to my addon folder.
    After reinstall addons i have something like this:
    • "D:/World of Warcraft/Interface/Addons/Prat"
    • "D:/World of Warcraft/Interface/Addons/Prat_AutoLoD"
    • "D:/World of Warcraft/Interface/Addons/Prat_Modules"_AutoLoD"
    "Prat_Modules" still inside "D:/World of Warcraft/Interface/Addons/Prat", and have path: "D:/World of Warcraft/Interface/Addons/Prat/Prat_Modules", but should be like this: "D:/World of Warcraft/Interface/Addons/Prat_Modules"

    • "D:/World of Warcraft/Interface/Addons/BigWigs"
    • "D:/World of Warcraft/Interface/Addons/BigWigs_AQ20"
    • ...
    • "D:/World of Warcraft/Interface/Addons/BigWigs_NefCount"
    • "D:/World of Warcraft/Interface/Addons/BigWigs_Plugins"
    • ...
    "Outland" still inside "D:/World of Warcraft/Interface/Addons/BigWigs", and have path: "D:/World of Warcraft/Interface/Addons/BigWigs/Outland", but should be like this: "D:/World of Warcraft/Interface/Addons/BigWigs_Outland"

    • "D:/World of Warcraft/Interface/Addons/PitBull"
    • "D:/World of Warcraft/Interface/Addons/PitBull_AltAura"
    • "D:/World of Warcraft/Interface/Addons/PitBull_Banzai"
    • ...
    "Aura" still inside "D:/World of Warcraft/Interface/Addons/PitBull", and have path: "D:/World of Warcraft/Interface/Addons/PitBull/Aura", but should be like this: "D:/World of Warcraft/Interface/Addons/PitBull_Aura"

    And so on...

    Diagnostic logging in attachment...
    Posted in: Updaters
  • 0

    posted a message on Bugs in WAU or...
    Right now i'm try this... Kill all Ace addons in addon folder and install they with WAU.

    Babble-Boss-2.2 now in addon folder.
    BigWigs_Outland still not cuted, but... If i use mode "WITH externals", then BigWigs_Outland is appears is addon folder. If i use mode "WITHOUT" externals, then not... Strange :)
    Prat_Modules still not cuted. Not important what mode i use...
    SpecialEvents-Aura-2.0 now in addon folder...

    I don't know, what to say...

    My WAU version right now is 1.9.44.675... I can print here my list of addons if it needed...
    Posted in: Updaters
  • 0

    posted a message on Bugs in WAU or...
    After release of a patch 2.2 i have noticed following problem, at updating addons:
    There is no unpacking of the some addons.
    For example:

    Babble-2.2 - After updating in folder X:\World of Warcraft\Interface\AddOns\Babble-2.2 i see 2 "modules": "Babble-Boss-2.2" and "Babble-Mount-2.2". But they should be in a folder X:\World of Warcraft\Interface\AddOns\...
    BigWigs - Same problem. In folder i found: "Outland". In addons folder i'm not found "BigWigs_Outland". So, timers for Gruul, Magtheridon and etc. are not available. Sometimes not cut folder "BigWigs_Plugins".
    Prat - In addon folder: "Prat_Modules". If i don't cut this folder to X:\World of Warcraft\Interface\AddOns\, Prat will not working.
    And some addons still refer to SpecialEvents-Aura-2.0, but this addon is not available for download.

    What's wrong with all this or me?
    My WAU config is attached.
    Posted in: Updaters
  • To post a comment, please or register a new account.