• 0

    posted a message on Scroll Frames
    Ringleron,

    I think I said one thing, and you basically repeated it...but maybe I misunderstood. I think we're on the same page about how updating this type of ScrollFrame would work.

    Quote from sylvanaar »

    Dont think of it as a linked table you are rebuilding. You are updating graphical elements which are already built, you are just changing their properties.


    Right, though "their properties" just happen to correspond to the lines in a linked table, unless I misunderstand.
    Posted in: Lua Code Discussion
  • 0

    posted a message on Scroll Frames
    Ringleron,

    I'm not an addon developer (yet...I have a couple ideas, and all your questions are proving invaluable as I learn the capabilities of Lua), but I am a software developer. My guess is to avoid exactly the issue you've brought up, ACP re-creates the table each time a header is expanded or collapsed, and reassigns that to the ScrollFrame. It's certainly a common practice to have a function to rebuild a data set, and that particular function [probably] just traverses the addon data in its tables.

    Then, rather than have a complicated function to insert or remove data from the table, the entire table is replaced.
    Posted in: Lua Code Discussion
  • 0

    posted a message on DBMFTLBBQ
    Quote from tezro »

    I know this is a old thread, but is there a possibility to add the countdown in?
    I hear the sounds of the countdown from DBM but I don't see a visual timer.
    Now I just count to 4 and start doing stuff, but a visual timer would be nice if possible.

    I am also in a guild forced to use DBM atm.....



    I don't know what syncing DBM does for that, but the fix I'd suggest (since I assume people with DBMFTLBBQ are BW fans, like myself) is to call whatever function handles the /bwlcb command with the appropriate time/message.
    Posted in: Raid AddOns
  • 0

    posted a message on BigWigs - The Eye
    Quote from Saroz »

    Cause sometimes he sticks to the same platform, making mods unreliable. Also, there is really no real use for this information in the encounter. Phase 1 is trivial to say the least.


    Not to mention, my raid leader with DBM tries to announces these changes, and the timers don't seem to be right. Maybe it's just Vent lag, but I think it's pretty obvious when a giant flaming bird moves from platform to platform. Also, if it announces this, do you also want it to announce platform vs. air?

    Things like Remote Toy on tanks for Kael'thas, or Static Charge on Vashj, or fear timers, or Leo's WW are very potentially fight-altering. A 30 second timer for platform changes is not fight altering. Platform transitions are a very predictable event, whereas the others affect random (or numerous) people, and being able to react quickly enough makes a substantial difference in beating the encounter. These are the types of events that I need information on, not mindless 30 second timers, or Maulgar's Heroic Strike timer, which are regular, and easily dealt with.

    Posted in: Raid AddOns
  • 0

    posted a message on BigWigs
    Quote from Thunderheart »

    another thing i noticed too on hydross in ssc. for the debuff is goes by percent instead of the number. and would be really nice to have a 10sec warning before the next mark. was really useful to have so the tank knew when to change him over before mark 5. the percent part we can get use to, just missing 10sec warning before the next mark.


    The marks are only 15 seconds long, as soon as the 4th one is done, start moving. Hunter MDs are 2 minutes cooldown, so 4 full marks is sufficient for the Cooldown to be up. I think the big bar counting down from 15 is sufficient....it's pretty easy to see when the bar says "10".
    Posted in: Raid AddOns
  • 0

    posted a message on ArkInventory v2.00
    I just want to say that I absolutely love v2 of this mod. v1 was getting kinda bloated and unwieldy, but you've done an awesome job with the rewrite for v2!
    Posted in: General AddOns
  • 0

    posted a message on Recount
    BugGrabber report for the same bug:

    Date: 2007-07-01 00:35:36
    ID: 53
    Error occured in: Global
    Count: 1
    Message: ..\AddOns\Recount\Tracker.lua line 767:
      attempt to compare number with nil
    Debug:
      ...face\AddOns\Recount\Libs\ParserLib-1.1\ParserLib.lua:625:
       ...face\AddOns\Recount\Libs\ParserLib-1.1\ParserLib.lua:614
      ...face\AddOns\Recount\Libs\ParserLib-1.1\ParserLib.lua:522: OnEvent()
      ...face\AddOns\Recount\Libs\ParserLib-1.1\ParserLib.lua:457:
       ...face\AddOns\Recount\Libs\ParserLib-1.1\ParserLib.lua:457
    AddOns:
     ACP, v2.3.1.$Revision: 41975 $
     agUnitFrames, v05-01-07
     aUFBanzai, v2.1
     ArkInventory, v1.45
     AshCore, v3.1
     Bartender3, v3.1 r41263
     Cartographer, vr42028
     CartographerCoordinates, v2.0
     CartographerFoglight, v2.0
     CartographerGroupColors, v2.0
     CartographerGuildPositions, v2.0
     CartographerLookNFeel, v2.0
     CartographerNotes, v2.0
     CartographerProfessions, v2.0
     CartographerFishing, v1.0
     CartographerNoteshare, v1.0
     CartographerQuests, v0.2
     ClosetGnome, v1
     Decursive, v2.0.0 Final
     FlightMap, v2.0-1
     DrDamage, v1.1.9
     ElkBuffBar, v1.3
     Examiner, v07.06.23
     FishingAce, v0.4.2a
     FuBarClockFu, v2.0
     FuBarDurabilityFu, v2.0
     FuBarExperienceFu, v1.1 $Revision: 40915 $
     FuBarMoneyFu, v20000-1
     FuBarPerformanceFu, v2.0
     FuBar, v33424
     Ludwig
     LudwigSellValue
     MobInfo2, v3.14
     MultiTips, v0.31
     Niagara, v1.0 r37488
     nQuestLog, v1.0
     Postal, v2.0 r40510
     Prat, v2.0 41676
     PratAutoLoD
     PratModules
     RatingBuster, v1.2.4 (r42366)
     Recount, v$Revision: 42357 $
     Sanity2, v2.2
     SanityItemCache, v2.1
     sct, v5.61
     sctd, v2.33
     simpleMinimap, v20100-6
     Swatter, v4.0.2
     tekKompare, v2.1.0.423
     UberQuest, vReborn Again 2.1.1
    Posted in: General AddOns
  • 0

    posted a message on ClosetGnome - Wear it or lose it.
    Here's BugGrabber for that error as of last night:

    Date: 2007-06-30 22:03:25
    ID: 30
    Error occured in: Global
    Count: 1
    Message: ..\AddOns\ClosetGnome\ClosetGnome.lua line 1095:
      'end' expected (to close 'do' at line 913) near '<eof>'
    Debug:
      [C]: ?
    AddOns:
     ACP, v2.3.1.$Revision: 41975 $
     agUnitFrames, v05-01-07
     aUFBanzai, v2.1
     ArkInventory, v1.45
     AshCore, v3.1
     Bartender3, v3.1 r41263
     Capping, v2.1.011
     Cartographer, vr41974
     CartographerNotes, v2.0
     CartographerNoteshare, v1.0
     ClosetGnome, v1
     FuBar, v33424
     Swatter, v4.0.2
    Posted in: General AddOns
  • 0

    posted a message on Omen - Bug Reports and Suggestions
    We slaughtered Nightbane last night with absolutely no aggro problems using a mix of Omen/KTM. I've had no real continuing issues with it, other than the whole Void Reaver knockback coefficient figuring out.

    Great job, Antiarc and Threat team!
    Posted in: Raid AddOns
  • 0

    posted a message on ACP - Official Thread
    Alright, I happened across this mod while browsing the entire list some weeks ago, and there's one "feature" that's been bugging me. :p It involves the protected addon ability, which I *really* like. However, I seem to get this message all the time when reloading UI, or loading the game for the first time. If I go ahead and reload, I don't get it the next time, but any time I change sets and reload, the message tends to reappear. It also happens when I zone in and out of instances, or hearth/portal.

    If the addons are protected, why aren't they loading? Does it have something to do with dependencies? Perhaps something with LoD mods that depend on protected addons? It's extremely frustrating in arenas because every time I enter one the popup appears, and every time I leave arenas it appears.

    I like the protected addon ability because it means I'm never without the core of my UI package, but if it persists, I'll have to go back to not using protected addons.

    Thanks!
    Posted in: General AddOns
  • 0

    posted a message on Cartographer
    The below bug occurs on load with Cartographer [POI] not checked.

    Date: 2007-06-23 16:25:48
    ID: 1
    Error occured in: Global
    Count: 1
    Message: ...ce\AddOns\FuBar\libs\AceLocale-2.2\AceLocale-2.2.lua line 487:
    AceLocale(Cartographer_POI): Translation "POI" does not exist.
    Debug:
    ...ce\AddOns\FuBar\libs\AceLocale-2.2\AceLocale-2.2.lua:488:
    ...ce\AddOns\FuBar\libs\AceLocale-2.2\AceLocale-2.2.lua:485
    ...ce\AddOns\FuBar\libs\AceLocale-2.2\AceLocale-2.2.lua:46:
    ...ce\AddOns\FuBar\libs\AceLocale-2.2\AceLocale-2.2.lua:44
    ...ns\Cartographer_Noteshare\Cartographer_Noteshare.lua:216: in main chunk
    AddOns:
    ACP, v2.3.1.$Revision: 39122 $
    agUnitFrames, v05-01-07
    aUFBanzai, v2.1
    ArkInventory, v1.45
    AshCore, v3.1
    Bartender3, v3.1 r41263
    Cartographer, vr40952
    CartographerNotes, v2.0
    CartographerNoteshare, v1.0
    FuBar, v33424
    Swatter, v4.0.2

    Posted in: Map/Minimap AddOns
  • 0

    posted a message on Omen - Bug Reports and Suggestions
    Quote from teedog »

    Don't all bosses that have Random Secondary Targetting abilities switch targets briefly? Strange that I haven't noticed this problem personally. Is it specific to the Maiden or am I not very observant?


    I think maybe you aren't too observant :p I've noticed that on a number of bosses, but using the pullout bar makes this *almost* a non-issue (except when I become the secondary target).
    Posted in: Raid AddOns
  • 0

    posted a message on BigWigs
    Alright, that hasn't been working then. As a warlock, I'm (along with several others that I know use BigWigs, some are using Deadly Boss Mods) most definitely targeting bosses while I proceed to obliterate them. Are there messages I can watch, or any debugging comments I could uncomment to get some more insight into this problem? Any debug statements I could add to the code? Where would I add these?

    I really like BigWigs, and I'd hate to switch away from it. I can add my list of other addons here if that would help.
    Posted in: Raid AddOns
  • 0

    posted a message on BigWigs
    Quote from Silverstorm »

    Quote from Silverstorm »

    Quote from Funkydude »

    did you try relogging?
    did you try uninstalling all BigWigs folders and installing with WAU?


    I did try relogging during the Gruul encounters, since I also got the "you can't accept res" bug.
    I use WAU all the time, with DeleteBeforeExtract or whatever set to true. Tonight I will completely reinstall everything and see how things go in Gruul/Kara.


    OK, after more attempts with BigWigs on Gruul and Kara, still no luck with it activating. I've reloaded UI, completely reinstalled BigWigs, totally shut down WoW and restarted...nothing. Is there some sort of Debug I can do that would help?


    In raids this week, I turned on the Debugging part, but all it would say is "<Insert boss> module reset". I never got a module activation.

    OK, last night I completely wiped out my UI and just turned on BigWigs. I walked into Gruul's Lair, and BigWigs activated, but the individual modules did not. What is the logic to activate a boss module?
    Posted in: Raid AddOns
  • 0

    posted a message on BigWigs
    Quote from Silverstorm »

    Quote from Funkydude »

    did you try relogging?
    did you try uninstalling all BigWigs folders and installing with WAU?


    I did try relogging during the Gruul encounters, since I also got the "you can't accept res" bug.
    I use WAU all the time, with DeleteBeforeExtract or whatever set to true. Tonight I will completely reinstall everything and see how things go in Gruul/Kara.


    OK, after more attempts with BigWigs on Gruul and Kara, still no luck with it activating. I've reloaded UI, completely reinstalled BigWigs, totally shut down WoW and restarted...nothing. Is there some sort of Debug I can do that would help?
    Posted in: Raid AddOns
  • To post a comment, please or register a new account.