• 0

    posted a message on Dominos - A main actionbar replacement
    Loving Dominos in the beta (swapped because Bartender was being slightly persnickety). One question -- any chance of getting bar shifts based on multiple controller keys? I.e., Shift-Control, Shift-Alt, etc? Not a deal breaker for me, just something that would be convenient.
    Posted in: General AddOns
  • 0

    posted a message on StatBlockCore v2: Make use of your broker plugins!
    Quote from Zidomo »

    Right, right. Posted before I noticed people posting here about Omen/Threat-2.0 and the upcoming WotLK changes. Have never really been interested in alphas/betas of WoW patches/expansions. Only mods and how they are affected by them :).


    Zidomo, if you still want this send me a PM or something and I'll port it (I wrote the original). I'm more interested in porting it to WotLK, though, now that I have a beta account.
    Posted in: Data Broker AddOns
  • 0

    posted a message on Guild Crafts ~~Stable Beta now~~
    Quote from OrionShock »

    ok think with me here....

    "GuildCraft" is a global object declared in the core file that loads first. The fubar module loads last. So what your getting is either extraordanarily strange or there is another error that your not seeing there (more likely)

    and please clip your addon list, and use bug sack / bug grabber to report errors, it tends to give a more informative debug.


    Check out his library loading errors. I'm getting the same sort of thing:

    [2008/06/29 21:14:24-4359-x1]: GuildCraft-2\core.lua:162: Usage: EmbedLibrary(addon, libname, silent, offset): 'libname' - Cannot find a library instance of "AceTimer-3.0".
    AceAddon-3.0\AceAddon-3.0.lua:150: in function `EmbedLibrary'
    AceAddon-3.0\AceAddon-3.0.lua:138: in function `EmbedLibraries'
    AceAddon-3.0\AceAddon-3.0.lua:111: in function `NewAddon'
    GuildCraft-2\core.lua:162: in main chunk

    And when I look at the Libs folder, I see:

    % ls Libs
    AceAddon-3.0 Libs\AceComm-3.0
    AceComm-3.0 Libs\AceConfig-3.0
    AceConfig-3.0 Libs\AceConsole-3.0
    AceConsole-3.0 Libs\AceDB-3.0
    AceDB-3.0 Libs\AceEvent-3.0
    AceEvent-3.0 Libs\AceGUI-3.0
    AceGUI-3.0 Libs\AceLocale-3.0
    AceLocale-3.0 Libs\AceSerializer-3.0
    AceSerializer-3.0 Libs\AceTimer-3.0
    CallbackHandler-1.0 Libs\CallbackHandler-1.0
    LibGratuity-3.0 Libs\LibGratuity-3.0
    Libs\AceAddon-3.0

    Note: no AceTimer-3.0 at the top level of the Libs folder. You may have a problem with your dependencies?

    Since the GuildCraft global object is declared as:

    GuildCraft = LibStub("AceAddon-3.0"):NewAddon("GuildCraft", "AceConsole-3.0", "AceEvent-3.0", "AceTimer-3.0")

    You're obviously going to have trouble if any of those don't load.
    Posted in: General AddOns
  • 0

    posted a message on Graph of threat for tanks
    Quote from FlareCDE »

    Recount itself doesn't have an option to display threat as a graph? I think it's alt-click on the bars? Been awhile since I dropped that mod due to it being abandoned.


    Yeah, I like Recount's graph. I hadn't been able to figure out any way to look at it post-combat, though, which is more of what I was interested in.

    The promise of 2.4 is so high that I can't bring myself to put a lot of effort into anything you can do with the current limited tools.
    Posted in: Raid AddOns
  • 0

    posted a message on Graph of threat for tanks
    Quote from mastergara »

    I realize this is a suggestion that has probably already been made for Omen or Recount or the like, but is there an AddOn that records the data from Omen (Threat-1.0, KTM, etc), and can put it into a graph for a selected individual? A quick google search revealed http://forums.worldofwarcraft.com/thread.html?topicId=1778578625&sid=1 and I cant help but wonder if the data is already there, how difficult would it be to log it as a part of Recount or Omen?


    Not very. I wrote that script; I haven't updated it for the Devastate changes because it would be slightly more difficult than simply changing values and I'm lazy. Using Threat-1.0 as a source of threat numbers would be very smart. However, I'm not a Lua programmer and did I mention the lazy bit?

    The right approach would be a small addon that consumes Threat-1.0 data and logs via the SavedVariables file; add to that a script/program that consumes that file and produces a threat graph. Not too hard.
    Posted in: Raid AddOns
  • 0

    posted a message on ClassTimer - Official thread
    Added to Main.lua -- ClassTimer:Trinkets():
    		"Arcane Energy",
    		"Focused Power",
    		"Unstable Power",


    For Vengeance of the Illidari, Glowing Crystal Insignia, and Zandalarian Hero Charm respectively.
    Posted in: General AddOns
  • 0

    posted a message on Loggerhead (Automatic Combat Logging)
    Didn't see a thread for this; not sure if the author reads these forums. However...

    Awesome addon. There's one aspect of the functionality that's driving me mildly nuts; when I die in an instance and release, combatlogging automatically gets turned off, since I don't have autologging on for outside zones. This means that I have to remember to move the old log aside so that the combat log created when I zone back in doesn't overwrite it.

    Possibly there's a way to make combat logging append, rather than overwrite. If not, though, it'd be cool if LoggerHead didn't turn off combat logging when you exit a zone as a ghost.
    Posted in: General AddOns
  • 0

    posted a message on Manufac: Retooled Professions
    Quote from Nymbia »

    Oh my, this thread got big while I wasn't looking.

    Quote from Strand »

    OK, I'm getting the breakage where things don't show up in menus again. The debug output looks like this:

    (blah blah blah)

    -----MENU STARTED----- Special Minerals nil nil nil
    -----STARTING SECOND LEVEL-----
    line660error Smelt Silver
    -----SUB MENU STARTED-----
    -----SUB MENU COMPLETE-----


    Does it still happen if you hit escape a couple times then re-open the menu?


    Yep. I'll let you know if I still get it with the new version. Weird little problem.
    Posted in: General AddOns
  • 0

    posted a message on Manufac: Retooled Professions
    OK, I'm getting the breakage where things don't show up in menus again. The debug output looks like this:

    (blah blah blah)

    -----MENU STARTED----- Special Minerals nil nil nil
    -----STARTING SECOND LEVEL-----
    line660error Smelt Silver
    -----SUB MENU STARTED-----
    -----SUB MENU COMPLETE-----

    Posted in: General AddOns
  • 0

    posted a message on Manufac: Retooled Professions
    Quote from Nymbia »

    Quote from digitalruse »

    I've noticed in the most recent build that I can no longer see any of my enchanting skills. The categories are there, but when I hover over them, they are all empty.

    Already tried the standard delete WTF settings/reinstall the mod.

    Any thoughts?
    -DR
    Got any errors? If not, just close and reopen the profession (and maybe toggle manufac to standby and back to enabled) and it should work fine.


    I'm getting this too, sometimes. Let me see if I can recreate it...

    I can't. But if it happens again I'll get debugging output.

    When it is happening, it also happens to my other character's mining Manufac menu -- he can see stuff to be smelted in the "Can Make" menu, but not anything in "Basic Minerals" and "Special Minerals." I can't get it to happen right now, but the last time it happened I got errors relating to Dark Iron smelting and Elementium smelting.
    Posted in: General AddOns
  • To post a comment, please or register a new account.