• 0

    posted a message on Postal Works Fine - User Does Not!
    Quote from Xinhuan »
    I am the current maintainer of Postal, and I would like to inform you that you are quite mistaken about your lost gold. First, let me explain how the AH and mail system currently works.

    Xinhuan, thanks for the prompt response and explanation - you managed to do what no GM did which was actually answer the question and explain wy my worries were incorrect.

    My concerns were that when I clicked the 'buyer found' mail that it then disappeared. Due to the volume of sales I get in my mailbox I was unable to tie it up to a then later and separate mail containing the gold. I wish the GM had explained this to me as you efficiently as you have!

    Many thanks for the work you put into Postal - as I said in my original post it is a most excellent addon.

    TL.

    PS I have edited the thread title to remove any implication that it is Postal's error as it is nothing to do with Postal and everything to do with my lack of understanding!
    Posted in: General AddOns
  • 0

    posted a message on Postal Works Fine - User Does Not!
    I trade a lot and get a lot of sales. I tend not to read each sale docket, I just shift-click (addon feature) on the mail to get the item or gold.

    I noticed about 3-4 days back that you could shift click on an auction sold mail when it was within it's initial delay period of 60 minutes. My addon played the usual 'coins chinking' sound (like gold being deposited into my bags) and the mail disappeared. I therefore believed that I had received the gold earlier than the hour and that some sort of hot-fix had allowed you to pick up the auction proceeds earlier than before. Unfortunately I did not audit this belief as it was in the middle of several pages of sales, hence I had no chance to check totals I should have received against what I actually received.

    At one point yesterday I logged back onto my character after a short period offline and found 3 sales mails from Auction House. 2 had been for sales over an hour ago (of about 21G each) and the third was for a stack of pots (for about 13G) which had sold within the last hour (and still had time remaining on the 'delay hour'). I shift clicked all 3 mails, all made the 'coin chink' sound, all disappeared from my mailbox. However my bank addon showed I had only received 42G, not the 55G I should have done.

    A fourth item then sold, so I tested this error by shift clicking on this sales mail (again within the 60 minutes delay period) and again the coin chink happened, mail disappeared, but no gold received. I then realised that I had probably lost in excess of a thousand gold over the last few days due to this error. I had noticed a lower cashflow than I had expected in the last few days, but had not related it to me clicking on auction mails with 'time remaining' left!

    Is this behaviour specific to Postal, or has somethign changed in Blizz's code that is triggering this potential error?

    I have submitted a ticket and after the third ticket (previous 2 GM responses were useless) managed to speak to a GM who seemed to catch on to what it meant. It has now been escalated up to a special team to investigate. It will need them to audit my sales against gold in my bags for them to discover and confirm the error, so I do not expect this to happen quickly.

    The GM told me that it was not possible for a mail to be deleted whilst it still had time remaining and still owed me gold. I demonstrated clearly that this is precisely what the this error appears to do - I'm still unsure if Postal or Blizz, but suspect the latter if Blizz's coding lets me delete an allegedly undeletable mail.

    I await the GM's response with not inconsiderable financial interest and would welcome comment from anyone involved with the maintenance of the most excellent Postal addon.

    To users: You have been warned!

    TL.
    Posted in: General AddOns
  • To post a comment, please or register a new account.