• 0

    posted a message on Plz Fix Pitbull Profiles!
    Look this has been brought up by others before but, since I am now about to reconfigure PitBull for all toons for maybe the TENTH FREAKIN TIME I am going to bring it up again: PLZ FIX PROFILE SAVING!

    How can you guys even THINK about doing any development on Pitbull that doesn't Profiliing first? I love Pitbull to death but I cannot even begin to tell you how much time I have wasted configuring this add-on because Profile saving/reloading is messed up. The only difference between tweaking now and tweaking when I first began using Pitbull is that now I have rebuilt my stuff so often out of neccesity that I can do it in 30 minutes per toon instead of an hour. A few months ago I left Pitbull out of frustration for that very reason but couldn't find another Unit Frames add-on that suited my tastes, and I reluctantly returned.

    Fix it or not, w/e: but one day a Unit Frames add-on will come along that will offer those things that Pitbull offers and will have a working profile feature too: when that happens I'll jump ship and never look back.
    Posted in: Unit Frames
  • 0

    posted a message on eePanels2 - Official Thread
    With the kind help and patience of some folks here I've finally got my elite indicator working more-or-less perfectly, although sometimes it fails to activate. For the most part, it's perfect, and it does exactly what I'd hoped it would do: it's really come in handy in AV when the action gets heavy and I want to focus on Elites that are surrounded by PVP. Yeah I know PB has an Elite indicator frame, and you can see that I've customized Target Text to add large Elite text, but the Dragon graphic really stands out. It also looks good...

    Not sure if I can change Elite border color, if so I will change it to match the border within the dragon image. For now, it's good enough.

    Here it is:



    Here is the script, which is simply the script in the wiki with my eepanels2 number:

    -------------------------------------

    function eePanels2:PLAYER_TARGET_CHANGED()
    if UnitIsPlusMob("target") == 1 then
    eePanel1:Show()
    else
    eePanel1:Hide()
    end
    end

    eePanels2:RegisterEvent("PLAYER_TARGET_CHANGED")

    -------------------------------------
    Posted in: General AddOns
  • 0

    posted a message on eePanels2 - Official Thread
    Quote from Evil Elvis »

    You also need to double-check the type of mobs you're targeting. World bosses might not be considered elite by this script, and maybe not rare-elites either. You can do a /print UnitIsPlusMob("target") to see what the output should be.

    You can also try using the UnitClassification("target") function. See this post: http://www.wowace.com/forums/index.php?topic=8139.msg144909#msg144909


    Talk about hitting the nail on the head: as soon as I targetted an unfreindly elite there it was. Excellent! I'd been practicing in the safety of a major city, targetting freindly guards. That worked for some tweaking I did to PitBull, but didn't for EePanels2.

    Many thanks!
    Posted in: General AddOns
  • 0

    posted a message on eePanels2 - Official Thread
    Hi,

    I'm a noob when it comes to scripting and LUA, so this may be something very simple...

    I've adapted the "Show if Target is Elite" script to my eepanel (#1) so that an Elite Dragon appears around my PitBull target, but I can't get it to work the way that I want it to: the dragon does not appear. If I remove the script then the dragon appears whenever I target a unit, so I presume that that is an indication that I have the parenting appropriately configured. Of course, I've exited the game and re-invoked whenever a change has been made, just to be on the safe side. I've also enabled Blizz Target Unit Frame, so that I can use the Blizz Target to verify that I am, in fact, targeting an elite.

    Both Parent and Anchor are set to PitBullUnitFrame4.

    Here is the script: the only modification I've made is changing eepanel4 to eepanel1.

    ----------------------

    function eePanels2:PLAYER_TARGET_CHANGED()
    local isElite = UnitIsPlusMob("target")
    if (isElite) then
    eePanel1:Show()
    else
    eePanel1:Hide()
    end
    end

    eePanels2:RegisterEvent("PLAYER_TARGET_CHANGED")

    ----------------------

    Thanks for your help.
    Posted in: General AddOns
  • 0

    posted a message on Elite/Rare Graphic?
    Many thanks!

    Now a question from a EEPanels/2 noob: can I adapt that graphic to wrap around the left or right end of a PitBull target unit frame, based on the Classifaction of the unit being targeted? Just a confirmation will suffice: if you'll confirm I'll dig through the data and at least try to figure it out on my own...

    Thanks again...
    Posted in: Unit Frames
  • 0

    posted a message on Elite/Rare Graphic?
    Hi,

    I would like to add an Elite/Rare graphic to my Unit Frames, but I've no idea where I can find one. I'm looking for a circular dragon icon, or something similar, that resembles the wrap-around default indicator for wow frames. My indicator willl reside above my PitBull unit fram for Target, next to the unit name (I'll be experimenting with EEPanels2).

    Thanks.
    Posted in: Unit Frames
  • 0

    posted a message on Crazy PitBull Issue: StatusBar Textures
    OK figured it out. Did what Scyth suggested and it all worked again, but I had to reconfig my add-ons. As soon as I got them all going again the problem came back. I used LoadIt to locate the culprit. It was Recount. (Recount is used for all of my other tonos, I had turned it off for this new Priest, and didn't realize that it had affected PitBull). Have no idea why this is, although I've noticed that Recount, as well as Pitbull, has the same list of textures, so it appears that by disabling Recount I was removing, or affecting, the textures used by PitBull.

    Thanks again for the help guys.
    Posted in: Unit Frames
  • 0

    posted a message on Crazy PitBull Issue: StatusBar Textures

    Quote from ScythXIII »

    Try deleting your WTF info for that character. Then copy it the preferences from another copy.


    You're a genius! I did just that and everything is back to normal (well, I have to reconfig now, but that's ok, at least I can get it the way I want it).

    I thought there must be some sort of profile repository somewhere, but I had no idea where. Many thanks.

    Now for one final question: if I copy all of those profile directories does that mean that I've essentially got a complete backup of all add-on config? (not just PitBull)

    Thanks again.
    Posted in: Unit Frames
  • 0

    posted a message on Crazy PitBull Issue: StatusBar Textures
    Crazy PitBull Issue: StatusBar Textures

    Hi,

    Pitbull V53016

    Today, while grinding with a new toon, I began tweaking on it's PitBull profile. I ultimately ended up copying from another profile, which had mixed results, as has been mentioned here by others. However, I was able to get it looking just about right, did a reload, and 'blam' the selected Statusbar Texture reverted to "Blizzard" The only textures that were left were "blizzard" and "Cilo". Both could be selected and worked fine, but the others, particulalry "Minimalist" my preference, were not shown in the drop-down. OK that's odd but not necessarily unexpected with PitBull (I love it but it can be a pain, especially since Rock): Here's the freaky thing: my other toons still have all textures available for use, and they all work!.

    I've copied profiles, gotten in and out of the game several times, copied the various library TGAs (e.g minimalist.tga) into every directory i thought that they needed to be in, but nothing.

    Any ideas?

    Also, is it my imagination, or does PitBull auto-update. If so, how can I turn that off?

    Thanks
    Posted in: Unit Frames
  • To post a comment, please or register a new account.