CurseForge and Overwolf are joining forces!
Awesome More Information
  • 0

    posted a message on Addon loading too fast?
    I'm trying to code some lines for personal use. Its purpose is to remove some default Blizzard stuff (Gryphons, exp bar & rep bar).

    function FuckArt_OnEvent()
    	-- Remove the reputation bar
    	ReputationWatchBar:Hide();
    
    	-- Remove the experience bar
    	MainMenuExpBar:Hide();
    	MainMenuExpBar.pauseUpdates = true;
    	MainMenuBarMaxLevelBar:Show();
    	ExhaustionTick:Hide();
    
    	-- A check to see if the code runs
    	DEFAULT_CHAT_FRAME:AddMessage( "Hello world!", 255, 255, 255 )
    end
    
    local frame = CreateFrame("Frame", "FuckArtFrame");
    frame:SetScript("OnEvent", FuckArt_OnEvent);
    
    frame:RegisterEvent("PLAYER_LOGIN");
    frame:RegisterEvent("PLAYER_ENTERING_WORLD");
    frame:RegisterEvent("PLAYER_XP_UPDATE");
    frame:RegisterEvent("PLAYER_LEVEL_UP");
    frame:RegisterEvent("PLAYER_TARGET_CHANGED"); -- for testing only
    
    -- hide the Gryphons
    MainMenuBarRightEndCap:Hide();
    MainMenuBarLeftEndCap:Hide();


    After login I see 'Hello world!' twice, probably PLAYER_LOGIN & PLAYER_ENTERING_WORLD events. Exp & rep bar are not removed at that time. When I target something it is suddenly gone (with another Hello World ^^). How can I fix this?
    Posted in: AddOn HELP!
  • 0

    posted a message on AutoBar by Toadkiller (official thread)
    Quote from Toadkiller »

    No I did not say it's not the addon. Also, it is not about if you agree or disagree or have a completely different experience with using a blizzard macro on an action bar. Until I write code to support #showtooltip or to determine a default to show, or manage to call the blizzard updater code for macros (unlikely as this did not work a year ago), custom macros will simply not work like a blizzard macro.

    You can test this yourself by making your own custom macro button and adding #showtooltip to it. Then hover over the button using it and you will see #showtooltip show up, followed by whatever macro text you entered. If you have more than 1 trinket you could also hover over trinket 2 and look at the popups after the first one. These are also macros, and no their tooltips are not correct.

    Meanwhile the workaround is as below. It will give you a spell button which has proper tooltips etc. since it is not a macro.
    Maybe it's an idea to NOT use custom macro then? There's not much use in making one if it only contains a /cast <spell> line.
    Posted in: General AddOns
  • 0

    posted a message on AutoBar by Toadkiller (official thread)
    Quote from Toadkiller »

    It is not a tooltip issue, they are macro buttons. You can make regular spell buttons as detailed here: http://code.google.com/p/autobar/wiki/Usage

    I will add a ToDo for allowing cooldown display for macro buttons. This will not happen soon.


    So it works for every other spell and item except those 2 and you say it's not the addon? I have to disagree with you there. Even with a macro you can add #showtooltip to have it showed correctly.
    The cooldown display I do with another addon (CoolDownCount), but that only works if the tooltips are correct.
    Posted in: General AddOns
  • 0

    posted a message on AutoBar by Toadkiller (official thread)
    Could you please fix the tooltip for mage abilties "Ice Block" and "Invisibility"? Then I can also view the cooldowns of it :)

    Posted in: General AddOns
  • 0

    posted a message on AutoBar by Toadkiller (official thread)
    Mage abilties "Ice Block" and "Invisibility" don't have proper tooltip atm
    Posted in: General AddOns
  • 0

    posted a message on PowerDisplay - official thread
    Quote from gogusrl »

    I`m interested in the ability to remove the "Spell damage" text and just leave the numbers. As for the dogtag option, how do you use it ? i check it and nothing happens.
    Sorry for the long, long delay.
    I added this. You can set the fontsize to 0 now.
    Posted in: General AddOns
  • 0

    posted a message on G15display - official thread
    You like the G15 keyboard, but don't want to spent $$$ for it? G15display might become your new buddy!

    Probably buggy a lot, please report them here :)


    Links:
    - Wiki
    - Download
    Posted in: General AddOns
  • 0

    posted a message on PowerDisplay - official thread
    Quote from gogusrl »

    Could you allow us to edit/remove the detailed text about the skill? (maybe a dogtag like format?!).

    I made it a bit easy for myself there and added a yes/no option to use dogtags. Please test and comment here.
    Posted in: General AddOns
  • 0

    posted a message on PowerDisplay - official thread
    Quote from Serenus »

    Spell Hit Rating isn't working either, shows as 0 regardless.
    Still having that problem?
    Posted in: General AddOns
  • 0

    posted a message on PowerDisplay - official thread
    Quote from Serenus »

    Is it possible to control the spacing between lines? ;x
    I never would have thought of that...

    Added :)
    Posted in: General AddOns
  • 0

    posted a message on ClosetGnome - Wear it or lose it.
    Quote from Malan »

    One of my sets has totally disappeared from the drop down menu. The set is still registered though, I can set keybinds to it and it shows up as the 'active' set when I have it on, but I cannot select it through the drop down menu on fubar.

    I have tried to delete the set and then add it again, or just edit/add it again and none of that has worked. Other new sets that I've added recently show up fine.
    I guess you have it set in the Mount options. Rabbit decided to remove them from the list then. I'm not happy with that either, but he didn't make it optional (yet?).
    Posted in: General AddOns
  • 0

    posted a message on PowerDisplay - official thread
    /powerd display lines 0
    /powerd display lines 1
    /powerd display lines 2
    /powerd display lines 3
    /powerd display lines 4
    /powerd display lines 5


    The none options has been removed because of the ability to remove them completely.
    Posted in: General AddOns
  • 0

    posted a message on PowerDisplay - official thread
    I hope those issues are fixed now. I just did a clean installation of the latest version (profile deleted ofc) without errors and a working frame.

    Sorry for the trouble :(
    Posted in: General AddOns
  • 0

    posted a message on PowerDisplay - official thread
    Quote from Kelem »

    I'd like to ask to have an option put in for just 'spell dmg' instead of a specific class
    Also to have the text display field a selection of right/left instead of top and down (such as, having 2 areas next to each other instead of on top).
    Spell Damage has been added. Layout will be worked on later

    Quote from Serenus »

    Aparentlty /powerd frame isn't working.

    Spell Hit Rating isn't working either, shows as 0 regardless.
    frame options was removed since the frame is (alt)draggable now. Spell Hit Rating is working for me as intended (Warlock)

    Quote from Yssaril »

    any chance spell haste and melee haste rating could be added?
    Done! Including Ranged Haste Rating.

    ---

    New version may require some options to be re-set. Sorry for that.
    Posted in: General AddOns
  • 0

    posted a message on ClosetGnome - Wear it or lose it.
    Quote from Rabbit »

    Should be fixed now.

    Too bad it's not optional and too bad it's not only the mount set, but in my case also my default set.
    Posted in: General AddOns
  • To post a comment, please or register a new account.