• 0

    posted a message on Quartz: Modular Casting Bar
    Quote from: Samasnier on March 22, 2008, 12:42:48 am
    I'm having problems incorporating /quartztimer into a macro.

    I have the following macro for my water elemental:

    Code:

    #showtooltip Summon Water Elemental
    /petpassive
    /stopmacro [pet:water elemental]
    /cast Summon Water Elemental
    /script PetActionBarFrame:Show(); PetActionBarFrame.locked=true


    I want to add create a timer bar that will appear when I summon my pet and last for 45 seconds (or until he's killed, but I don't believe /quartztimer can do that). I've tried adding in /quartztimer 45 Water Elemental but it doesn't create the timer bar. However, when I have /quartztimer 45 Water Elemental in its own macro it works perfectly.

    Any help would be greatly appreciated! If quartzimer can be used to create a timer bar that perfectly tracks my elemental's actual life span (ie it disappears when he dies prematurely), I'd love to know how to do that.

    Try out the attached zip. This isn't actually a Quartz module, it has no options and it does nothing more than start/stop a 45s timer for Water Elementals based on the UNIT_PET event.

    Edit: Fixed a bug that would cause bad custom table errors after your pet despawned.

    Edit2: ^ For real this time. Wonder why I have to delay a routine to delete the timer until after the event. Note to ask Nymbia.


    I would really like the Water Elemental timer but cant seem to get it to work. I downloaded the zip and added it to the Quartz addon folder but nothing. I also tried it in the addon folder but not under the Quartz folder and still no joy. Am I missing something? I also dont seem to have any timers showing at all but just the cast bar.

    Thanks
    Posted in: General AddOns
  • 0

    posted a message on Spellcraft Sheep announce problem
    I currently use this addon as a space saver for my portals. I also wanted a sheep announcer for partys but even though I have the polymorph announce part switched on is still wont announce anything. Any ideas if there is something im missing? Thanks
    Posted in: AddOn HELP!
  • 0

    posted a message on Pitbull problem with party pets
    Can anyone help at all?
    Posted in: Unit Frames
  • 0

    posted a message on Pitbull problem with party pets
    Is there a way to configure the party pets to automatically connect to the proper person? The issue I am having is that the pet shows up but will go anywhere and not with the person whos per it is. I can unlock the fames and move it wherever but the next time i party is will go anywhere again. I have attached an image to show the problem. Thanks
    Posted in: Unit Frames
  • 0

    posted a message on Pitbull/Blizzard Frames issue
    I though it may be something like that, I will go and try that now. Thanks for the reply.
    Posted in: Unit Frames
  • 0

    posted a message on Pitbull/Blizzard Frames issue
    I have a small problem that when I log on, Hearth or Portal I end up with Blizz frames also activated. I have to open the Pitbull interface and uncheck and recheck the hide Blizzard frames option to get rid of them. Any ideas?
    Posted in: Unit Frames
  • 0

    posted a message on Post cool PitBull layouts here!
    I have a small problem that when I log on, Hearth or Portal I end up with Blizz frames also activated. I have to open the Pitbull interface and uncheck and recheck the hide Blizzard frames option to get rid of them. Any ideas?
    Posted in: Unit Frames
  • To post a comment, please or register a new account.