• 0

    posted a message on FuBar_GuildFu
    Ok, here is a copy of the relevant section of the FramesXML.log that I have.

    11/4 17:25:24.863  Loading add-on Fubar_GuildFu
    11/4 17:25:24.863  ** Loading table of contents Interface\AddOns\Fubar_GuildFu\Fubar_GuildFu.toc
    11/4 17:25:24.863  Error loading Interface\AddOns\Fubar_GuildFu\libs\LibStub\LibStub.lua
    11/4 17:25:24.863  Error loading Interface\AddOns\Fubar_GuildFu\libs\AceLibrary\AceLibrary.lua
    11/4 17:25:24.863  Error loading Interface\AddOns\Fubar_GuildFu\libs\AceOO-2.0\AceOO-2.0.lua
    11/4 17:25:24.863  Error loading Interface\AddOns\Fubar_GuildFu\libs\AceEvent-2.0\AceEvent-2.0.lua
    11/4 17:25:24.863  Error loading Interface\AddOns\Fubar_GuildFu\libs\AceAddon-2.0\AceAddon-2.0.lua
    11/4 17:25:24.863  Error loading Interface\AddOns\Fubar_GuildFu\libs\AceConsole-2.0\AceConsole-2.0.lua
    11/4 17:25:24.863  Error loading Interface\AddOns\Fubar_GuildFu\libs\AceDB-2.0\AceDB-2.0.lua
    11/4 17:25:24.863  Error loading Interface\AddOns\Fubar_GuildFu\libs\AceLocale-2.2\AceLocale-2.2.lua
    11/4 17:25:24.863  Error loading Interface\AddOns\Fubar_GuildFu\libs\Dewdrop-2.0\Dewdrop-2.0.lua
    11/4 17:25:24.863  Error loading Interface\AddOns\Fubar_GuildFu\libs\Tablet-2.0\Tablet-2.0.lua
    11/4 17:25:24.863  Error loading Interface\AddOns\Fubar_GuildFu\libs\FuBarPlugin-2.0\FuBarPlugin-2.0.lua
    11/4 17:25:24.863  Couldn't open Interface\AddOns\Fubar_GuildFu\libs\LibBabble-Zone-3.0\lib.xml
    11/4 17:25:24.863  Couldn't open Interface\AddOns\Fubar_GuildFu\libs\LibTourist-3.0\lib.xml


    After looking at that, I compared what I had pulled from the subversion repository versus what is in the zip file available for download. The zip file has all those libraries included in the 'libs' folder, while the subversion repository is not including those as embeds and pulling them in while updating from the svn repo and were not present. I copied those libraries into my own 'libs' folder, reloaded, and everything works again as advertised. The strange thing is that I still have those libraries running disembedded and are showing up as being loaded.

    Problem is pulling from the svn repository, not in the zip file available for download. Thanks for the help, anything else I can do to help, please let me know.
    Posted in: FuBar AddOns
  • 0

    posted a message on FuBar_GuildFu
    To answer all 3 questions:

    - where/how you got the addon
    Currently using revision 106 from the wowace subversion repository.


    - which locale you use
    enUS locale, so english I suppose.


    And yes to the final question, these are all the errors that I am presented with when enabling the addon.

    If you need anything else from me, just let me know.
    Posted in: FuBar AddOns
  • 0

    posted a message on Mapster: Official Thread
    Sorry about that, I figured that different lines signified different errors, but guess not. I use alphas because I like to try to help where I can by posting errors from real world users because my own lua coding experience is not all that good. Thanks for a good addon.
    Posted in: Map/Minimap AddOns
  • 0

    posted a message on Mapster: Official Thread
    Version 1.0.5-11-gcecaeb9 fixed the above errors and now presents the following errors:

    [2008/11/02 11:59:33-3032-x1]: Mapster-1.0.5\BattleMap.lua:125: attempt to index field '?' (a nil value)
    Mapster-1.0.5\BattleMap.lua:113: in function `Refresh'
    Mapster-1.0.5\BattleMap.lua:80: in function <Interface\AddOns\Mapster\BattleMap.lua:77>
    (tail call): ?:
    <in C code>: ?
    <string>:"safecall Dispatcher[1]":9: in function <[string "safecall Dispatcher[1]"]:5>
    (tail call): ?:
    AceAddon-3.0-5 (Ace3):340: in function `InitializeAddon'
    AceAddon-3.0-5 (Ace3):428: in function <Interface\AddOns\Ace3\AceAddon-3.0\AceAddon-3.0.lua:421>


    [2008/11/02 11:59:38-3032-x1]: Mapster-1.0.5\BattleMap.lua:91: attempt to index global 'BattlefieldMinimapCorner' (a nil value)
    (tail call): ?:
    <in C code>: ?
    <string>:"safecall Dispatcher[1]":9: in function <[string "safecall Dispatcher[1]"]:5>
    (tail call): ?:
    AceAddon-3.0-5 (Ace3):365: in function `EnableAddon'
    AceAddon-3.0-5 (Ace3):377: in function `EnableAddon'
    AceAddon-3.0-5 (Ace3):435: in function <Interface\AddOns\Ace3\AceAddon-3.0\AceAddon-3.0.lua:421>
    <in C code>: in function `LoadAddOn'
    Interface\FrameXML\UIParent.lua:991: in function `UIParentLoadAddOn':
    Interface\FrameXML\UIParent.lua:241: in function `CombatLog_LoadUI':
    Interface\FrameXML\UIParent.lua:389: in function `UIParent_OnEvent':
    <string>:"*:OnEvent":1: in function <[string "*:OnEvent"]:1>
    Posted in: Map/Minimap AddOns
  • 0

    posted a message on Mapster: Official Thread
    Mapster is now throwing the following errors in version labeled 1.0.5-10-g77fbc5f from the repository:

    [2008/11/02 11:45:30-3031-x1]: Mapster-1.0.5\BattleMap.lua:121: attempt to index field '?' (a nil value)
    Mapster-1.0.5\BattleMap.lua:110: in function `Refresh'
    Mapster-1.0.5\BattleMap.lua:79: in function <Interface\AddOns\Mapster\BattleMap.lua:76>
    (tail call): ?:
    <in C code>: ?
    <string>:"safecall Dispatcher[1]":9: in function <[string "safecall Dispatcher[1]"]:5>
    (tail call): ?:
    AceAddon-3.0-5 (Ace3):340: in function `InitializeAddon'
    AceAddon-3.0-5 (Ace3):428: in function <Interface\AddOns\Ace3\AceAddon-3.0\AceAddon-3.0.lua:421>


    [2008/11/02 11:45:35-3031-x1]: Mapster-1.0.5\BattleMap.lua:88: attempt to index global 'BattlefieldMinimapCorner' (a nil value)
    (tail call): ?:
    <in C code>: ?
    <string>:"safecall Dispatcher[1]":9: in function <[string "safecall Dispatcher[1]"]:5>
    (tail call): ?:
    AceAddon-3.0-5 (Ace3):365: in function `EnableAddon'
    AceAddon-3.0-5 (Ace3):377: in function `EnableAddon'
    AceAddon-3.0-5 (Ace3):435: in function <Interface\AddOns\Ace3\AceAddon-3.0\AceAddon-3.0.lua:421>
    <in C code>: in function `LoadAddOn'
    Interface\FrameXML\UIParent.lua:991: in function `UIParentLoadAddOn':
    Interface\FrameXML\UIParent.lua:241: in function `CombatLog_LoadUI':
    Interface\FrameXML\UIParent.lua:389: in function `UIParent_OnEvent':
    <string>:"*:OnEvent":1: in function <[string "*:OnEvent"]:1>
    Posted in: Map/Minimap AddOns
  • 0

    posted a message on FuBar_GuildFu
    I really do hate resurrecting dead posts like this, but is this addon being maintained anymore, because if so, I have been getting the following errors since patch 3.0. If anyone has an idea of how to fix this, please let me know.

    [2008/11/01 10:50:23-3014-x1]: AceLocale-2.2-91091 (Ace2):487: AceLocale(FuBar_GuildFu): Translation "70" does not exist.
    Fubar_GuildFu-2.4.1-@project-revision@\FuBar_GuildFuOptions.lua:305: in main chunk


    [2008/11/01 10:50:23-3014-x1]: AceLocale-2.2-91091 (Ace2):487: AceLocale(FuBar_GuildFu): Translation "Toggles display of level 70 chars" does not exist.
    Fubar_GuildFu-2.4.1-@project-revision@\FuBar_GuildFuOptions.lua:305: in main chunk


    [2008/11/01 10:50:23-3014-x1]: AceLocale-2.2-91091 (Ace2):487: AceLocale(FuBar_GuildFu): Translation "Zone Filter Settings" does not exist.
    Fubar_GuildFu-2.4.1-@project-revision@\FuBar_GuildFuOptions.lua:313: in main chunk


    [2008/11/01 10:50:23-3014-x1]: AceLocale-2.2-91091 (Ace2):487: AceLocale(FuBar_GuildFu): Translation "In Battleground" does not exist.
    Fubar_GuildFu-2.4.1-@project-revision@\FuBar_GuildFuOptions.lua:315: in main chunk


    [2008/11/01 10:50:23-3014-x1]: AceLocale-2.2-91091 (Ace2):487: AceLocale(FuBar_GuildFu): Translation "Toggles display of chars in battlegrounds" does not exist.
    Fubar_GuildFu-2.4.1-@project-revision@\FuBar_GuildFuOptions.lua:315: in main chunk


    [2008/11/01 10:50:23-3014-x1]: AceLocale-2.2-91091 (Ace2):487: AceLocale(FuBar_GuildFu): Translation "In Instance" does not exist.
    Fubar_GuildFu-2.4.1-@project-revision@\FuBar_GuildFuOptions.lua:321: in main chunk


    [2008/11/01 10:50:23-3014-x1]: AceLocale-2.2-91091 (Ace2):487: AceLocale(FuBar_GuildFu): Translation "Toggles display of chars in instances" does not exist.
    Fubar_GuildFu-2.4.1-@project-revision@\FuBar_GuildFuOptions.lua:321: in main chunk


    [2008/11/01 10:50:23-3014-x1]: AceLocale-2.2-91091 (Ace2):487: AceLocale(FuBar_GuildFu): Translation "In Open Field" does not exist.
    Fubar_GuildFu-2.4.1-@project-revision@\FuBar_GuildFuOptions.lua:327: in main chunk


    [2008/11/01 10:50:23-3014-x1]: AceLocale-2.2-91091 (Ace2):487: AceLocale(FuBar_GuildFu): Translation "In Open Field" does not exist.
    Fubar_GuildFu-2.4.1-@project-revision@\FuBar_GuildFuOptions.lua:327: in main chunk


    [2008/11/01 10:50:23-3014-x1]: Fubar_GuildFu-2.4.1-@project-revision@\FuBar_GuildFuOptions.lua:339: attempt to index global 'FuBar_GuildFu' (a nil value)
    Posted in: FuBar AddOns
  • 0

    posted a message on EavesDrop 2.0 (a SCT style combat log)
    Using r83 from the wowace svn repository, getting the following error message while hunter pet is out:

    [2008/10/25 00:16:07-2971-x100]: EavesDrop-2.1\EavesDrop.lua:590: bad argument #3 to 'string_format' (string expected, got nil)
    EavesDrop-2.1\EavesDrop.lua:590: in function `?'
    CallbackHandler-1.0\CallbackHandler-1.0.lua:146: in function <...ber\libs\CallbackHandler-1.0\CallbackHandler-1.0.lua:146>
    <string>:"safecall Dispatcher[14]":4: in function <[string "safecall Dispatcher[14]"]:4>
    <in C code>: ?
    <string>:"safecall Dispatcher[14]":13: in function `?'
    CallbackHandler-1.0\CallbackHandler-1.0.lua:91: in function `Fire'
    AceEvent-3.0\AceEvent-3.0.lua:70: in function <Interface\AddOns\Ace3\AceEvent-3.0\AceEvent-3.0.lua:69>
    Posted in: General AddOns
  • 0

    posted a message on DrDamage - Official Thread
    Stupid question, but is there a way to change a setting or modify a file to stop getting spammed with a "Dr. Damage: debuff ftw!" message every time the mob you are targeting gets any kind of debuff. This only became noticable once I started using the wrath clone repository version of the mod. Just wondering if anyone else is getting this.
    Posted in: General AddOns
  • 0

    posted a message on X-Perl Thread
    This is probably the error attached to the issue above regarding no options when right clicking raidframes.

    [2008/10/17 00:01:05-2922-x3]: Blizzard_RaidUI\Blizzard_RaidUI.lua:647: attempt to index local 'self' (a nil value)
    XPerl_RaidFrames\XPerl_Raid.lua:1537: in function `initFunction'
    Interface\FrameXML\UIDropDownMenu.lua:51: in function `UIDropDownMenu_Initialize':
    Interface\FrameXML\UIDropDownMenu.lua:719: in function `ToggleDropDownMenu':
    XPerl_RaidFrames\XPerl_Raid.lua:189: in function `func'
    Interface\FrameXML\SecureTemplates.lua:365: in function `SecureActionButton_OnClick':
    <string>:"*:OnClick":1: in function <[string "*:OnClick"]:1>
    Posted in: Unit Frames
  • 0

    posted a message on Talented, a Talent template editor !
    I am also getting the following errors in current build r304:

    [2008/10/16 15:32:23-2908-x1]: Talented-1.9\viewmode.lua:145: bad argument #2 to 'SetFormattedText' (string expected, got nil)
    Talented-1.9\viewmode.lua:145: in function `UpdateView'
    Talented-1.9\core.lua:129: in function `SetMode'
    Talented-1.9\core.lua:300: in function `SetTemplate'
    Talented-1.9\core.lua:348: in function `Update'
    Talented-1.9\core.lua:337: in function `ToggleTalentFrame'
    Talented_Loader\core.lua:10: in function `ToggleTalentFrame'
    <string>:"*:OnClick":1: in function <[string "*:OnClick"]:1>


    [2008/10/16 15:32:27-2908-x4]: Talented-1.9\viewmode.lua:145: bad argument #2 to 'SetFormattedText' (string expected, got nil)
    Talented-1.9\viewmode.lua:145: in function `UpdateView'
    Talented-1.9\core.lua:350: in function `Update'
    Talented-1.9\core.lua:337: in function <Interface\AddOns\Talented\core.lua:334>
    (tail call): ?:
    <string>:"*:OnClick":1: in function <[string "*:OnClick"]:1>
      ---


    EDIT: Commented out the offending line 145 and it seemed to fix the lua errors and allowed the frame to appear which it had not been doing before. Not sure yet if that will create more problems for myself then it is worth or not.
    Posted in: General AddOns
  • 0

    posted a message on X-Perl Thread
    Posted new ticket here on WowAce with applicable error logs regarding bugs in r181 being produced on live. Let me know if you need anything else from me regarding these errors.
    Posted in: Unit Frames
  • 0

    posted a message on BigWigs
    I looked back on posts back to June and did not see anything about this, but is there a development version in the works that will be patch 3.0.2/WotLK compatable? Just wondering since this patch is a week out, perhaps two.
    Posted in: Raid AddOns
  • 0

    posted a message on Bartender4 - Official Topic
    Unrelated question. What is the status of this mod in relation to the SVN server on WoWAce now? There is currently a git repository which is fairly unfriendly to use by Windows users. Any chance of getting an SVN link associated with the project page?
    Posted in: General AddOns
  • 0

    posted a message on HeadCount - Raid attendance and loot tracker
    Sorry to say, the initial attempt did not work for me, but I would consider myself the exception to things. Thanks for all the hard work.
    Posted in: Raid AddOns
  • 0

    posted a message on HeadCount - Raid attendance and loot tracker
    Incubator does not start timers, and CombatTimeFu while incombat, resets once hitting 1 second, and once out of combat, starts counting up as if I was in combat, and continues to do so until getting into combat again, and starts resetting after 1 second again.
    Posted in: Raid AddOns
  • To post a comment, please or register a new account.