• 0

    posted a message on WoW UI Updater (Win/OSX/Linux, supports multiple sites), 1.6 thread
    Quote from lejordet2
    Thanks! I've been looking into it a bit now (it's kinda hard with about 7000ms ping and 14kbps bandwidth) and for me it looks like the new download page requires Flash and/or Javascript, can anybody confirm? I only have Google Chrome and IE8 on this computer, so I'll try downloading Firefox+noscript too (which'll take an hour).


    It appears to be a JavaScript authentication system. The error/captcha page says you need Java but there appears to be no Java involved. Edit: Looks like it does fall back to a Java Applet if you are not logged in.

    It's sad that WoWMatrix has caused this to happen as these updaters have the potential to cut their bandwith in half if they would implement an efficient API for querying and downloading updates.
    Posted in: Updaters
  • 0

    posted a message on LibBars r80269 - mess with width, height and orientation
    Quote from Nevcairiel »

    Just use "tostring(yourid)" as bar names?


    I could, by why add the overhead?

    LibBars is a generic library, if you want specific functions like adding a unlimited amount of icons, i suggest to write your own bar implementation at some point, only features that are really useful to alot of people deserve to be in a library ;)


    It's a pretty generic method. Rather than hard-coding the current single icon it could be added or removed using such a method and has many uses.
    Posted in: Libraries
  • 0

    posted a message on LibBars r80269 - mess with width, height and orientation
    Sounds good. It would be nice to get an appendIcon method or similar that would allow adding as many icons as you want to either side of the bar rather than the default one icon.

    Also can someone plz apply the attached patch for me. It fixes numerical bar indexes and is kind of a show stopper for me ATM.

    Thanks

    Posted in: Libraries
  • 0

    posted a message on WotLK Error
    Whoops, didn't notice that Ace3 had a WotLK branch. I'll check it out, thanks.
    Posted in: Ace3
  • 0

    posted a message on WotLK Error
    Got into the WotLK beta and Ace3 seems to be okay except for the following error (from Bugsack) with tabs in AceGUI-3.0. Any ideas?

    "Interface\\FrameXML\\UIPanelTemplates.lua:32: attempt to index local 'tab' (a number value):
    ...ll\\libs\\AceGUI-3.0\\widgets\\AceGUIWidget-TabGroup.lua:58: in function `SetText':
    ...ll\\libs\\AceGUI-3.0\\widgets\\AceGUIWidget-TabGroup.lua:185: in function `BuildTabs':
    ...ll\\libs\\AceGUI-3.0\\widgets\\AceGUIWidget-TabGroup.lua:145: in function `SetTabs':
    AceConfigDialog-3.0\\AceConfigDialog-3.0.lua:1491: in function `FeedGroup'
    AceConfigDialog-3.0\\AceConfigDialog-3.0.lua:1688: in function `Open'
    AceConfigDialog-3.0\\AceConfigDialog-3.0.lua:1699: in function <...nfig-3.0\\AceConfigDialog-3.0\\AceConfigDialog-3.0.lua:1697>
    (tail call): ?:
    <in C code>: ?
    <string>:\"safecall Dispatcher[2]\":9: in function <[string \"safecall Dispatcher[2]\"]:5>
    (tail call): ?:
    AceGUI-3.0\\AceGUI-3.0.lua:257: in function `Fire'
    ...AceGUI-3.0\\widgets\\AceGUIWidget-BlizOptionsGroup.lua:67: in function <...AceGUI-3.0\\widgets\\AceGUIWidget-BlizOptionsGroup.lua:66>:
    <in C code>: in function `Show'
    Interface\\FrameXML"
    Posted in: Ace3
  • 0

    posted a message on LibBars r80269 - mess with width, height and orientation
    The vertical orientation is defiantly a real mess. I've been trying to use it in my mod. Your recent changes have helped a ton but it's still not quite there. If an API change is required then I'm all for it.

    There also seems to be a dirty recycling problem as well. If I load my addon and fire 10 bars with custom colors and wait until they are finished then fire 10 more using default colors some or all of the bars will be randomly colored based on my old colors.

    Also I'm using number rather than string based bar names and there is a bug in ReleaseBar() that causes it not to work. Should be
    if type(name) == "string" or type(name) == "number" then
    on line 204.
    Posted in: Libraries
  • 0

    posted a message on LibBars-1.0 r72899+
    IsAnchorVisible() is missing a return call on line 526
    Posted in: Libraries
  • 0

    posted a message on WoW UI Updater (Windows/Linux/Mac) - supports multiple sites
    Same error in 1.6.438
    Posted in: Updaters
  • 0

    posted a message on WoW UI Updater (Windows/Linux/Mac) - supports multiple sites
    humm, w v1.6.432 I get:
    ...
    2007-10-09 19:55:09 (INFO ) Loaded settings, 117 Addons found
    2007-10-09 19:55:09 (INFO ) Scanned Addon directory, 117 Addons found (0 new, 0 installed fresh, 0 missing, 47 ignored, 0 dummy, 0 deleted)
    2007-10-09 19:55:10 (ERROR ) WUU Error: -182477540
    Traceback (most recent call last):
    File "/home/eric/WUU-1.6.432-src.zip_FILES/WUU.py", line 3754, in <module>
    app = WurmApp()
    File "/usr/lib64/python2.5/site-packages/wx-2.8-gtk2-unicode/wx/_core.py", line 7757, in __init__
    self._BootstrapApp()
    File "/usr/lib64/python2.5/site-packages/wx-2.8-gtk2-unicode/wx/_core.py", line 7354, in _BootstrapApp
    return _core_.PyApp__BootstrapApp(*args, **kwargs)
    File "/home/eric/WUU-1.6.432-src.zip_FILES/WUU.py", line 3703, in OnInit
    self.wurmframe = WurmUI(None, -1, _('WoW UI Updater %(ver)s') % { 'ver': wuuversion })
    File "/home/eric/WUU-1.6.432-src.zip_FILES/WUU.py", line 445, in __init__
    self.CreateUI()
    File "/home/eric/WUU-1.6.432-src.zip_FILES/WUU.py", line 1062, in CreateUI
    self.OnLoad(None)
    File "/home/eric/WUU-1.6.432-src.zip_FILES/WUU.py", line 2116, in OnLoad
    self.OnScan(None)
    File "/home/eric/WUU-1.6.432-src.zip_FILES/WUU.py", line 2143, in OnScan
    self.RefreshAddonList(count = True)
    File "/home/eric/WUU-1.6.432-src.zip_FILES/WUU.py", line 1623, in RefreshAddonList
    self.SortListItems(0, True) # re-sort after load
    File "/usr/lib64/python2.5/site-packages/wx-2.8-gtk2-unicode/wx/lib/mixins/listctrl.py", line 79, in SortListItems
    self.GetListCtrl().SortItems(self.GetColumnSorter())
    File "/usr/lib64/python2.5/site-packages/wx-2.8-gtk2-unicode/wx/_controls.py", line 4821, in SortItems
    return _controls_.ListCtrl_SortItems(*args, **kwargs)
    File "/usr/lib64/python2.5/site-packages/wx-2.8-gtk2-unicode/wx/lib/mixins/listctrl.py", line 137, in __ColumnSorter
    item1 = self.itemDataMap[key1][col]
    KeyError: -182477540
    Posted in: Updaters
  • 0

    posted a message on WoW UI Updater (Windows/Linux/Mac) - supports multiple sites
    Just downloaded v1.6.427 and I get:
    ...
    2007-10-08 17:48:24 (INFO ) Loaded settings, 117 Addons found
    2007-10-08 17:48:24 (INFO ) Scanned Addon directory, 117 Addons found (0 new, 0 installed fresh, 0 missing, 47 ignored, 0 dummy, 0 deleted)
    2007-10-08 17:48:25 (ERROR ) WUU Error: WUU crashed on startup! Error details:
    -182477540
    Traceback (most recent call last):
    File "WUU.py", line 3746, in <module>
    app = WurmApp()
    File "/usr/lib64/python2.5/site-packages/wx-2.8-gtk2-unicode/wx/_core.py", line 7757, in __init__
    self._BootstrapApp()
    File "/usr/lib64/python2.5/site-packages/wx-2.8-gtk2-unicode/wx/_core.py", line 7354, in _BootstrapApp
    return _core_.PyApp__BootstrapApp(*args, **kwargs)
    File "WUU.py", line 3697, in OnInit
    raise Exception, "WUU crashed on startup! Error details:\n%s" % (str(details))
    Exception: WUU crashed on startup! Error details:
    -182477540

    I was using v1.5.418 and it was working great. This is on a Linux box.
    Posted in: Updaters
  • 0

    posted a message on Yata (not an official thread)
    Quote from Tornhoof »

    I added my cycircled code.

    Known bugs:
    - sometimes it simply switches layouts (not yet sure why)

    Please report unusual behaviour since I don't use cycircled.


    Couple bugs I've noticed with this:
    1) I'm currently level 28 and have my Fire, Earth and Water totems but it currently only skins my Earth and Water bar and leaves my Fire bar unskinned.

    2) On my non shaman classes when Yata auto disables its self, it breaks cyCircled. Seems more like a bug with cyCircled not checking for loaded but disabled plugins.
    Posted in: General AddOns
  • To post a comment, please or register a new account.