• 0

    posted a message on Prat: Chat Mod Framework
    Quote from Dssurge »

    variable timestamp formatting isn't working it seems, I want to display seconds on my combat log but when I change the format of chat frame 1 it affects all subsequent chat frames.


    It's a known bug.. Like I said in some post earlier, I haven't found a manner to figure in what ChatFrame the message is actually written...
    Posted in: General AddOns
  • 0

    posted a message on Prat: Chat Mod Framework
    Quote from Don »

    Uncertain if this has been said but when I checked group in Playernames it continues to show their numbers in /g etc even after I left the group :/


    It's a known bug, I think one of my last commit has corrected that, but it seems that the problem is still preset.

    Try to correct that this evening.
    Posted in: General AddOns
  • 0

    posted a message on Prat: Chat Mod Framework
    Quote from Harwel »

    Interesting thing with 14947... the "To" and "From" are reversed on whispers. For example, if I am Harwel, and I send Rysia a tell, Prat displays:


    [W From][Rysia]: zoh mah gahd whispers are reversed!!!1!


    If she sends me a tell back, Prat displays:


    [W To][Rysia]: Yes, they are!


    Not sure if this is new with this version; I've never used a prior version of Prat.


    Yes I know, but I were to lazy today to commit a fix :D

    You can easily change the channel replacement to match the correct information ^^

    Sorry for this typo.
    Posted in: General AddOns
  • 0

    posted a message on Prat: Chat Mod Framework
    Quote from Silencer »

    I want the left chat channel to have on left side buttonz and i want right channelz to have button on right side. And I don't see anywere options for that :(


    If you don't select the "move button" option, buttons are on their default position. So it's exactly what you want. Otherwise, you can delete the buttons modules to have the default behavior for the chat buttons. And finally, you can provide a patch if you want :D
    Posted in: General AddOns
  • 0

    posted a message on Prat: Chat Mod Framework
    @bwuser : Cool :D don't know what I've changed ^^

    @Silencer : yes, I've made an error for whisper, I'll changed that this afternoon. For the buttons, there's an option to move them to the right, don't use it if you want them on the left side ^^

    @Fraplamon : the zipping process isn't my job. I haven't access to the server, so I can't do anything for you.
    Posted in: General AddOns
  • 0

    posted a message on Prat: Chat Mod Framework
    The MoneyFu thing is corrected if you update externals I think, I have no erreor at all with the externals up to date.
    Posted in: General AddOns
  • 0

    posted a message on Prat: Chat Mod Framework
    Quote from bwuser »

    I just grabbed r14040 from /files and its the latest version that is saving settings, anything after that no longer keeps them.(I also replaced all my old files/variables). However, externals were needed to keep the settings.


    Do you play in english ? Have you this problem only with one char or with all of them ? Have you try on another computer ?

    I'll look what are the main difference between r14040 and the last one.
    Posted in: General AddOns
  • 0

    posted a message on Prat: Chat Mod Framework
    Prat\\Prat.lua:37: attempt to index global `self' (a nil value)\nPrat\\Prat.lua:37: in main chunk\n\n ---",


    Corrected.

    For the settings bug, like I've already said, it working perfectly for me, so I can't do any testing about it. I'm pretty sure that this is a problem with your AceProfile configuration or something like this. There's nothing I can do for you.
    Posted in: General AddOns
  • 0

    posted a message on Prat: Chat Mod Framework
    Thx for the feedback about Prat in standby, it's now fixed.

    The tenth channel replacement bug is fixed too.

    Prat ChannelNames now have option for says, whispers and yells :)

    Known bug : if you change the replacement for a channel or disable a replacement, you have to post / receive one message before it takes effect.

    NB : all your ChannelNames settings will be gone if you use the last revision, it's not a bug, sorry for the inconvenience.
    Posted in: General AddOns
  • 0

    posted a message on Prat: Chat Mod Framework
    Quote from Connall »

    Small request: I have a bit of a special layout where I want my editbox to appear about 50 pixels above the top of my chat frame. This isn't possible with Visor and I always need to alter the code that moves the editbox whenever I update.

    Any chance of having an option to specify where we want the editbox to end up?


    There's an undocked mod for the editbox.
    Posted in: General AddOns
  • 0

    posted a message on Prat: Chat Mod Framework
    Quote from Zeusjuice »

    Noticed that Channel 10 channel name wasn't being replaced. I hope this fixes it:
    function Prat_ChannelNames:AddMessage(frame, text, ...)
      if text then
        local pattern = "%]%s+(.*|Hplayer)"
        local channel = string.gsub(text, ".*%[(.+)" .. pattern ..".+", "%1")
        if string.find(channel, "%d+%. ") then
          channel = string.gsub(channel, "(%d+)%..+", "Channel%1")
          pattern = "%[%d+%..-" .. pattern



    I already applied that change one time on the code, but someone have deleted it :(

    I'll commit the fix after doing some more improvement on the code :D

    Thx.


    If you have problems with settings that don't save, please try to fulle update Prat (with externals). Prat is actually saving his settings, so if you have a problem, it is on your side (addon compatibility, bad update, etc).

    @Quantuvis : I have looked at Confab code, and since I don't want to hook that many function, I try to do it another way. But it seems that this is the only solution :( Maybee I'll fix that this evening if I have some times.
    Posted in: General AddOns
  • 0

    posted a message on Prat: Chat Mod Framework
    Quote from Quantuvis »

    I've done some more testing on ChannelSeparator, and I've come to the conclusion that it just doesn't work :) Helpful huh? :)

    Seriously though, I've tried it on clean WoW on two different PCs now, several characters, but only one account though. All of these symptoms are reproducable by me on clean WoW 1.12.1 and newest prat from /files.

    It simply doesn't save settings. Also, while selecting only Officers chat correctly filters out normal Guild spam, selecting Guild always allows Officer to get through too.

    Furthermore, there is no name for the Battleground submenu of the ChatFrame context menu - it's simply a blank space which leads to the submenu containing Battleground and Battleground leader.

    I've kinda spammed this topic with this problem, I'm fully aware of that - but I have yet to receive any acknowledgement or dismissal of what I'm experiencing.


    Since I'm not using this modules, I haven't tested it. It's merely dry coded. I haven't actually the time to debug it, but feel free to hack and commit a fix if you want. Sorry, but this is not on my priority list, I plan to fix others bugs and add others feature before correcting ChannelsSeparator.

    Perhaps I am overlooking it but is there an option to remove the scrolling buttons on the side of chat? Thanks.


    Yes, in the Button module.
    Posted in: General AddOns
  • 0

    posted a message on Prat: Chat Mod Framework
    Quote from bwuser »

    Fully delete your Prat and the Saved Variable, Start up WoW, change PRAT from default settings, log out. Check the Saved Variables to see the only thing it is saving is Player color and Class and nothing else. I rolled back my computer one week and saw the saved variable file kept fontsizes, et al. Log back into the game, Prat is back to default settings. What other mod would be causing a conflict to prevent PRAT from saving its own settings?


    Dunno what is the problem, but my setting are kept between sessions.

    I have one question and one suggestion.

    Question: How come the player names only change color in guild and party chat, but not in my main channels like LFG?

    Suggestion: Add an option to get rid of the editbox border. ^^;


    I haven't any problems with the coloring in other chans. Do you have tekNicolor or something like this ?

    I'll give a look for you suggestion
    Posted in: General AddOns
  • 0

    posted a message on Prat: Chat Mod Framework
    Quote from Verjigorm »

    2 more problems:

    wenn i link an item in tradechat, other players see always:
    [CLINK:fffff ....

    why isn't the lvl displayed everytime?

    rev 14502


    If you dont want the CLINK things, disable the chatlink modules.
    For the WinAceUptater problem, ask on the appropriate thread, nothing to do with prat ^^
    What do you mean with the lvl isn't displayed everytime ?

    @All : The error on line 288 of PlayerNames is corrected in the new revision.

    I personnaly don't have any settings reset on login, maybee à compatibility problem with some others addons.

    The random coloring of nickname is now added and the tab completion works a little bit better.

    @Aileen : Sorry for your timestamtps, but some majors modification where made to the code, so all timestamps settings are gone.

    About the chat buttons, there's a new option to move them in the chat frame. After changing this option, you must reload UI to take effect.

    [Reminder] The per ChatFrame settings of timestamps still not work. I haven't actually found a way to figure on what ChatFrame I'm actually sending the text. Still looking for a solution
    Posted in: General AddOns
  • 0

    posted a message on Prat: Chat Mod Framework
    Quote from Sariash »

    Could be that I have some chars in the friendlist that are deleted or moved the server ... but the error is only happening if I disable the level display - so the playernames modul should behave like in the version before without the leveldisplay (with raidgroup disabled too), shouldn't it?


    No, now I'm saving the level even if you don't want to show it, then if you change opinion, the level of people is already saved.

    Test the last revision please, I've added a nil test.
    Posted in: General AddOns
  • To post a comment, please or register a new account.