CurseForge and Overwolf are joining forces!
Awesome More Information
  • 0

    posted a message on Prat 3.0 Chat Mod Framework
    Quote from Alfrunnah »

    I get the following error when I load in:

    Interface/Addons/Prat-3.0/modules/EditBox.lua:412:Attempt to index global 'AceGUIWidgetLSMlists' (a nil value)

    Doesn't give me the option to move my editbox, even though I have it enabled in module control.


    If you just recently updated Ace3 or if you're using the embedded version they said in the last commit that some of AceGUI was now broken because some of Blizz's code is broken:

    ------------------------------------------------------------------------
    r81877 | nevcairiel | 2008-09-19 02:21:29 -0400 (Fri, 19 Sep 2008) | 2 lines
    Changed paths:
      M /trunk/Ace3/AceGUI-3.0/widgets/AceGUIWidget-TreeGroup.lua
    
    Ace3 - AceGUI-3.0: merge fix for the latest beta patch
    - NOTE: The Blizzard Integration into the Interface Options is still broken due to a number of bugs in the FrameXML Code in this build!
    Posted in: General AddOns
  • 0

    posted a message on Prat 3.0 Chat Mod Framework
    Problem with the new button module:



    You can see on the far right chat box the buttons do not line up with the chat box. Not a problem without the module, nor with regularly sized (or larger) chat frames.
    Posted in: General AddOns
  • 0

    posted a message on Prat 3.0 Chat Mod Framework
    Quote from sylvanaar »

    Well, this may be a live-only issue, ie. i have no issues on beta. Live is going to be brought up to 30000 "soon" - so it may just be broken until then. Make sure you have the chatlinks module enabled though...


    Will do sylvanaar. As I said, I haven't had a problem before, so I'm pretty sure the chat mod is enabled (looking at my saved variable file, it's default, and I think default is on, IIRC). I did see that the 3.0 patch is available for download, so it should be "soon" like you said. I'll just wait.

    Should we continue letting you know about bugs on Live or just wait until the 3.0 patch?
    Posted in: General AddOns
  • 0

    posted a message on Prat 3.0 Chat Mod Framework
    Had this bug on the 13th of September (on live). I believe I'm using version r81600 (at least that's the largest version on the change log files I have). The quest link for whatever reason in the general chat wasn't working. I've seen this work on other channels. Please see the attached picture (could have done the copy paste, but I'm writing this bug report after it happened) for the full example.
    Posted in: General AddOns
  • 0

    posted a message on Prat 3.0 Chat Mod Framework
    Quote from Dustine »

    Is it possible to remove the icons on the left? (Scroll/emote/scroll bottom etc.)

    Thanks.


    ATM, no, but it will be coming.
    Posted in: General AddOns
  • 0

    posted a message on ag_UnitFrames Status (What's going on?)
    Quote from frithy »

    Andreas, upon updating to the wotlk build, I've noticed my buffs/debuffs have disappeared on the player and target unitframes... any suggestions?


    He mentioned a little earlier that some of the buffing stuff if you're using WotLK branch on live didn't work.
    Posted in: Unit Frames
  • 0

    posted a message on ag_UnitFrames Status (What's going on?)
    Quote from andreasg »

    There's more to it than that though, I think it is in playerframe.lua or something:)


    Could be. I haven't looked at playerframe. UnitFrame and VehicleFrame looked like it had most of the information.

    Edit: You are correct Andreas, there is quite a bit of functionality in PlayerFrame, and an extra event that was not in the others. It looks like all that ag_UF needs to do is have a way of showing that you're in a vehicle, showing that vehicle's Unit frame, and having a way of kicking off the leaving of a vehicle. Sounds simple, doesn't it?
    Posted in: Unit Frames
  • 0

    posted a message on ag_UnitFrames Status (What's going on?)
    Quote from lightguard »

    Here's an except from Blizz's code (found at http://wowcompares.com/3028905/FrameXML/UnitFrame.lua):

    	local textureName = self.portrait:GetTexture();
    	if ( (not textureName) or (textureName == "Interface\\CharacterFrame\\TemporaryPortrait-Pet") or
    		(string.sub(textureName or "", 1, 51) == "Interface\\CharacterFrame\\TemporaryPortrait-Vehicle-") ) then
    		if ( self.portraitType == "Mechanical" ) then
    			self.portrait:SetTexture("Interface\\CharacterFrame\\TemporaryPortrait-Vehicle-Mechanical");
    		elseif ( self.portraitType == "Natural" ) then
    			self.portrait:SetTexture("Interface\\CharacterFrame\\TemporaryPortrait-Vehicle-Organic");
    		else
    			self.portrait:SetTexture("Interface\\CharacterFrame\\TemporaryPortrait-Pet");
    		end
    	end



    Hit post too early. There are a couple of events too: UNIT_ENTERED_VEHICLE, VEHICLE_PASSENGERS_CHANGED, UNIT_EXITED_VEHICLE that will be helpful. Also here are some bindings that may help:

    	<Binding name="VEHICLEEXIT" header="VEHICLE">
    		VehicleExit();
    	</Binding>
    	<Binding name="VEHICLEPREVSEAT">
    		VehiclePrevSeat();
    	</Binding>
    	<Binding name="VEHICLENEXTSEAT">
    		VehicleNextSeat();
    	</Binding>

    Posted in: Unit Frames
  • 0

    posted a message on ag_UnitFrames Status (What's going on?)
    Here's an except from Blizz's code (found at http://wowcompares.com/3028905/FrameXML/UnitFrame.lua):

    	local textureName = self.portrait:GetTexture();
    	if ( (not textureName) or (textureName == "Interface\\CharacterFrame\\TemporaryPortrait-Pet") or
    		(string.sub(textureName or "", 1, 51) == "Interface\\CharacterFrame\\TemporaryPortrait-Vehicle-") ) then
    		if ( self.portraitType == "Mechanical" ) then
    			self.portrait:SetTexture("Interface\\CharacterFrame\\TemporaryPortrait-Vehicle-Mechanical");
    		elseif ( self.portraitType == "Natural" ) then
    			self.portrait:SetTexture("Interface\\CharacterFrame\\TemporaryPortrait-Vehicle-Organic");
    		else
    			self.portrait:SetTexture("Interface\\CharacterFrame\\TemporaryPortrait-Pet");
    		end
    	end
    Posted in: Unit Frames
  • 0

    posted a message on ag_UnitFrames Status (What's going on?)
    How does ag_UF work with the new Vehicle Unit Frame concept Blizz created?
    Posted in: Unit Frames
  • 0

    posted a message on ag_UnitFrames Status (What's going on?)
    Quote from andreasg »

    That would be the layout file you would have to edit.


    Excellent! That's what I wanted to hear. What about the raid layouts?
    Posted in: Unit Frames
  • 0

    posted a message on ag_UnitFrames Status (What's going on?)
    Does ag_UF support the idea of swapping raid layout / grouping changing or swapping like sRaidFrames?
    Posted in: Unit Frames
  • 0

    posted a message on ag_UnitFrames Status (What's going on?)
    Another Aura question for you Andreas. Is it possible (WotLK version) to grow the auras vertically or would that take modifying the aura.lua file?
    Posted in: Unit Frames
  • 0

    posted a message on Prat 3.0 Chat Mod Framework
    Quote from Hallithron »

    I've been following this thread as well as the previous development thread, and haven't found this mentioned; is there a plan to include tab completion for player names in Prat-3.0?


    Yes, I mentioned it and sylvanaar replied about nine posts back.
    Posted in: General AddOns
  • 0

    posted a message on Prat 3.0 Chat Mod Framework
    I don't want to put words into sylvanaar's mouth, but this seems like it would be out of the scope of Prat (but I can see your point, because it's related to chat). I don't think it would be that difficult to create a different addon (or even a Prat module) to handle this though.
    Posted in: General AddOns
  • To post a comment, please or register a new account.