• 0

    posted a message on I made 4 small addons... need some advice
    Hello Tekkub.

    First of all, thank you for taking the time to beat my lousy addons up. I do however have some questions about your statements... You said I made a mess in the namespace which I can understand but my idea is to give users with next to none knowledge about programming a chance of changing the addon settings without an ingame config. Should I continue to use locals or should I write alot of comments in the code to make it easier for beginners?

    That Broker addon was just a test which I basicly put together in 30 minutes... do you think it can be released now when you corrected the mistakes?
    Posted in: Lua Code Discussion
  • 0

    posted a message on I made 4 small addons... need some advice
    Hello everyone!

    I've made 4 small addons which I would want some of you more experienced coders and programmers to criticize. I want all kind of feedback, be it bad or good. I'll give you a short description on each addon.

    The first 2 addons, FeignDeathResistWarner and HunterAutoShotTimer are only made for hunter's in mind. The name should explain what they do. I did use Quartz by Nymbia as a model for the HunterAutoShotTimer addon, but removed, added and changed several things.

    For my third addon I wanted to test the Ace3 framework a bit and it is called SimpleAutoRepair. Obviously it will automaticly repair when you talk with a NPC capable of repairing. It also contains basic options, if you want to use your own money or the gbank for example. The settings is saved.

    The fourth addon is a LibBroker addon called Broker_Happiness. This one is aswell only aimed for hunter's. It adds a block into LibBroker's storages printing out your pets happiness.

    Bear in mind these are the first addons I've made apart from the Hello_World examples. I hope you will atleast read the code of the hunter only addons if you don't have one. I am looking forward of hearing your criticism.

    Gurkan46
    Posted in: Lua Code Discussion
  • 0

    posted a message on BadBoy: An extremely minimal spam blocker & reporter
    Hello,
    the website that wasn't blocked were already included in the blacklist so I didn't bother to include in the original post (it was long enough). It was "<>" (not exactly written like that though). I thought it didn't get blocked because it was spammed in trade channel. Will such support be included in later releases or has it already? Forgive me for not checking the earlier posts in the thread about that question.

    If some other advertisments get through the addon I'll try to remember to grab a screenshot of the message and post it here for you.
    Posted in: General AddOns
  • 0

    posted a message on BadBoy: An extremely minimal spam blocker & reporter
    I think I've found a bug, let me describe it for you.

    A bot, let's call him X, whispers me, the whisper gets automatic blocked by the addon and the complaint gets registered. I get this message in the chat window, "Complaint Registered. (X)".
    All fine.

    However, 2 minutes later another Bot, (Y), spams the trade channel and does not get blocked by the addon, so I choose to report him manually, the problem is the message I get in the chat window this time is not "Complaint Registered. (Y)", but "Complaint Registered. (X)" again. Notice it keep saying I've reported (X) instead of the other bot, (Y). I've no idea if it's just a visual bug, or a real bug causing you to keep reporting the same one.

    I did wait till a third bot, (Z) started to spam trade chat, but the result was the same. The message still says I've reported (X).

    After waiting another 10 minutes, a new whisper gets blocked, this time by a new bot (K), and the addon blocks it. The message in the window is fine, it says "Complaint Registered. (K)". After this I scrolled up and tried to manually report (Z) again, but yet again, it says I've reported (K).

    So the problem seems to be whenever the addon automatic blocks a whisper, you can't manually report someone in trade channel. It will keep saying the bot who whispered you gets reported.

    I used r71624 when I tested it, the newest one. I do use other addons such as Chatter, perhaps it's a conflict? I don't know.
    Posted in: General AddOns
  • 0

    posted a message on GatherMate: Offical Thread
    Could you add an option to only load Burning Crusade herbs when importing from GatherMate_Data? I'm only interested in those (I guess I'm not the only one) and I see the old herbs only as increased memory consumption and longer loading times.
    Posted in: General AddOns
  • 0

    posted a message on AckisRecipeList - Official Thread
    Enchant Bracer - Greater Intellect
    requires skill 255, I just checked in-game.
    Posted in: General AddOns
  • 0

    posted a message on Recount
    Yes, write "/recount realtime raid dps".
    Posted in: General AddOns
  • 0

    posted a message on Quartz embedded latency desplay
    They haven't released any info yet. It's probably just some tweaking from Blizzard's side anyway.
    Posted in: General Chat
  • 0

    posted a message on ArkInventory v2.00
    Quote from Wonderfool »

    How can i make a System category (Equipment not soulbound) take precedence over a custom rule?


    You can't. You can however create an rule named "Non soulbound eq" with the code

    equip() and not soulbound()


    which would do the same thing as that category.
    Posted in: General AddOns
  • 0

    posted a message on WowAceUpdater - An update tool for Windows users.
    Perhaps it's time for a new thread... in the first post you can clearly state which versions which are supported and other infos, for example, who are the developers, where to send in bug reports etc.

    Anyway... I had a problem this morning, with build 586... or rather 600. You see I updated to build 600 yesterday but this morning it has been reverted back to 586 which refuses to work properly, it don't want to download any addon's nor update to the correct version again. I'm using Vista ulti x64 with most security settings turned off so I doubt that's causing the issues.
    Posted in: Updaters
  • 0

    posted a message on ArkInventory v2.00
    Quote from Gurkan46 »

    Can you add an 'apply' button in the rule edit frame? It's kind of annoying if you're trying to fix an complex rule if you have to press 'ok' to see if it worked, and if it didn't you have to select the rule again and press edit.
    Posted in: General AddOns
  • 0

    posted a message on ArkInventory v2.00
    While looking on offline character's bag/bank, several items is missing their icons.
    Posted in: General AddOns
  • 0

    posted a message on PeriodicTable-3.0
    I would be happy if someone could add the following items under their respective criteria.

    • Arakkoa Feather (25719) - Reputation.Turnin.Lower City
    • Dreadfang Venom Sac (25802) - Reputation.Turnin.The Aldor
    • Dampscale Basilisk Eye (25744) - Reputation.Turnin.The Scryers
    • Bolt of Netherweave (21840) - Tradeskill.Mat.ByType.Bolt
    • Bolt of Soulcloth (21844) - Tradeskill.Mat.ByType.Bolt
    Posted in: Libraries
  • 0

    posted a message on CowTip - a tooltip addon - Official Topic
    Yep, it's skinner related. I had the same problem and disabled skinner, afterwards CowTip worked great.
    Posted in: General AddOns
  • 0

    posted a message on ArkInventory v2.00
    Can you add an 'apply' button in the rule edit frame? It's kind of annoying if you're trying to fix an complex rule if you have to press 'ok' to see if it worked, and if it didn't you have to select the rule again and press edit.
    Posted in: General AddOns
  • To post a comment, please or register a new account.