• 0

    posted a message on Skinner

     I receive the following error with beta7.27843.1:

    16x Skinner\Modules\UIButtons.lua:404: attempt to call method 'GetNormalTexture' (a nil value)
    Skinner\Modules\UIButtons.lua:404: in function `skinStdButton'
    Skinner\PlayerFrames.lua:2825: in function <Skinner\PlayerFrames.lua:2817>
    (tail call): ?
    [C]: ?
    [C]: in function `Show'
    FrameXML\LootFrame.lua:412: in function `GroupLootContainer_AddFrame'
    FrameXML\LootFrame.lua:626: in function <FrameXML\LootFrame.lua:579>
    [C]: ?
    [C]: in function `BonusRollFrame_StartBonusRoll'
    FrameXML\UIParent.lua:1564: in function <FrameXML\UIParent.lua:1090>
    [C]: ?

    Locals:
    InCombatSkipped
    Posted in: General AddOns
  • 0

    posted a message on Skinner

    I still have a few errors with the newest version:

     

    Error #1

    1x Skinner\AddonSkins\PetTracker-8.0.2.lua:86: attempt to index field 'PetTrackerTamerJournal' (a nil value)
    (tail call): ?
    [C]: in function `xpcall'
    Skinner\UtilFuncs.lua:109: in function <Skinner\UtilFuncs.lua:100>
    (tail call): ?
    Skinner\AddonFrames.lua:121: in function `AddonFrames'
    Skinner\Skinner-beta7.27219.1.lua:354: in function <Skinner\Skinner.lua:354>

    Error #2

    1x Skinner\Modules\UIButtons.lua:391: attempt to call method 'GetNormalTexture' (a nil value)
    Skinner\AddonSkins\Wholly-067.lua:8: in function <Skinner\AddonSkins\Wholly.lua:5>
    (tail call): ?
    [C]: in function `xpcall'
    Skinner\UtilFuncs.lua:109: in function <Skinner\UtilFuncs.lua:100>
    (tail call): ?
    Skinner\AddonFrames.lua:121: in function `AddonFrames'
    Skinner\Skinner-beta7.27219.1.lua:354: in function <Skinner\Skinner.lua:354>

    Error #3

    1x Skinner\UIFrames.lua:243: attempt to index field 'DurabilityBackground' (a nil value)
    Skinner\UIFrames.lua:243: in function <Skinner\UIFrames.lua:224>
    Skinner\UIFrames.lua:1965: in function <Skinner\UIFrames.lua:1964>
    (tail call): ?
    [C]: in function `Show'
    ...risonTemplates\Blizzard_GarrisonMissionTemplates.lua:830: in function `OnClickViewCompletedMissionsButton'
    ...risonTemplates\Blizzard_GarrisonMissionTemplates.lua:2343: in function <...risonTemplates\Blizzard_GarrisonMissionTemplates.lua:2338>
    [C]: in function `Click'
    [string "*:OnKeyDown"]:3: in function <[string "*:OnKeyDown"]:1>
    Posted in: General AddOns
  • 0

    posted a message on Client v5 not seeing any updates at all

    That'd be my guess.

    Posted in: WoW Sites Feedback
  • 0

    posted a message on PackageMeta improvents

    AFAIK, you can still update the project description using a .docmeta file.

     

    Contents:

    -
      type: markdown
      input-file: README.md
      output-page: "Main"
    Posted in: WoW Sites Feedback
  • 0

    posted a message on Skinner

    Receiving the following error with beta7.25021.2:

    4x Skinner\Skinner-beta7.25021.2.lua:615: attempt to index field 'obj' (a nil value)
    (tail call): ?
    Skinner\AddonSkins\ServerHop-7.3.0.1.lua:8: in function <Skinner\AddonSkins\ServerHop.lua:5>
    (tail call): ?
    [C]: in function `xpcall'
    Skinner\UtilFuncs.lua:105: in function <Skinner\UtilFuncs.lua:98>
    (tail call): ?
    Skinner\AddonFrames.lua:123: in function `AddonFrames'
    Skinner\Skinner-beta7.25021.2.lua:370: in function <Skinner\Skinner.lua:370>
    
    Locals:
    nil
    Posted in: General AddOns
  • 0

    posted a message on Skinner

    Beta7.25021.2 isn't available for download.

     

    Edit:

    It is now. Thank you.

    Posted in: General AddOns
  • 0

    posted a message on Skinner

    Receiving the following error with beta7.25021.1:

    1884x Skinner\UIFrames.lua:824: attempt to index upvalue 'bmDB' (a nil value)
    Skinner\UIFrames.lua:835: in function <Skinner\UIFrames.lua:786>
    (tail call): ?
    [C]: in function `xpcall'
    Skinner\UtilFuncs.lua:105: in function <Skinner\UtilFuncs.lua:98>
    (tail call): ?
    Skinner\AddonFrames.lua:108: in function <Skinner\AddonFrames.lua:99>
    Skinner\AddonFrames.lua:185: in function `LoDFrames'
    Skinner\AddonFrames.lua:221: in function <Skinner\AddonFrames.lua:221>
    
    Locals:
    nil
    Posted in: General AddOns
  • 0

    posted a message on user-generated content needs a captcha for new users
    this is because i have started to see random spam lately on curse sites (including here on forums)...so probably a captcha might help.

    Started!? Ha! No, it has been bad for quite a while now.

    Posted in: WoW Sites Feedback
  • 0

    posted a message on Skinner

    I'm receiving two errors with b7.22996.2.

    Error #1:

    Skinner\UIFrames.lua:28: Usage: HookScript(object, method, [handler]): 'object' - nil or table expected got string
    Ace3\AceHook-3.0\AceHook-3.0-8.lua:130: in function <Ace3\AceHook-3.0\AceHook-3.0.lua:118>
    Ace3\AceHook-3.0\AceHook-3.0-8.lua:367: in function 'HookScript'
    Skinner\UIFrames.lua:28: in function <Skinner\UIFrames.lua:18>
    Skinner\UtilFuncs.lua:209: in function 'add2Table'
    Skinner\SkinMe\Wholly-060.lua:36: in function <Skinner\SkinMe\Wholly.lua:4>
    (tail call): ?
    [C]: in function 'xpcall'
    Skinner\UtilFuncs.lua:190: in function <Skinner\UtilFuncs.lua:181>
    (tail call): ?
    Skinner\AddonFrames.lua:120: in function '?'
    Ace3\AceTimer-3.0\AceTimer-3.0-17.lua:53: in function <Ace3\AceTimer-3.0\AceTimer-3.0.lua:48>
    
    Locals:
    nil

    Error #2:

    1x Skinner\UIFrames.lua:2465: attempt to index field 'Toast' (a nil value)
    Skinner\UIFrames.lua:2465: in function <Skinner\UIFrames.lua:2464>
    [C]: in function 'Play'
    FrameXML\QuickJoinToast.lua:257: in function 'ShowToast'
    FrameXML\QuickJoinToast.lua:169: in function 'CheckDisplayToast'
    FrameXML\QuickJoinToast.lua:160: in function 'CheckShowToast'
    FrameXML\QuickJoinToast.lua:153: in function <FrameXML\QuickJoinToast.lua:151>
    SharedXML\C_TimerAugment.lua:16: in function <SharedXML\C_TimerAugment.lua:14>
    
    Locals:
    this =  {
     0 = 
    }
    (*temporary) = nil
    (*temporary) = nil
    (*temporary) = "attempt to index field 'Toast' (a nil value)"
    Posted in: General AddOns
  • 0

    posted a message on Projects updated on curse.com but not registering on curse app

    I've also noticed that some addons won't show an update after clicking Refresh, but if I close the app and reopen it, updates will then show up.

    Posted in: WoW Sites Feedback
  • 0

    posted a message on Skinner

    I'm receiving two errors with b7.22908.2.

    Error #1:

    3x Skinner\UIFrames.lua:23: Usage: HookScript(object, method, [handler]): 'object' - nil or table expected got string
    Ace3\AceHook-3.0\AceHook-3.0-8.lua:130: in function <Ace3\AceHook-3.0\AceHook-3.0.lua:118>
    Ace3\AceHook-3.0\AceHook-3.0-8.lua:367: in function 'HookScript'
    Skinner\UIFrames.lua:23: in function <Skinner\UIFrames.lua:14>
    Skinner\UtilFuncs.lua:198: in function 'add2Table'
    Skinner\SkinMe\Wholly-060.lua:36: in function <Skinner\SkinMe\Wholly.lua:4>
    (tail call): ?
    [C]: in function 'xpcall'
    Skinner\UtilFuncs.lua:181: in function <Skinner\UtilFuncs.lua:175>
    (tail call): ?
    Skinner\AddonFrames.lua:294: in function '?'
    Ace3\AceTimer-3.0\AceTimer-3.0-17.lua:53: in function <Ace3\AceTimer-3.0\AceTimer-3.0.lua:48>
    
    Locals:
    nil

    Error #2:

    1x Skinner\Skinner-b7.22908.2.lua:1245: attempt to index local 'obj' (a nil value)
    Skinner\Skinner-b7.22908.2.lua:1245: in function 'removeRegions'
    Skinner\UIFrames.lua:141: in function <Skinner\UIFrames.lua:139>
    Skinner\UIFrames.lua:215: in function <Skinner\UIFrames.lua:213>
    (tail call): ?
    [C]: in function 'setUpFunction'
    FrameXML\AlertFrames.lua:131: in function 'ShowAlert'
    FrameXML\AlertFrames.lua:68: in function 'AddAlert'
    FrameXML\AlertFrames.lua:312: in function <FrameXML\AlertFrames.lua:276>
    
    Locals:
    
    Posted in: General AddOns
  • 0

    posted a message on Skinner

    You're running b7.22566.1 which contains the aforementioned errors. b7.22566.2 hasn't been released as of yet.

    Posted in: General AddOns
  • 0

    posted a message on Skinner

    You forgot to push the tag to your repository.

    Posted in: General AddOns
  • 0

    posted a message on Skinner

     Unfortunately, I'm receiving three errors with b7.22566.1.

    Error #1

    1x Skinner\AddonFrames.lua:17: '}' expected (to close '{' at line 7) near '"ArenaUI"'
    
    
    Locals:
    

    Error #2

    1x Skinner\Options-Options.lua:1802: bad argument #1 to 'pairs' (table expected, got nil)
    Skinner\Options-Options.lua:1802: in function <Skinner\Options.lua:191>
    (tail call): ?
    [C]: in function `xpcall'
    Skinner\UtilFuncs.lua:180: in function <Skinner\UtilFuncs.lua:174>
    (tail call): ?
    Skinner\Skinner-b7.22566.1.lua:87: in function <Skinner\Skinner.lua:59>
    (tail call): ?
    [C]: ?
    [string "safecall Dispatcher[1]"]:9: in function <[string "safecall Dispatcher[1]"]:5>
    (tail call): ?
    Ace3\AceAddon-3.0\AceAddon-3.0-12.lua:529: in function `InitializeAddon'
    Ace3\AceAddon-3.0\AceAddon-3.0-12.lua:644: in function <Ace3\AceAddon-3.0\AceAddon-3.0.lua:636>
    
    Locals:
    nil

    Error #3

    1x Skinner\Skinner-b7.22566.1.lua:301: Usage: RegisterEvent("eventname", "methodname"): 'methodname' - method 'AUCTION_HOUSE_SHOW' not found on self.
    [C]: ?
    ...Ons\Ace3\CallbackHandler-1.0\CallbackHandler-1.0-6.lua:138: in function `RegisterEvent'
    Skinner\Skinner-b7.22566.1.lua:301: in function <Skinner\Skinner.lua:265>
    (tail call): ?
    [C]: ?
    [string "safecall Dispatcher[1]"]:9: in function <[string "safecall Dispatcher[1]"]:5>
    (tail call): ?
    Ace3\AceAddon-3.0\AceAddon-3.0-12.lua:558: in function `EnableAddon'
    Ace3\AceAddon-3.0\AceAddon-3.0-12.lua:651: in function <Ace3\AceAddon-3.0\AceAddon-3.0.lua:636>
    [C]: ?
    [C]: in function `LoadAddOn'
    FrameXML\UIParent.lua:391: in function `UIParentLoadAddOn'
    FrameXML\UIParent.lua:414: in function `CombatLog_LoadUI'
    FrameXML\UIParent.lua:995: in function <FrameXML\UIParent.lua:891>
    [C]: ?
    
    Locals:
    nil
    Posted in: General AddOns
  • 0

    posted a message on WYSIWYG editor is bad, bad, bad
    Quote from Seerah >>

    This is my first post on these new forums. The WYSIWYG editor seems to be functioning fine on Chrome.

     

    What I absolutely hate, however, is the blinding white.  I'm surprised Phanx did not mention this, too, as I think I remember this bothers her eyes as well.

    I'm not seeing a lot of the problems Phanx has commented on in Chrome either. Perhaps they haven't done as much testing with Firefox?
    I despise the white background as well, but I've modified the CSS with Stylish. However, more sane default options are coming, eventually:
    Quote from Kaelten >>

    I've spoken with the dev team, and we will have light and dark versions of the themes in the future. I'll speak to timelines once I know for sure. :)`````

    Posted in: WoW Sites Feedback
  • To post a comment, please or register a new account.