• 0

    posted a message on AddOn 'Ace3' tried to call the protected function 'MultiBarLeft:originalHide()

    I was afraid of that. I have a couple of suspects...

     

    Thanks for reply.

    Posted in: Ace3
  • 0

    posted a message on AddOn 'Ace3' tried to call the protected function 'MultiBarLeft:originalHide()

    I dont know if this is a common error, but it seems I'm not the only one getting it. If this is really caused by and can be fixed by Ace3 I'm not certain of. I could not find any issues on wowace about this, so it may not be as big a problem as it is an annoyance...

     

    7x [ADDON_ACTION_BLOCKED] AddOn 'Ace3' tried to call the protected function 'MultiBarLeft:originalHide()'.
    !BugGrabber\BugGrabber.lua:573: in function <!BugGrabber\BugGrabber.lua:573>
    [C]: in function `originalHide'
    FrameXML\FrameLocks.lua:96: in function <FrameXML\FrameLocks.lua:72>
    FrameXML\FrameLocks.lua:107: in function <FrameXML\FrameLocks.lua:100>
    FrameXML\FrameLocks.lua:125: in function `Hide'
    FrameXML\MultiActionBars.lua:63: in function `MultiActionBar_Update'
    FrameXML\ActionBarController.lua:174: in function `ValidateActionBarTransition'
    FrameXML\ActionBarController.lua:142: in function `ActionBarController_UpdateAll'
    FrameXML\ActionBarController.lua:64: in function <FrameXML\ActionBarController.lua:53>

    Posted in: Ace3
  • 0

    posted a message on Set chat-setting via Lua/Addon?

    Can you set,"Experience" in chat via a command in lua? I cant find anything about that... The menu that comes up when you rightclick a chat tab and choose settings/other... I wanne turn it on without having to think about it and remembering it on all my chars on both accounts... :P

    Posted in: Lua Code Discussion
  • 0

    posted a message on Cant get Secure Button to work

    I figured it out. I moved the 'buttoncheck' from the SetScript checking for buttons to an OnUpdate script (if script is the correct 'term'?) and it worked just like intended. Been messing on and off with this a few times, so very happy to finally get it to work.

     

    Thanks for the tips guys, and Blazeflack was kinda right, hehe =)

    Posted in: Lua Code Discussion
  • 0

    posted a message on Mining Addons

    Gatherer from gathereraddon.com

    Posted in: AddOn HELP!
  • 0

    posted a message on Cant get Secure Button to work

    I've been struggeling with this issue when playing around with some unitframes and trying to add the functionality with clicking the unitframe to target myself. It just will not work.

    It doesnt taint either, it just seems to do nothing when going trough the SetAttribute. If I add a print after the two SetAttribute, it does indeed print, but it does not target me, nor does it give an error.
    I can not get it to work when trying the macrotext method either.

     

    local uframe = CreateFrame("Button", "uframe", UIParent,"SecureUnitButtonTemplate")

    RegisterUnitWatch(uframe)


    uframe:SetAttribute("*type1", "target")

    uframe:SetAttribute("unit", "player")

    Posted in: Lua Code Discussion
  • 0

    posted a message on NPCScan

    Sure thing, _NPCScan.Overlay settings:

    Posted in: General AddOns
  • 0

    posted a message on NPCScan

    Well, I dont think you're supposed to keep the old _npc scan folder, only the new one without the underscore in the name. Try to move/delete the old folder with the _ in the name out of your addonfolder, and just keep the NPCScanner folder.

    At some point there was a change in the foldername, so maybe that is whats causing problems. Worth a try?

     

    _npcScan.Overlay is another extra addon that works with NPCScan, but its a seperate download.

    Posted in: General AddOns
  • 0

    posted a message on NPCScan
    Quote from fitsou >>

     Out of the blue, in the minimap I see a Yellow Circle. I cannot find an option to turn it off.

     Probably in _npcScan.Overlay settings, the 100 yard ring =)
    Posted in: General AddOns
  • 0

    posted a message on Prat 3.6.20 problem

    It does make sense when you say it; I have had a couple of other addons give me trouble lately aswell, so it may very well be a problem bigger than just Prat.

     

    Have anyone checked out the new version 3.6.23 that came out a couple of hours ago?

     

    EDIT: Prat-3.0-3.6.23 seem to work fine here, no errors after login atleast =)

    Posted in: AddOn HELP!
  • 0

    posted a message on Prat 3.6.20 problem

    Same here, 10 errors in anything 3.6.20 or higher. 3.6.19 works fine for me aswell =)

    Posted in: AddOn HELP!
  • 0

    posted a message on Determin race vs expansion

    Yeah, I just wondered while I was fiddling with something =) Its not a problem to check it 'manually', just curious. Thanks for reply.

    Posted in: Lua Code Discussion
  • 0

    posted a message on Determin race vs expansion

    Just thinking about something, and couldnt find any answers while looking in the api nor google :P

     

    Is it possible to determine if a player is playing a race thats not from vanilla, and if so, what expansion the race is from?

    Posted in: Lua Code Discussion
  • 0

    posted a message on kgPanels Offical Thread
    Thats what I did, but making a few scripts that anchor in each other so I can move one and then they all moves, broke that option =)
    Posted in: General AddOns
  • 0

    posted a message on kgPanels Offical Thread
    I wanne anchor an addon in a kgpanels panel... I could anchor it to 'kgpanel36' but that can be troublesome since it can change that name when recycleing frames.
    Any way to set the addon 'XPBar' to parent to my kgPanel 'XP'? The other addon have the poss. to choose what to anchor it to. (Broker xpbar or close is the addons name)...
    Any help?
    Posted in: General AddOns
  • To post a comment, please or register a new account.