• 0

    posted a message on Skinner

    Hi Jncl,

     

    Getting this error message for Server Hop:

     

    1x Skinner\Skinner-b7.22624.1.lua:599: attempt to index field 'obj' (a nil value)
    (tail call): ?
    Skinner\SkinMe\ServerHop-4.0.6.lua:86: in function <Skinner\SkinMe\ServerHop.lua:5>
    (tail call): ?
    [C]: in function `xpcall'
    Skinner\UtilFuncs.lua:181: in function <Skinner\UtilFuncs.lua:175>
    (tail call): ?
    Skinner\AddonFrames.lua:285: in function `?'
    ...faceArchy\Libs\AceTimer-3.0\AceTimer-3.0-17.lua:53: in function <...faceArchy\Libs\AceTimer-3.0\AceTimer-3.0.lua:48>

    Locals:
    nil

    Posted in: General AddOns
  • 0

    posted a message on Skinner

    Hey Jncl,

     

    thanks for keeping the addon updated in Legion.

    With the last update, I am getting the same errors as Talyrius has stated, plus this one:

     

    1x Skinner\Modules\UIButtons.lua:618: attempt to index field 'ACR' (a nil value)
    Skinner\Modules\UIButtons.lua:618: in function <Skinner\Modules\UIButtons.lua:597>
    (tail call): ?
    [C]: ?
    [string "safecall Dispatcher[1]"]:9: in function <[string "safecall Dispatcher[1]"]:5>
    (tail call): ?
    ...aceMasque\Libs\AceAddon-3.0\AceAddon-3.0-12.lua:558: in function `EnableAddon'
    ...aceMasque\Libs\AceAddon-3.0\AceAddon-3.0-12.lua:571: in function `EnableAddon'
    ...aceMasque\Libs\AceAddon-3.0\AceAddon-3.0-12.lua:651: in function <...aceMasque\Libs\AceAddon-3.0\AceAddon-3.0.lua:636>
    [C]: in function `LoadAddOn'
    PitBull4\Main.lua:1180: in function `LoadModules'
    PitBull4\Main.lua:1312: in function `OnProfileChanged'
    PitBull4\Main.lua:1382: in function <PitBull4\Main.lua:1352>
    ...
    (tail call): ?
    [C]: ?
    [string "safecall Dispatcher[1]"]:9: in function <[string "safecall Dispatcher[1]"]:5>
    (tail call): ?
    ...aceMasque\Libs\AceAddon-3.0\AceAddon-3.0-12.lua:558: in function `EnableAddon'
    ...aceMasque\Libs\AceAddon-3.0\AceAddon-3.0-12.lua:651: in function <...aceMasque\Libs\AceAddon-3.0\AceAddon-3.0.lua:636>
    [C]: in function `LoadAddOn'
    FrameXML\UIParent.lua:391: in function `UIParentLoadAddOn'
    FrameXML\UIParent.lua:414: in function `CombatLog_LoadUI'
    FrameXML\UIParent.lua:995: in function <FrameXML\UIParent.lua:891>

    Locals:
    nil

     

    Posted in: General AddOns
  • 0

    posted a message on Skinner
    Quote from Jncl
    Hi NeoZeus,
    Are you sure you're using the latest Mapster skin? The line referenced in the error message you posted doesn't match a line in the current Mapster skin.


    You are correct. My mistake.
    Here is an error message for Master Plan:

    6x Skinner\SkinMe\MasterPlan-0.101.lua:148: Usage: SecureHook([object], method, [handler]): Attempting to hook a non existing target
    ...eBartender4\libs\AceHook-3.0\AceHook-3.0-8.lua:211: in function <...eBartender4\libs\AceHook-3.0\AceHook-3.0.lua:118>
    ...eBartender4\libs\AceHook-3.0\AceHook-3.0-8.lua:341: in function `SecureHook'
    Skinner\SkinMe\MasterPlan-0.101.lua:148: in function <Skinner\SkinMe\MasterPlan.lua:5>
    (tail call): ?
    [C]: in function `xpcall'
    Skinner\UtilFuncs.lua:180: in function <Skinner\UtilFuncs.lua:174>
    (tail call): ?
    Skinner\AddonFrames.lua:366: in function `?'
    ...y\Externals\curse\svn\Ace3-AceTimer\AceTimer-3.0-17.lua:53: in function <...y\Externals\curse\svn\Ace3-AceTimer\AceTimer-3.0.lua:48>

    Locals:
    nil
    Posted in: General AddOns
  • 0

    posted a message on Skinner
    Hi Jncl,

    Thanks for your continued work on this awesome addon.
    Don't know if you have time with all the bugs before legion, but here is a log for the Mapster skin:

    36x Skinner\SkinMe\Mapster-1.7.2.lua:10: Usage: SecureHook([object], method, [handler]): Attempting to hook a non existing target
    ...eBartender4\libs\AceHook-3.0\AceHook-3.0-8.lua:211: in function <...eBartender4\libs\AceHook-3.0\AceHook-3.0.lua:118>
    ...eBartender4\libs\AceHook-3.0\AceHook-3.0-8.lua:341: in function `SecureHook'
    Skinner\SkinMe\Mapster-1.7.2.lua:10: in function <Skinner\SkinMe\Mapster.lua:5>
    (tail call): ?
    [C]: in function `xpcall'
    Skinner\UtilFuncs.lua:180: in function <Skinner\UtilFuncs.lua:174>
    (tail call): ?
    Skinner\AddonFrames.lua:283: in function `?'
    ...y\Externals\curse\svn\Ace3-AceTimer\AceTimer-3.0-17.lua:53: in function <...y\Externals\curse\svn\Ace3-AceTimer\AceTimer-3.0.lua:48>

    Locals:
    nil
    Posted in: General AddOns
  • 0

    posted a message on Skinner
    Quote from Jncl
    Hi,
    Skinned ServerHop (as requested by NeoZeus)

    b6.21742.2

    @Gershuun, I have checked this again and not seeing this behaviour with just Skinner loaded



    Awesome work as always Jncl. Thank you!
    Posted in: General AddOns
  • 0

    posted a message on Skinner
    Hi Jncl,

    was wondering if you have time could you skin Server Hop?

    Thanks in advance!
    Posted in: General AddOns
  • 0

    posted a message on Skinner
    Hi Jncl,

    getting an error since Rematch updated:

    17x Skinner\Skinner-b6.21355.1.lua:1981: attempt to index field 'obj' (a nil value)
    Skinner\Skinner-b6.21355.1.lua:2005: in function `skinUsingBD'
    Skinner\SkinMe\Rematch-4.4.1.lua:300: in function <Skinner\SkinMe\Rematch.lua:5>
    (tail call): ?
    [C]: in function `xpcall'
    Skinner\UtilFuncs.lua:180: in function <Skinner\UtilFuncs.lua:174>
    Skinner\UtilFuncs.lua:295: in function `checkAndRunAddOn'
    Skinner\AddonFrames.lua:289: in function `?'
    ...y\Externals\curse\svn\Ace3-AceTimer\AceTimer-3.0-17.lua:53: in function <...y\Externals\curse\svn\Ace3-AceTimer\AceTimer-3.0.lua:48>

    Locals:
    nil
    Posted in: General AddOns
  • 0

    posted a message on Skinner
    Hey Jncl,

    getting the following error for Rematch:

    2x Skinner\SkinMe\Rematch-4.1.9.lua:45: attempt to index field 'NarrowModeButton' (a nil value)
    (tail call): ?
    [C]: in function `xpcall'
    Skinner\UtilFuncs.lua:180: in function <Skinner\UtilFuncs.lua:174>
    Skinner\UtilFuncs.lua:295: in function `checkAndRunAddOn'
    Skinner\AddonFrames.lua:288: in function `?'
    ...s\AckisRecipeList\libs\AceTimer-3.0\AceTimer-3.0-17.lua:53: in function <...s\AckisRecipeList\libs\AceTimer-3.0\AceTimer-3.0.lua:48>

    Locals:
    nil
    Posted in: General AddOns
  • 0

    posted a message on Skinner
    Hi Jncl,

    I downloaded your update, but the garrison skin is not skinning:

    20x Skinner\UIFrames.lua:1129: Usage: SecureHook([object], method, [handler]): Attempting to hook a non existing target
    ...eBartender4\libs\AceHook-3.0\AceHook-3.0-8.lua:211: in function <...eBartender4\libs\AceHook-3.0\AceHook-3.0.lua:118>
    ...eBartender4\libs\AceHook-3.0\AceHook-3.0-8.lua:341: in function `SecureHook'
    Skinner\UIFrames.lua:1129: in function `skinGarrisonLandingPage'
    Skinner\UIFrames.lua:1373: in function <Skinner\UIFrames.lua:939>
    (tail call): ?
    [C]: in function `xpcall'
    Skinner\UtilFuncs.lua:150: in function <Skinner\UtilFuncs.lua:144>
    (tail call): ?
    Skinner\AddonFrames.lua:317: in function `func'
    ...s\AckisRecipeList\libs\AceTimer-3.0\AceTimer-3.0-17.lua:55: in function <...s\AckisRecipeList\libs\AceTimer-3.0\AceTimer-3.0.lua:48>

    Locals:
    nil
    Posted in: General AddOns
  • 0

    posted a message on Skinner
    Can confirm what Decabah said.
    Posted in: General AddOns
  • 0

    posted a message on Skinner
    Hey Jncl,

    The Master Plan skin is out of date. Could you please update it?

    Thank you in advance!
    Posted in: General AddOns
  • 0

    posted a message on Skinner
    While we're at out of date skins. A new skin is needed for Reforge Lite and Fishing Buddy.

    Thanks in advance, Jncl!
    Posted in: General AddOns
  • 0

    posted a message on Skinner
    Hi Jncl,

    I was wondering if have the time, could you please skin the addon Ludwig?
    Thanks in advance!
    Posted in: General AddOns
  • 0

    posted a message on Skinner
    Hi Jncl,

    getting the following errors on log in:

    37x Skinner-b5.17399.1\SkinMe\_NPCScan-5.4.1.3.lua:6: attempt to call method "SetTextColor" (a nil value)
    (tail call): ?
    <in C code>
    Skinner-b5.17399.1\UtilFuncs.lua:120: in function <Skinner\UtilFuncs.lua:114>
    Skinner-b5.17399.1\UtilFuncs.lua:219: in function "checkAndRunAddOn"
    Skinner-b5.17399.1\AddonFrames.lua:280: in function "?"
    AckisRecipeList-2.5.7\libs\AceTimer-3.0\AceTimer-3.0-16.lua:41: in function <AckisRecipeList\libs\AceTimer-3.0\AceTimer-3.0.lua:36>

    Locals:
    nil

    2x Skinner\Skinner-b5.17399.1.lua:1191: attempt to index local "obj" (a nil value)
    Skinner-b5.17399.1\SkinMe\oQueue-1.6.1.lua:79: in function <Skinner\SkinMe\oQueue.lua:6>
    (tail call): ?
    <in C code>
    Skinner-b5.17399.1\UtilFuncs.lua:120: in function <Skinner\UtilFuncs.lua:114>
    Skinner-b5.17399.1\UtilFuncs.lua:219: in function "checkAndRunAddOn"
    Skinner-b5.17399.1\AddonFrames.lua:280: in function "?"
    AckisRecipeList-2.5.7\libs\AceTimer-3.0\AceTimer-3.0-16.lua:41: in function <AckisRecipeList\libs\AceTimer-3.0\AceTimer-3.0.lua:36>

    Locals:
    nil
    Posted in: General AddOns
  • 0

    posted a message on Skinner
    Quote from holymick
    Hi,

    I am currently running Skinner beta b5.17539.1 (have also tried rolling back to previous 5.3 version) and am finding that im having an issue with tidy plates (have used every current release beta, alpha and release) or tidy plate : threat plates (have used every current release beta, alpha and release) where the health plate sits way to high about the mob, even when changing the Y offset in threat plates to the lowest setting -60 I find I have to be zoomed very far back to see the name /health plate. I did the old turn every add on off till i found the add on affecting it and have been searching currently known issue with both addons. I am not very smart when it comes to addon, but was curious for some sort of fix or help as I am a MT in a raid guild and is causing me some issues.

    Thanks for all your hard work, I really love your addon


    Hey holymick,

    This has nothing to do with Skinner. Turn on "compatibility mode" in Tidy Plates settings, then reload your ui to fix this issue.
    Posted in: General AddOns
  • To post a comment, please or register a new account.