I would still expand the health bars more and use a bigger font for the health number. [...] but the healing number needs to be as big as possible. There is no reason why '-9999' cannot be 80% of the width the the health bar and all of it's height.
... I nevertheless think, that healthbars and text are big enough. (Yep also beeing a healer ;) )
Well opinions can spread like water in the ocean, so I think the best compromise (if not TO much expenditure to implement) would be to have an option to set healthbar height (and adjusting text size) or implementing 2 "modes" BIG and as in screenshot ...
I think this will make many people who are reluctant to switch to oRA reconsider. They can have the lean backend of oRA and the same frontend raid frames of CTRA that they've grown accustomed to in the last year of raiding.
I'd like you to be a little more specific with the "nice optimizations" which will make the frames "even faster" than PR and other mods. I'm not saying my code is perfect, but this community thrives specifically on code sharing and peer review. I can personally speak to the PerfectRaid code and say that given the fact that its beta code, know that there's minimal gain to be made over what already exists (nothing perceivable)
There are a few things that can be optimized on perfectRaid (scanning debuffs for instance), that said, the code for my frames and pRaid are somewhat of the same concept, some places I use the exact same methods you do, having perfectRaid to look at greatly accelerated my coding process. The current frames took me only a few days to make, and so far I am really happy with the result.
I'm hoping to put it in to SVN (give access?), as I'd like others to help look through the code (and maybe add a few tweaks/improvements)
I can see a lot of people have tons of feature request, however as Kyahx said, my goal was really to replace the current CTRA frames and keep the code as optimized as possible. I really dont want to add special features at the cost of overall performance.
Btw, still need a name. Currently I have it named oRA_RaidFrames, but I don't want to give off the impression that these frames are suppose to be part of the oRA package, since they don't use anything from oRA, they simply complement it.