I have also been getting this error for a week or two and have no clue which addon is causing it. I run about 50 addons and I'm not about to run though all of them to find it.
If it helps, I run WinXP, use WAU to update my addons, and no clue if they are external or embedded libraries (so probably embedded). And I have no idea what that code posted above is supposed to do or how in the world I'd enter it.
Basically I'm a regular user who just wants to find out what's broken.
Just did a search for any Glory-2.0 folders on my computer and came up with just one - Prat. So that's apparently where the problem is. I am using the latest version from WAU. It is version 69384.
I opened up my Prat folder, not really knowing what to look for. I found the Glory 2.0 Lib folder there and opened the .lua file, but not really sure what I'm looking for. I did find the line:
if not AceLibrary:HasInstance("LibBabble-Zone-3.0") then error(MAJOR_VERSION .. " requires LibBabble-Zone-3.0") end
Looking at the library files in prat, I see it has the Babble-Zone-2.2 folder in it - is that causing the problem???