Elkano, what do you suggest we rename the current plugins written for LibDataBroker? I moved them to trunk because Nev suggested that I moved stuff there when things were usable. However I do agree with you that we need another naming scheme, "Broker_" isn't very good.
Currently all LDB things are added to Fortress and enabled by default. Then, if the user wants to only have them shown in Tekkub's launchy thing, they can disable them in the Fortress options. I think that is the best way to do it.
Maybe the plugin should provide the format as well as the text. I'm not sure the "label" is the solution that would work best everywhere. i bet Tekkub or Nevcariel got an idea of what's the best thing to do, they're usually pretty good at seeing the big picture. :P
Hmm yeah, unless the same stuff is done in all other displays labels like "XP" or "DPS" won't show up when using Funkeh's plugins. On the other hand labels won't be colored in StatBlocks if using other broker plugins.
Of course this is something we need to talk about, why do you say we can't? :P